mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Martin J. Bligh" <mbligh@aracnet.com>
To: Davide Libenzi <davidel@xmailserver.org>
Cc: Con Kolivas <kernel@kolivas.org>,
	Nick Piggin <piggin@cyberone.com.au>,
	Andrew Morton <akpm@osdl.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Ingo Molnar <mingo@elte.hu>
Subject: Re: [PATCH] Fix find busiest queue 2.6.0-test9
Date: Sun, 09 Nov 2003 12:39:16 -0800	[thread overview]
Message-ID: <126890000.1068410355@[10.10.2.4]> (raw)
In-Reply-To: <Pine.LNX.4.44.0311090921090.12198-100000@bigblue.dev.mdolabs.com>

>> +/* 
>> + * macro to make the code more readable - this_rq->prev_cpu_load[i]
>> + * is our local cached value of i's prev cpu_load. However, putting
>> + * this_rq->prev_cpu_load into the code makes it read like it's the
>> + * prev_cpu_load of this_cpu, which makes it confusing to read
>> + */
>> +#define prev_cpu_load_cache(cpu) (this_rq->prev_cpu_load[cpu])
> 
> Ouch, the implicit "this_rq" is really evil ;) Eventually:

Yeah, I know, but ...
 
># define prev_cpu_load_cache(rq, cpu) (rq->prev_cpu_load[cpu])

I think the implicit version is clearer to read. Oh well, maybe a good
balance between readability and sheer evil ;-)

M.


      reply	other threads:[~2003-11-09 20:39 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-11-08 16:49 Con Kolivas
2003-11-08 22:41 ` Nick Piggin
2003-11-08 22:58 ` Andrew Morton
2003-11-08 23:42   ` Nick Piggin
2003-11-09  0:44     ` Davide Libenzi
2003-11-09 15:34       ` Martin J. Bligh
2003-11-09 15:53         ` Davide Libenzi
2003-11-09 15:58           ` Martin J. Bligh
2003-11-09 16:05             ` Davide Libenzi
2003-11-09 16:07               ` Con Kolivas
2003-11-09 17:10                 ` Martin J. Bligh
2003-11-10  0:59                   ` Nick Piggin
2003-11-10  7:46               ` Ingo Molnar
2003-11-09 15:59           ` Con Kolivas
2003-11-09 16:48             ` Martin J. Bligh
2003-11-09 17:27               ` Davide Libenzi
2003-11-09 20:39                 ` Martin J. Bligh [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='126890000.1068410355@[10.10.2.4]' \
    --to=mbligh@aracnet.com \
    --cc=akpm@osdl.org \
    --cc=davidel@xmailserver.org \
    --cc=kernel@kolivas.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=piggin@cyberone.com.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®