mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 3/3] Staging: comedi: fix warning: line over 80 characters issue in usbduxfast.c
       [not found] <[PATCH]Staging: comedi: fix warning line over 80 character issues in usbduxfast.c>
@ 2011-07-06  8:26 ` Ravishankar
  2011-07-06  8:43   ` Dan Carpenter
  0 siblings, 1 reply; 2+ messages in thread
From: Ravishankar @ 2011-07-06  8:26 UTC (permalink / raw)
  To: gregkh, wfp5p; +Cc: devel, linux-kernel, Ravishankar, Ravishankar

From: Ravishankar <ravi.shankar@greenturtles.in>

This is a patch to the usbduxfast.c file that fixes up a warning found by the checkpatch.pl tool

Signed-off-by: Ravishankar <ravishankarkm32@gmail.com>
---
 drivers/staging/comedi/drivers/usbduxfast.c |   25 +++++++++++++++----------
 1 files changed, 15 insertions(+), 10 deletions(-)

diff --git a/drivers/staging/comedi/drivers/usbduxfast.c b/drivers/staging/comedi/drivers/usbduxfast.c
index 2a8e725..de2e34c 100644
--- a/drivers/staging/comedi/drivers/usbduxfast.c
+++ b/drivers/staging/comedi/drivers/usbduxfast.c
@@ -453,7 +453,8 @@ static int usbduxfastsub_start(struct usbduxfastsub_s *udfs)
 	/* 7f92 to zero */
 	local_transfer_buffer[0] = 0;
 	/* bRequest, "Firmware" */
-	ret = usb_control_msg(udfs->usbdev, usb_sndctrlpipe(udfs->usbdev, 0), USBDUXFASTSUB_FIRMWARE,
+	ret = usb_control_msg(udfs->usbdev, usb_sndctrlpipe(udfs->usbdev, 0),
+				USBDUXFASTSUB_FIRMWARE,
 				VENDOR_DIR_OUT,	/* bmRequestType */
 				USBDUXFASTSUB_CPUCS,	/* Value */
 				0x0000,	/* Index */
@@ -477,7 +478,8 @@ static int usbduxfastsub_stop(struct usbduxfastsub_s *udfs)
 	/* 7f92 to one */
 	local_transfer_buffer[0] = 1;
 	/* bRequest, "Firmware" */
-	ret = usb_control_msg(udfs->usbdev, usb_sndctrlpipe(udfs->usbdev, 0), USBDUXFASTSUB_FIRMWARE,
+	ret = usb_control_msg(udfs->usbdev, usb_sndctrlpipe(udfs->usbdev, 0),
+			      USBDUXFASTSUB_FIRMWARE,
 			      VENDOR_DIR_OUT,	/* bmRequestType */
 			      USBDUXFASTSUB_CPUCS,	/* Value */
 			      0x0000,	/* Index */
@@ -504,7 +506,8 @@ static int usbduxfastsub_upload(struct usbduxfastsub_s *udfs,
 	       startAddr, local_transfer_buffer[0]);
 #endif
 	/* brequest, firmware */
-	ret = usb_control_msg(udfs->usbdev, usb_sndctrlpipe(udfs->usbdev, 0), USBDUXFASTSUB_FIRMWARE,
+	ret = usb_control_msg(udfs->usbdev, usb_sndctrlpipe(udfs->usbdev, 0),
+				USBDUXFASTSUB_FIRMWARE,
 				VENDOR_DIR_OUT,	/* bmRequestType */
 				startAddr,	/* value */
 				0x0000,	/* index */
@@ -1571,13 +1574,15 @@ static int usbduxfastsub_probe(struct usb_interface *uinterf,
 	usbduxfastsub[index].probed = 1;
 	up(&start_stop_sem);
 
-	ret = request_firmware_nowait(THIS_MODULE,
-				      FW_ACTION_HOTPLUG,
-				      "usbduxfast_firmware.bin",
-				      &udev->dev,
-				      GFP_KERNEL,
-				      usbduxfastsub + index,
-				      usbduxfast_firmware_request_complete_handler);
+	ret =
+	request_firmware_nowait(THIS_MODULE,
+				FW_ACTION_HOTPLUG,
+				"usbduxfast_firmware.bin",
+				&udev->dev,
+				GFP_KERNEL,
+				usbduxfastsub + index,
+				usbduxfast_firmware_request_complete_handler);
+
 
 	if (ret) {
 		dev_err(&udev->dev, "could not load firmware (err=%d)\n", ret);
-- 
1.7.1.1


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH 3/3] Staging: comedi: fix warning: line over 80 characters issue in usbduxfast.c
  2011-07-06  8:26 ` [PATCH 3/3] Staging: comedi: fix warning: line over 80 characters issue in usbduxfast.c Ravishankar
@ 2011-07-06  8:43   ` Dan Carpenter
  0 siblings, 0 replies; 2+ messages in thread
From: Dan Carpenter @ 2011-07-06  8:43 UTC (permalink / raw)
  To: Ravishankar; +Cc: gregkh, wfp5p, devel, linux-kernel, Ravishankar

On Wed, Jul 06, 2011 at 01:56:50PM +0530, Ravishankar wrote:
> -	ret = request_firmware_nowait(THIS_MODULE,
> -				      FW_ACTION_HOTPLUG,
> -				      "usbduxfast_firmware.bin",
> -				      &udev->dev,
> -				      GFP_KERNEL,
> -				      usbduxfastsub + index,
> -				      usbduxfast_firmware_request_complete_handler);
> +	ret =
> +	request_firmware_nowait(THIS_MODULE,
> +				FW_ACTION_HOTPLUG,
> +				"usbduxfast_firmware.bin",
> +				&udev->dev,
> +				GFP_KERNEL,
> +				usbduxfastsub + index,
> +				usbduxfast_firmware_request_complete_handler);
> +

No.  Don't do this.  The "usbduxfast_firmware_request_complete_handler"
variable name is too long.  Rename it something shorter.

regards,
dan carpenter


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2011-07-06  8:44 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <[PATCH]Staging: comedi: fix warning line over 80 character issues in usbduxfast.c>
2011-07-06  8:26 ` [PATCH 3/3] Staging: comedi: fix warning: line over 80 characters issue in usbduxfast.c Ravishankar
2011-07-06  8:43   ` Dan Carpenter

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®