From: Joe Perches <joe@perches.com>
To: Jan Kara <jack@suse.cz>
Cc: NamJae Jeon <linkinjeon@gmail.com>, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 5/6] udf: Neaten logging output, use vsprintf extension %pV
Date: Mon, 10 Oct 2011 08:20:51 -0700 [thread overview]
Message-ID: <1318260051.25811.12.camel@Joe-Laptop> (raw)
In-Reply-To: <20111010150444.GD3944@quack.suse.cz>
On Mon, 2011-10-10 at 17:04 +0200, Jan Kara wrote:
> On Mon 10-10-11 01:08:06, Joe Perches wrote:
> > Remove the warning and error prefixes that duplicate KERN_<level>.
> Please keep that in the prefix. It's easier to read messages when they
> are that way ...
I think duplicating kernel standard functionality
is not good and this merely increases logging buffer
size.
It's your code, you're the maintainer, fix it up
as you choose.
next prev parent reply other threads:[~2011-10-10 15:20 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-10-03 13:53 [PATCH 1/2 v3] udf : enable error print in udf_read_tagged() Namjae Jeon
2011-10-05 22:08 ` Jan Kara
2011-10-05 22:19 ` Joe Perches
2011-10-06 21:41 ` Jan Kara
2011-10-09 3:16 ` NamJae Jeon
2011-10-09 3:29 ` Joe Perches
2011-10-09 4:44 ` NamJae Jeon
2011-10-09 4:56 ` Joe Perches
2011-10-09 6:25 ` NamJae Jeon
2011-10-09 14:07 ` NamJae Jeon
2011-10-10 8:08 ` [PATCH 0/6] udf: Change some KERN_<level>s and logging neatening Joe Perches
2011-10-10 8:08 ` [PATCH 1/6] udf: Promote some debugging messages to udf_error Joe Perches
2011-10-10 10:06 ` NamJae Jeon
2011-10-10 17:32 ` Jan Kara
2011-10-10 8:08 ` [PATCH 2/6] udf: Rename udf_error to udf_err Joe Perches
2011-10-10 10:18 ` NamJae Jeon
2011-10-10 8:08 ` [PATCH 3/6] udf: Rename udf_warn to udf_warn Joe Perches
2011-10-10 10:18 ` NamJae Jeon
2011-10-10 18:25 ` Paul Bolle
2011-10-10 18:27 ` Joe Perches
2011-10-10 8:08 ` [PATCH 4/6] udf: Convert printks to pr_<level> Joe Perches
2011-10-10 10:21 ` NamJae Jeon
2011-10-10 14:59 ` Jan Kara
2011-10-10 15:20 ` Joe Perches
2011-10-10 15:23 ` Joe Perches
2011-10-10 16:41 ` Jan Kara
2011-10-10 17:25 ` Joe Perches
2011-10-10 17:40 ` Jan Kara
2011-10-10 8:08 ` [PATCH 5/6] udf: Neaten logging output, use vsprintf extension %pV Joe Perches
2011-10-10 10:22 ` NamJae Jeon
2011-10-10 15:04 ` Jan Kara
2011-10-10 15:20 ` Joe Perches [this message]
2011-10-10 8:08 ` [PATCH 6/6] udf: Neaten udf_debug uses Joe Perches
2011-10-10 10:23 ` NamJae Jeon
2011-10-10 10:24 ` [PATCH 0/6] udf: Change some KERN_<level>s and logging neatening NamJae Jeon
2011-10-10 17:47 ` Jan Kara
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1318260051.25811.12.camel@Joe-Laptop \
--to=joe@perches.com \
--cc=jack@suse.cz \
--cc=linkinjeon@gmail.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®