From: Kamal Mostafa <kamal@canonical.com>
To: Henrik Rydberg <rydberg@euromail.se>,
Dmitry Torokhov <dmitry.torokhov@gmail.com>,
Dudley Du <dudl@cypress.com>
Cc: linux-input@vger.kernel.org, linux-kernel@vger.kernel.org,
David Solda <dso@cypress.com>, Troy Abercrombia <ta@cypress.com>,
Kyle Fazzari <git@status.e4ward.com>,
Mario Limonciello <mario_limonciello@dell.com>,
Tim Gardner <tim.gardner@canonical.com>,
Herton Krzesinski <herton.krzesinski@canonical.com>
Subject: Re: [PATCH v3 2/4] input: Cypress PS/2 Trackpad psmouse driver
Date: Tue, 04 Dec 2012 18:22:49 -0800 [thread overview]
Message-ID: <1354674169.11174.87.camel@fourier> (raw)
In-Reply-To: <20121203074520.GA2687@polaris.bitmath.org>
Hi Henrik-
Thanks again for your review. The forthcoming PATCH v4 includes the
majority of your change requests, except where noted below (and
considering my email "Subject: SEMI_MT vs. simulated mt")...
On Mon, 2012-12-03 at 08:45 +0100, Henrik Rydberg wrote:
> > + /*
> > + * send extension command 0xE8 or 0xF3,
> > + * if send extension command failed,
> > + * try to send recovery command to make
> > + * trackpad device return to ready wait command state.
> > + * It alwasy success based on this recovery commands.
>
> -EPARSE
I don't understand the meaning of that comment either. Perhaps the
original author Dudley Du can explain it.
> > +static int cypress_read_vital_statistics(struct psmouse *psmouse)
>
> Why do you call this statistics?
Perhaps "cypress_read_tp_metrics" would be a better name. Any thoughts
on this, Dudley?
> > +/*
> > + * reset trackpad device to standard relative mode.
> > + * This is also the defalut mode when trackpad powered on.
> > + */
> > +static void cypress_reset(struct psmouse *psmouse)
> > +{
> > + struct cytp_data *cytp = psmouse->private;
> > +
> > + psmouse_reset(psmouse);
> > +
> > + CYTP_SET_MODE_BIT(CYTP_BIT_STANDARD_REL);
> > + CYTP_SET_PACKET_SIZE(3);
> > +
> > + cytp->prev_contact_cnt = 0;
> > +}
>
> I suppose it is, but is it necessary to reset to default mode?
I left this unchanged, as I think you and Dmitry agreed.
> > +
> > +static int cypress_set_input_params(struct input_dev *input,
> > + struct cytp_data *cytp)
> > +{
> > + int ret;
> > +
> > + if (cytp->mode & CYTP_BIT_ABS_MASK) {
>
> It seems the device will always operate in this mode, so please simplify.
I #ifdef'd out the unused relative-mode code, as opposed to deleting it.
Will that be acceptable?
> > + /* Remove HSCROLL bit */
> > + if (report_data->contact_cnt == 4)
> > + header_byte &= ~(ABS_HSCROLL_BIT);
>
> Why conditionally?
Dudley, can you answer this? I left this (and all the scroll code)
unchanged.
> > +#if 0
> > + /* FIXME: cypress_reconnect() never works...
> > + * just let psmouse re-init() us for now.
> > + */
> > + psmouse->reconnect = cypress_reconnect;
> > +#endif
>
> This needs to be removed or fixed, of course.
Per Dudley, this does work in his disconnect/reconnect scenario, so I
re-enabled it. We will continue to investigate why it fails
(harmlessly) in my suspend/resume scenario.
> > + int tp_max_abs_x; /* Max X absolution units can be reported. */
> > + int tp_max_abs_y; /* Max Y absolution units can be reported. */
>
> I do not think we are seeking absolution here. :-)
Ha! Speak for yourself, Henrik! ;-) I'm starting to feel like maybe I
should be seeking absolution here!
-Kamal
next prev parent reply other threads:[~2012-12-05 2:22 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-11-29 21:57 [PATCH v3 0/4] Cypress PS/2 Trackpad driver Kamal Mostafa
2012-11-29 21:57 ` [PATCH v3 1/4] input: increase struct ps2dev cmdbuf[] to 8 bytes Kamal Mostafa
2012-11-29 21:57 ` [PATCH v3 2/4] input: Cypress PS/2 Trackpad psmouse driver Kamal Mostafa
2012-12-03 3:20 ` Dudley Du
2012-12-03 5:57 ` Dudley Du
2012-12-03 6:31 ` Henrik Rydberg
2012-12-03 6:31 ` Dudley Du
2012-12-03 7:45 ` Henrik Rydberg
2012-12-03 17:04 ` Dmitry Torokhov
2012-12-05 2:22 ` Kamal Mostafa [this message]
2012-12-05 6:24 ` Dudley Du
2012-11-29 21:58 ` [PATCH v3 3/4] input: Cypress PS/2 Trackpad link into psmouse-base Kamal Mostafa
2012-11-29 21:58 ` [PATCH v3 4/4] input: Cypress PS/2 Trackpad simulated multitouch Kamal Mostafa
2012-12-03 1:58 ` Dudley Du
2012-12-03 7:36 ` [PATCH v3 0/4] Cypress PS/2 Trackpad driver Dmitry Torokhov
2012-12-05 2:22 ` SEMI_MT vs. simulated mt (was Re: [PATCH v3 0/4] Cypress PS/2 Trackpad driver) Kamal Mostafa
2012-12-03 7:50 ` [PATCH v3 0/4] Cypress PS/2 Trackpad driver Henrik Rydberg
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1354674169.11174.87.camel@fourier \
--to=kamal@canonical.com \
--cc=dmitry.torokhov@gmail.com \
--cc=dso@cypress.com \
--cc=dudl@cypress.com \
--cc=git@status.e4ward.com \
--cc=herton.krzesinski@canonical.com \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mario_limonciello@dell.com \
--cc=rydberg@euromail.se \
--cc=ta@cypress.com \
--cc=tim.gardner@canonical.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome