mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: navin patidar <navin.patidar@gmail.com>
To: gregkh@linuxfoundation.org
Cc: Larry.Finger@lwfinger.net, devel@driverdev.osuosl.org,
	linux-kernel@vger.kernel.org,
	navin patidar <navin.patidar@gmail.com>
Subject: [PATCH 09/41] staging:rtl8188eu:assign hal_EfusePgPacketWrite_8188e() to ->Efuse_PgPacketWrite
Date: Fri, 20 Jun 2014 20:29:15 +0530	[thread overview]
Message-ID: <1403276387-11841-10-git-send-email-navin.patidar@gmail.com> (raw)
In-Reply-To: <1403276387-11841-1-git-send-email-navin.patidar@gmail.com>

assign hal_EfusePgPacketWrite_8188e() to ->Efuse_PgPacketWrite directly
instead of going through many functions.

Signed-off-by: navin patidar <navin.patidar@gmail.com>
---
 drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c |   29 +--------------------
 drivers/staging/rtl8188eu/include/hal_intf.h      |    2 +-
 2 files changed, 2 insertions(+), 29 deletions(-)

diff --git a/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c b/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
index c5bbb08..7c53ea2 100644
--- a/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
+++ b/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
@@ -1567,33 +1567,6 @@ static bool hal_EfusePgPacketWrite_8188e(struct adapter *pAdapter, u8 offset, u8
 	return true;
 }
 
-static int Hal_EfusePgPacketWrite_Pseudo(struct adapter *pAdapter, u8 offset, u8 word_en, u8 *data, bool bPseudoTest)
-{
-	int ret;
-
-	ret = hal_EfusePgPacketWrite_8188e(pAdapter, offset, word_en, data, bPseudoTest);
-	return ret;
-}
-
-static int Hal_EfusePgPacketWrite(struct adapter *pAdapter, u8 offset, u8 word_en, u8 *data, bool bPseudoTest)
-{
-	int	ret = 0;
-	ret = hal_EfusePgPacketWrite_8188e(pAdapter, offset, word_en, data, bPseudoTest);
-
-	return ret;
-}
-
-static int rtl8188e_Efuse_PgPacketWrite(struct adapter *pAdapter, u8 offset, u8 word_en, u8 *data, bool bPseudoTest)
-{
-	int	ret;
-
-	if (bPseudoTest)
-		ret = Hal_EfusePgPacketWrite_Pseudo (pAdapter, offset, word_en, data, bPseudoTest);
-	else
-		ret = Hal_EfusePgPacketWrite(pAdapter, offset, word_en, data, bPseudoTest);
-	return ret;
-}
-
 static struct HAL_VERSION ReadChipVersion8188E(struct adapter *padapter)
 {
 	u32				value32;
@@ -1722,7 +1695,7 @@ void rtl8188e_set_hal_ops(struct hal_ops *pHalFunc)
 	pHalFunc->EFUSEGetEfuseDefinition = &rtl8188e_EFUSE_GetEfuseDefinition;
 	pHalFunc->EfuseGetCurrentSize = &hal_EfuseGetCurrentSize_8188e;
 	pHalFunc->Efuse_PgPacketRead = &hal_EfusePgPacketRead_8188e;
-	pHalFunc->Efuse_PgPacketWrite = &rtl8188e_Efuse_PgPacketWrite;
+	pHalFunc->Efuse_PgPacketWrite = &hal_EfusePgPacketWrite_8188e;
 	pHalFunc->Efuse_WordEnableDataWrite = &rtl8188e_Efuse_WordEnableDataWrite;
 
 	pHalFunc->sreset_init_value = &sreset_init_value;
diff --git a/drivers/staging/rtl8188eu/include/hal_intf.h b/drivers/staging/rtl8188eu/include/hal_intf.h
index d971e6e..f4f6443 100644
--- a/drivers/staging/rtl8188eu/include/hal_intf.h
+++ b/drivers/staging/rtl8188eu/include/hal_intf.h
@@ -243,7 +243,7 @@ struct hal_ops {
 				       bool bPseudoTest);
 	int	(*Efuse_PgPacketRead)(struct adapter *adapter, u8 offset,
 				      u8 *data, bool bPseudoTest);
-	int	(*Efuse_PgPacketWrite)(struct adapter *padapter, u8 offset,
+	bool	(*Efuse_PgPacketWrite)(struct adapter *padapter, u8 offset,
 				       u8 word_en, u8 *data, bool bPseudoTest);
 	u8	(*Efuse_WordEnableDataWrite)(struct adapter *padapter,
 					     u16 efuse_addr, u8 word_en,
-- 
1.7.10.4


  parent reply	other threads:[~2014-06-20 15:01 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-06-20 14:59 [PATCH 00/41] Cleanup and consolidate efuse related code navin patidar
2014-06-20 14:59 ` [PATCH 01/41] staging: rtl8188eu: Rename hal_EfusePowerSwitch_RTL8188E() navin patidar
2014-06-20 14:59 ` [PATCH 02/41] staging: rtl8188eu: Remove rtl8188e_ReadEFuse() navin patidar
2014-06-20 14:59 ` [PATCH 03/41] staging: rtl8188eu: Remove unused function ReadEFuse_Pseudo() navin patidar
2014-06-20 14:59 ` [PATCH 04/41] staging: rtl8188eu: Remove rtl8188e_EfuseGetCurrentSize() navin patidar
2014-06-20 14:59 ` [PATCH 05/41] staging: rtl8188eu: Remove unused function Hal_EfuseGetCurrentSize_Pseudo() navin patidar
2014-06-20 14:59 ` [PATCH 06/41] staging: rtl8188eu: Remove function Hal_EFUSEGetEfuseDefinition_Pseudo88E() navin patidar
2014-06-20 14:59 ` [PATCH 07/41] staging: rtl8188eu: Rename Hal_EFUSEGetEfuseDefinition88E() navin patidar
2014-06-20 14:59 ` [PATCH 08/41] staging: rtl8188eu: assign hal_EfusePgPacketRead_8188e() to ->Efuse_PgPacketRead navin patidar
2014-06-20 14:59 ` navin patidar [this message]
2014-06-20 14:59 ` [PATCH 10/41] staging:rtl8188eu: Assign rtl8188e_Efuse_WordEnableDataWrite() to ->Efuse_WordEnableDataWrite navin patidar
2014-06-20 14:59 ` [PATCH 11/41] staging: rtl8188eu: rtw_efuse.c: Remove unnecessary function declaration navin patidar
2014-06-20 14:59 ` [PATCH 12/41] staging: rtl8188eu: Rename rtl8188e_EFUSE_GetEfuseDefinition() navin patidar
2014-06-20 14:59 ` [PATCH 13/41] staging: rtl8188eu: Rename hal_EfuseGetCurrentSize_8188e() navin patidar
2014-06-20 14:59 ` [PATCH 14/41] staging: rtl8188eu: Rename rtl8188e_EfusePowerSwitch() to Efuse_PowerSwitch() navin patidar
2014-06-20 14:59 ` [PATCH 15/41] staging: rtl8188eu: Rename function Hal_EfuseWordEnableDataWrite() navin patidar
2014-06-20 14:59 ` [PATCH 16/41] staging: rtl8188eu: Remove function Hal_EfuseReadEFuse88E() navin patidar
2014-06-20 14:59 ` [PATCH 17/41] staging: rtl8188eu: Rename function ReadEFuseByIC() to efuse_ReadEFuse() navin patidar
2014-06-20 14:59 ` [PATCH 18/41] staging: rtl8188eu: Rename hal_EfusePgPacketRead_8188e() to Efuse_PgPacketRead() navin patidar
2014-06-20 14:59 ` [PATCH 19/41] staging: rtl8188eu: Rename hal_EfusePgPacketWrite_8188e() navin patidar
2014-06-20 14:59 ` [PATCH 20/41] staging: rtl8188eu: Remove function Efuse_Write1ByteToFakeContent() navin patidar
2014-06-20 14:59 ` [PATCH 21/41] staging: rtl8188eu: Remove function Efuse_Read1ByteFromFakeContent() navin patidar
2014-06-20 14:59 ` [PATCH 22/41] staging: rtl8188eu: Remove function rtw_BT_efuse_map_write() navin patidar
2014-06-20 14:59 ` [PATCH 23/41] staging: rtl8188eu: Remove unused function Efuse_PgPacketWrite_BT() navin patidar
2014-06-20 14:59 ` [PATCH 24/41] staging: rtl8188eu: Remove function rtw_BT_efuse_map_read() navin patidar
2014-06-20 14:59 ` [PATCH 25/41] staging: rtl8188eu: Remove unused function ReadEFuseByte() navin patidar
2014-06-20 14:59 ` [PATCH 26/41] staging: rtl8188eu: Remove unused function EFUSE_Read1Byte() navin patidar
2014-06-20 14:59 ` [PATCH 27/41] staging: rtl8188eu: efuse_OneByteRead():Remove unused parameter bool test navin patidar
2014-06-20 14:59 ` [PATCH 28/41] staging: rtl8188eu: efuse_OneByteWrite(): Remove " navin patidar
2014-06-20 14:59 ` [PATCH 29/41] staging: rtl8188eu: efuse_ReadEFuse(): Remove parameter bool bPseudoTest navin patidar
2014-06-20 14:59 ` [PATCH 30/41] staging: rtl8188eu: Efuse_GetCurrentSize(): Remove parameter bool test navin patidar
2014-06-20 14:59 ` [PATCH 31/41] staging: rtl8188eu: Efuse_ReadAllMap(): Remove unused " navin patidar
2014-06-20 14:59 ` [PATCH 32/41] staging: rtl8188eu: EFUSE_ShadowMapUpdate():Remove " navin patidar
2014-06-20 14:59 ` [PATCH 33/41] staging: rtl8188eu: Efuse_WordEnableDataWrite(): Remove unused parameter test navin patidar
2014-06-20 14:59 ` [PATCH 34/41] staging: rtl8188eu: hal_EfuseCheckIfDatafollowed(): Remove unused parameter navin patidar
2014-06-20 14:59 ` [PATCH 35/41] staging: rtl8188eu: Remove bool bPseudoTest parameter from efuse functions navin patidar
2014-06-20 14:59 ` [PATCH 36/41] staging: rtl8188eu: rtl8188e_hal_init.c: Remove forward declarations navin patidar
2014-06-20 14:59 ` [PATCH 37/41] staging: rtl8188eu: hal_EfusePartialWriteCheck(): Remove bluetooth specific code navin patidar
2014-06-20 14:59 ` [PATCH 38/41] staging: rtl8188eu: rtw_efuse.c: Remove unused global variables navin patidar
2014-06-20 14:59 ` [PATCH 39/41] staging: rtl8188eu: rtw_efuse.c: Remove unused local variables navin patidar
2014-06-20 14:59 ` [PATCH 40/41] staging: rtl8188eu: rtw_efuse.c: Remove unnecessary comments navin patidar
2014-06-20 14:59 ` [PATCH 41/41] staging: rtl8188eu: Move all efuse related code to rtw_efuse.c navin patidar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1403276387-11841-10-git-send-email-navin.patidar@gmail.com \
    --to=navin.patidar@gmail.com \
    --cc=Larry.Finger@lwfinger.net \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®