From: navin patidar <navin.patidar@gmail.com>
To: gregkh@linuxfoundation.org
Cc: Larry.Finger@lwfinger.net, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org,
navin patidar <navin.patidar@gmail.com>
Subject: [PATCH 04/41] staging: rtl8188eu: Remove rtl8188e_EfuseGetCurrentSize()
Date: Fri, 20 Jun 2014 20:29:10 +0530 [thread overview]
Message-ID: <1403276387-11841-5-git-send-email-navin.patidar@gmail.com> (raw)
In-Reply-To: <1403276387-11841-1-git-send-email-navin.patidar@gmail.com>
rtl8188e_EfuseGetCurrentSize() checks bool bPseudoTest and then calls suitable
function to get efuse size, hal_EfuseGetCurrentSize_8188e() also does same thing.
So use hal_EfuseGetCurrentSize_8188e() and drop rtl8188e_EfuseGetCurrentSize().
Signed-off-by: navin patidar <navin.patidar@gmail.com>
---
drivers/staging/rtl8188eu/core/rtw_efuse.c | 5 ++---
drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c | 17 +++--------------
drivers/staging/rtl8188eu/include/hal_intf.h | 2 +-
drivers/staging/rtl8188eu/include/rtw_efuse.h | 2 +-
4 files changed, 7 insertions(+), 19 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_efuse.c b/drivers/staging/rtl8188eu/core/rtw_efuse.c
index 31507e7..b450458 100644
--- a/drivers/staging/rtl8188eu/core/rtw_efuse.c
+++ b/drivers/staging/rtl8188eu/core/rtw_efuse.c
@@ -128,12 +128,11 @@ Efuse_PowerSwitch(
u16
Efuse_GetCurrentSize(
struct adapter *pAdapter,
- u8 efuseType,
bool pseudo)
{
u16 ret = 0;
- ret = pAdapter->HalFunc.EfuseGetCurrentSize(pAdapter, efuseType, pseudo);
+ ret = pAdapter->HalFunc.EfuseGetCurrentSize(pAdapter, pseudo);
return ret;
}
@@ -490,7 +489,7 @@ u16 efuse_GetMaxSize(struct adapter *padapter)
u8 efuse_GetCurrentSize(struct adapter *padapter, u16 *size)
{
Efuse_PowerSwitch(padapter, false, true);
- *size = Efuse_GetCurrentSize(padapter, EFUSE_WIFI, false);
+ *size = Efuse_GetCurrentSize(padapter, false);
Efuse_PowerSwitch(padapter, false, false);
return _SUCCESS;
diff --git a/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c b/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
index b7066cb..84393aa 100644
--- a/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
+++ b/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
@@ -1215,17 +1215,6 @@ static u16 Hal_EfuseGetCurrentSize_Pseudo(struct adapter *pAdapter, bool bPseudo
return ret;
}
-static u16 rtl8188e_EfuseGetCurrentSize(struct adapter *pAdapter, u8 efuseType, bool bPseudoTest)
-{
- u16 ret = 0;
-
- if (bPseudoTest)
- ret = Hal_EfuseGetCurrentSize_Pseudo(pAdapter, bPseudoTest);
- else
- ret = hal_EfuseGetCurrentSize_8188e(pAdapter, bPseudoTest);
- return ret;
-}
-
static int hal_EfusePgPacketRead_8188e(struct adapter *pAdapter, u8 offset, u8 *data, bool bPseudoTest)
{
u8 ReadState = PG_STATE_HEADER;
@@ -1357,7 +1346,7 @@ static bool hal_EfuseFixHeaderProcess(struct adapter *pAdapter, u8 efuseType, st
if (!PgWriteSuccess)
return false;
else
- efuse_addr = Efuse_GetCurrentSize(pAdapter, efuseType, bPseudoTest);
+ efuse_addr = Efuse_GetCurrentSize(pAdapter, bPseudoTest);
} else {
efuse_addr = efuse_addr + (pFixPkt->word_cnts*2) + 1;
}
@@ -1646,7 +1635,7 @@ hal_EfusePgCheckAvailableAddr(
/* Change to check TYPE_EFUSE_MAP_LEN , because 8188E raw 256, logic map over 256. */
EFUSE_GetEfuseDefinition(pAdapter, EFUSE_WIFI, TYPE_EFUSE_MAP_LEN, (void *)&efuse_max_available_len, false);
- if (Efuse_GetCurrentSize(pAdapter, efuseType, bPseudoTest) >= efuse_max_available_len)
+ if (Efuse_GetCurrentSize(pAdapter, bPseudoTest) >= efuse_max_available_len)
return false;
return true;
}
@@ -1836,7 +1825,7 @@ void rtl8188e_set_hal_ops(struct hal_ops *pHalFunc)
pHalFunc->EfusePowerSwitch = &rtl8188e_EfusePowerSwitch;
pHalFunc->ReadEFuse = &ReadEFuseByIC;
pHalFunc->EFUSEGetEfuseDefinition = &rtl8188e_EFUSE_GetEfuseDefinition;
- pHalFunc->EfuseGetCurrentSize = &rtl8188e_EfuseGetCurrentSize;
+ pHalFunc->EfuseGetCurrentSize = &hal_EfuseGetCurrentSize_8188e;
pHalFunc->Efuse_PgPacketRead = &rtl8188e_Efuse_PgPacketRead;
pHalFunc->Efuse_PgPacketWrite = &rtl8188e_Efuse_PgPacketWrite;
pHalFunc->Efuse_WordEnableDataWrite = &rtl8188e_Efuse_WordEnableDataWrite;
diff --git a/drivers/staging/rtl8188eu/include/hal_intf.h b/drivers/staging/rtl8188eu/include/hal_intf.h
index ca29676..ecc92a6 100644
--- a/drivers/staging/rtl8188eu/include/hal_intf.h
+++ b/drivers/staging/rtl8188eu/include/hal_intf.h
@@ -239,7 +239,7 @@ struct hal_ops {
u16 _size_byte, u8 *pbuf, bool bPseudoTest);
void (*EFUSEGetEfuseDefinition)(struct adapter *padapter, u8 efuseType,
u8 type, void *pOut, bool bPseudoTest);
- u16 (*EfuseGetCurrentSize)(struct adapter *padapter, u8 efuseType,
+ u16 (*EfuseGetCurrentSize)(struct adapter *padapter,
bool bPseudoTest);
int (*Efuse_PgPacketRead)(struct adapter *adapter, u8 offset,
u8 *data, bool bPseudoTest);
diff --git a/drivers/staging/rtl8188eu/include/rtw_efuse.h b/drivers/staging/rtl8188eu/include/rtw_efuse.h
index df51355..cc19e19 100644
--- a/drivers/staging/rtl8188eu/include/rtw_efuse.h
+++ b/drivers/staging/rtl8188eu/include/rtw_efuse.h
@@ -127,7 +127,7 @@ u8 rtw_BT_efuse_map_read(struct adapter *adapter, u16 addr,
u16 cnts, u8 *data);
u8 rtw_BT_efuse_map_write(struct adapter *adapter, u16 addr,
u16 cnts, u8 *data);
-u16 Efuse_GetCurrentSize(struct adapter *adapter, u8 efusetype, bool test);
+u16 Efuse_GetCurrentSize(struct adapter *adapter, bool test);
u8 Efuse_CalculateWordCnts(u8 word_en);
void ReadEFuseByte(struct adapter *adapter, u16 _offset, u8 *pbuf, bool test);
void EFUSE_GetEfuseDefinition(struct adapter *adapt, u8 type, u8 type1,
--
1.7.10.4
next prev parent reply other threads:[~2014-06-20 15:00 UTC|newest]
Thread overview: 42+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-06-20 14:59 [PATCH 00/41] Cleanup and consolidate efuse related code navin patidar
2014-06-20 14:59 ` [PATCH 01/41] staging: rtl8188eu: Rename hal_EfusePowerSwitch_RTL8188E() navin patidar
2014-06-20 14:59 ` [PATCH 02/41] staging: rtl8188eu: Remove rtl8188e_ReadEFuse() navin patidar
2014-06-20 14:59 ` [PATCH 03/41] staging: rtl8188eu: Remove unused function ReadEFuse_Pseudo() navin patidar
2014-06-20 14:59 ` navin patidar [this message]
2014-06-20 14:59 ` [PATCH 05/41] staging: rtl8188eu: Remove unused function Hal_EfuseGetCurrentSize_Pseudo() navin patidar
2014-06-20 14:59 ` [PATCH 06/41] staging: rtl8188eu: Remove function Hal_EFUSEGetEfuseDefinition_Pseudo88E() navin patidar
2014-06-20 14:59 ` [PATCH 07/41] staging: rtl8188eu: Rename Hal_EFUSEGetEfuseDefinition88E() navin patidar
2014-06-20 14:59 ` [PATCH 08/41] staging: rtl8188eu: assign hal_EfusePgPacketRead_8188e() to ->Efuse_PgPacketRead navin patidar
2014-06-20 14:59 ` [PATCH 09/41] staging:rtl8188eu:assign hal_EfusePgPacketWrite_8188e() to ->Efuse_PgPacketWrite navin patidar
2014-06-20 14:59 ` [PATCH 10/41] staging:rtl8188eu: Assign rtl8188e_Efuse_WordEnableDataWrite() to ->Efuse_WordEnableDataWrite navin patidar
2014-06-20 14:59 ` [PATCH 11/41] staging: rtl8188eu: rtw_efuse.c: Remove unnecessary function declaration navin patidar
2014-06-20 14:59 ` [PATCH 12/41] staging: rtl8188eu: Rename rtl8188e_EFUSE_GetEfuseDefinition() navin patidar
2014-06-20 14:59 ` [PATCH 13/41] staging: rtl8188eu: Rename hal_EfuseGetCurrentSize_8188e() navin patidar
2014-06-20 14:59 ` [PATCH 14/41] staging: rtl8188eu: Rename rtl8188e_EfusePowerSwitch() to Efuse_PowerSwitch() navin patidar
2014-06-20 14:59 ` [PATCH 15/41] staging: rtl8188eu: Rename function Hal_EfuseWordEnableDataWrite() navin patidar
2014-06-20 14:59 ` [PATCH 16/41] staging: rtl8188eu: Remove function Hal_EfuseReadEFuse88E() navin patidar
2014-06-20 14:59 ` [PATCH 17/41] staging: rtl8188eu: Rename function ReadEFuseByIC() to efuse_ReadEFuse() navin patidar
2014-06-20 14:59 ` [PATCH 18/41] staging: rtl8188eu: Rename hal_EfusePgPacketRead_8188e() to Efuse_PgPacketRead() navin patidar
2014-06-20 14:59 ` [PATCH 19/41] staging: rtl8188eu: Rename hal_EfusePgPacketWrite_8188e() navin patidar
2014-06-20 14:59 ` [PATCH 20/41] staging: rtl8188eu: Remove function Efuse_Write1ByteToFakeContent() navin patidar
2014-06-20 14:59 ` [PATCH 21/41] staging: rtl8188eu: Remove function Efuse_Read1ByteFromFakeContent() navin patidar
2014-06-20 14:59 ` [PATCH 22/41] staging: rtl8188eu: Remove function rtw_BT_efuse_map_write() navin patidar
2014-06-20 14:59 ` [PATCH 23/41] staging: rtl8188eu: Remove unused function Efuse_PgPacketWrite_BT() navin patidar
2014-06-20 14:59 ` [PATCH 24/41] staging: rtl8188eu: Remove function rtw_BT_efuse_map_read() navin patidar
2014-06-20 14:59 ` [PATCH 25/41] staging: rtl8188eu: Remove unused function ReadEFuseByte() navin patidar
2014-06-20 14:59 ` [PATCH 26/41] staging: rtl8188eu: Remove unused function EFUSE_Read1Byte() navin patidar
2014-06-20 14:59 ` [PATCH 27/41] staging: rtl8188eu: efuse_OneByteRead():Remove unused parameter bool test navin patidar
2014-06-20 14:59 ` [PATCH 28/41] staging: rtl8188eu: efuse_OneByteWrite(): Remove " navin patidar
2014-06-20 14:59 ` [PATCH 29/41] staging: rtl8188eu: efuse_ReadEFuse(): Remove parameter bool bPseudoTest navin patidar
2014-06-20 14:59 ` [PATCH 30/41] staging: rtl8188eu: Efuse_GetCurrentSize(): Remove parameter bool test navin patidar
2014-06-20 14:59 ` [PATCH 31/41] staging: rtl8188eu: Efuse_ReadAllMap(): Remove unused " navin patidar
2014-06-20 14:59 ` [PATCH 32/41] staging: rtl8188eu: EFUSE_ShadowMapUpdate():Remove " navin patidar
2014-06-20 14:59 ` [PATCH 33/41] staging: rtl8188eu: Efuse_WordEnableDataWrite(): Remove unused parameter test navin patidar
2014-06-20 14:59 ` [PATCH 34/41] staging: rtl8188eu: hal_EfuseCheckIfDatafollowed(): Remove unused parameter navin patidar
2014-06-20 14:59 ` [PATCH 35/41] staging: rtl8188eu: Remove bool bPseudoTest parameter from efuse functions navin patidar
2014-06-20 14:59 ` [PATCH 36/41] staging: rtl8188eu: rtl8188e_hal_init.c: Remove forward declarations navin patidar
2014-06-20 14:59 ` [PATCH 37/41] staging: rtl8188eu: hal_EfusePartialWriteCheck(): Remove bluetooth specific code navin patidar
2014-06-20 14:59 ` [PATCH 38/41] staging: rtl8188eu: rtw_efuse.c: Remove unused global variables navin patidar
2014-06-20 14:59 ` [PATCH 39/41] staging: rtl8188eu: rtw_efuse.c: Remove unused local variables navin patidar
2014-06-20 14:59 ` [PATCH 40/41] staging: rtl8188eu: rtw_efuse.c: Remove unnecessary comments navin patidar
2014-06-20 14:59 ` [PATCH 41/41] staging: rtl8188eu: Move all efuse related code to rtw_efuse.c navin patidar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1403276387-11841-5-git-send-email-navin.patidar@gmail.com \
--to=navin.patidar@gmail.com \
--cc=Larry.Finger@lwfinger.net \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®