From: navin patidar <navin.patidar@gmail.com>
To: gregkh@linuxfoundation.org
Cc: Larry.Finger@lwfinger.net, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org,
navin patidar <navin.patidar@gmail.com>
Subject: [PATCH 15/41] staging: rtl8188eu: Rename function Hal_EfuseWordEnableDataWrite()
Date: Fri, 20 Jun 2014 20:29:21 +0530 [thread overview]
Message-ID: <1403276387-11841-16-git-send-email-navin.patidar@gmail.com> (raw)
In-Reply-To: <1403276387-11841-1-git-send-email-navin.patidar@gmail.com>
Rename Hal_EfuseWordEnableDataWrite() to Efuse_WordEnableDataWrite()
and remove original EFUSE_GetEfuseDefinition() function,
so that driver can call Hal_EfuseWordEnableDataWrite() directly
without going through Efuse_WordEnableDataWrite().
Signed-off-by: navin patidar <navin.patidar@gmail.com>
---
drivers/staging/rtl8188eu/core/rtw_efuse.c | 9 ---------
drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c | 3 +--
drivers/staging/rtl8188eu/include/hal_intf.h | 3 ---
3 files changed, 1 insertion(+), 14 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_efuse.c b/drivers/staging/rtl8188eu/core/rtw_efuse.c
index 7adb7b4..f2d374d 100644
--- a/drivers/staging/rtl8188eu/core/rtw_efuse.c
+++ b/drivers/staging/rtl8188eu/core/rtw_efuse.c
@@ -350,15 +350,6 @@ void efuse_WordEnableDataRead(u8 word_en, u8 *sourdata, u8 *targetdata)
}
}
-u8 Efuse_WordEnableDataWrite(struct adapter *pAdapter, u16 efuse_addr, u8 word_en, u8 *data, bool pseudo)
-{
- u8 ret = 0;
-
- ret = pAdapter->HalFunc.Efuse_WordEnableDataWrite(pAdapter, efuse_addr, word_en, data, pseudo);
-
- return ret;
-}
-
static u8 efuse_read8(struct adapter *padapter, u16 address, u8 *value)
{
return efuse_OneByteRead(padapter, address, value, false);
diff --git a/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c b/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
index 525973f..8e93d48 100644
--- a/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
+++ b/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c
@@ -1026,7 +1026,7 @@ void EFUSE_GetEfuseDefinition(struct adapter *pAdapter, u8 efuseType, u8 type, v
}
}
-static u8 Hal_EfuseWordEnableDataWrite(struct adapter *pAdapter, u16 efuse_addr, u8 word_en, u8 *data, bool bPseudoTest)
+u8 Efuse_WordEnableDataWrite(struct adapter *pAdapter, u16 efuse_addr, u8 word_en, u8 *data, bool bPseudoTest)
{
u16 tmpaddr = 0;
u16 start_addr = efuse_addr;
@@ -1681,7 +1681,6 @@ void rtl8188e_set_hal_ops(struct hal_ops *pHalFunc)
pHalFunc->ReadEFuse = &ReadEFuseByIC;
pHalFunc->Efuse_PgPacketRead = &hal_EfusePgPacketRead_8188e;
pHalFunc->Efuse_PgPacketWrite = &hal_EfusePgPacketWrite_8188e;
- pHalFunc->Efuse_WordEnableDataWrite = &Hal_EfuseWordEnableDataWrite;
pHalFunc->sreset_init_value = &sreset_init_value;
pHalFunc->sreset_get_wifi_status = &sreset_get_wifi_status;
diff --git a/drivers/staging/rtl8188eu/include/hal_intf.h b/drivers/staging/rtl8188eu/include/hal_intf.h
index 38285d6..a7cad6f 100644
--- a/drivers/staging/rtl8188eu/include/hal_intf.h
+++ b/drivers/staging/rtl8188eu/include/hal_intf.h
@@ -239,9 +239,6 @@ struct hal_ops {
u8 *data, bool bPseudoTest);
bool (*Efuse_PgPacketWrite)(struct adapter *padapter, u8 offset,
u8 word_en, u8 *data, bool bPseudoTest);
- u8 (*Efuse_WordEnableDataWrite)(struct adapter *padapter,
- u16 efuse_addr, u8 word_en,
- u8 *data, bool bPseudoTest);
bool (*Efuse_PgPacketWrite_BT)(struct adapter *padapter, u8 offset,
u8 word_en, u8 *data, bool test);
--
1.7.10.4
next prev parent reply other threads:[~2014-06-20 15:02 UTC|newest]
Thread overview: 42+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-06-20 14:59 [PATCH 00/41] Cleanup and consolidate efuse related code navin patidar
2014-06-20 14:59 ` [PATCH 01/41] staging: rtl8188eu: Rename hal_EfusePowerSwitch_RTL8188E() navin patidar
2014-06-20 14:59 ` [PATCH 02/41] staging: rtl8188eu: Remove rtl8188e_ReadEFuse() navin patidar
2014-06-20 14:59 ` [PATCH 03/41] staging: rtl8188eu: Remove unused function ReadEFuse_Pseudo() navin patidar
2014-06-20 14:59 ` [PATCH 04/41] staging: rtl8188eu: Remove rtl8188e_EfuseGetCurrentSize() navin patidar
2014-06-20 14:59 ` [PATCH 05/41] staging: rtl8188eu: Remove unused function Hal_EfuseGetCurrentSize_Pseudo() navin patidar
2014-06-20 14:59 ` [PATCH 06/41] staging: rtl8188eu: Remove function Hal_EFUSEGetEfuseDefinition_Pseudo88E() navin patidar
2014-06-20 14:59 ` [PATCH 07/41] staging: rtl8188eu: Rename Hal_EFUSEGetEfuseDefinition88E() navin patidar
2014-06-20 14:59 ` [PATCH 08/41] staging: rtl8188eu: assign hal_EfusePgPacketRead_8188e() to ->Efuse_PgPacketRead navin patidar
2014-06-20 14:59 ` [PATCH 09/41] staging:rtl8188eu:assign hal_EfusePgPacketWrite_8188e() to ->Efuse_PgPacketWrite navin patidar
2014-06-20 14:59 ` [PATCH 10/41] staging:rtl8188eu: Assign rtl8188e_Efuse_WordEnableDataWrite() to ->Efuse_WordEnableDataWrite navin patidar
2014-06-20 14:59 ` [PATCH 11/41] staging: rtl8188eu: rtw_efuse.c: Remove unnecessary function declaration navin patidar
2014-06-20 14:59 ` [PATCH 12/41] staging: rtl8188eu: Rename rtl8188e_EFUSE_GetEfuseDefinition() navin patidar
2014-06-20 14:59 ` [PATCH 13/41] staging: rtl8188eu: Rename hal_EfuseGetCurrentSize_8188e() navin patidar
2014-06-20 14:59 ` [PATCH 14/41] staging: rtl8188eu: Rename rtl8188e_EfusePowerSwitch() to Efuse_PowerSwitch() navin patidar
2014-06-20 14:59 ` navin patidar [this message]
2014-06-20 14:59 ` [PATCH 16/41] staging: rtl8188eu: Remove function Hal_EfuseReadEFuse88E() navin patidar
2014-06-20 14:59 ` [PATCH 17/41] staging: rtl8188eu: Rename function ReadEFuseByIC() to efuse_ReadEFuse() navin patidar
2014-06-20 14:59 ` [PATCH 18/41] staging: rtl8188eu: Rename hal_EfusePgPacketRead_8188e() to Efuse_PgPacketRead() navin patidar
2014-06-20 14:59 ` [PATCH 19/41] staging: rtl8188eu: Rename hal_EfusePgPacketWrite_8188e() navin patidar
2014-06-20 14:59 ` [PATCH 20/41] staging: rtl8188eu: Remove function Efuse_Write1ByteToFakeContent() navin patidar
2014-06-20 14:59 ` [PATCH 21/41] staging: rtl8188eu: Remove function Efuse_Read1ByteFromFakeContent() navin patidar
2014-06-20 14:59 ` [PATCH 22/41] staging: rtl8188eu: Remove function rtw_BT_efuse_map_write() navin patidar
2014-06-20 14:59 ` [PATCH 23/41] staging: rtl8188eu: Remove unused function Efuse_PgPacketWrite_BT() navin patidar
2014-06-20 14:59 ` [PATCH 24/41] staging: rtl8188eu: Remove function rtw_BT_efuse_map_read() navin patidar
2014-06-20 14:59 ` [PATCH 25/41] staging: rtl8188eu: Remove unused function ReadEFuseByte() navin patidar
2014-06-20 14:59 ` [PATCH 26/41] staging: rtl8188eu: Remove unused function EFUSE_Read1Byte() navin patidar
2014-06-20 14:59 ` [PATCH 27/41] staging: rtl8188eu: efuse_OneByteRead():Remove unused parameter bool test navin patidar
2014-06-20 14:59 ` [PATCH 28/41] staging: rtl8188eu: efuse_OneByteWrite(): Remove " navin patidar
2014-06-20 14:59 ` [PATCH 29/41] staging: rtl8188eu: efuse_ReadEFuse(): Remove parameter bool bPseudoTest navin patidar
2014-06-20 14:59 ` [PATCH 30/41] staging: rtl8188eu: Efuse_GetCurrentSize(): Remove parameter bool test navin patidar
2014-06-20 14:59 ` [PATCH 31/41] staging: rtl8188eu: Efuse_ReadAllMap(): Remove unused " navin patidar
2014-06-20 14:59 ` [PATCH 32/41] staging: rtl8188eu: EFUSE_ShadowMapUpdate():Remove " navin patidar
2014-06-20 14:59 ` [PATCH 33/41] staging: rtl8188eu: Efuse_WordEnableDataWrite(): Remove unused parameter test navin patidar
2014-06-20 14:59 ` [PATCH 34/41] staging: rtl8188eu: hal_EfuseCheckIfDatafollowed(): Remove unused parameter navin patidar
2014-06-20 14:59 ` [PATCH 35/41] staging: rtl8188eu: Remove bool bPseudoTest parameter from efuse functions navin patidar
2014-06-20 14:59 ` [PATCH 36/41] staging: rtl8188eu: rtl8188e_hal_init.c: Remove forward declarations navin patidar
2014-06-20 14:59 ` [PATCH 37/41] staging: rtl8188eu: hal_EfusePartialWriteCheck(): Remove bluetooth specific code navin patidar
2014-06-20 14:59 ` [PATCH 38/41] staging: rtl8188eu: rtw_efuse.c: Remove unused global variables navin patidar
2014-06-20 14:59 ` [PATCH 39/41] staging: rtl8188eu: rtw_efuse.c: Remove unused local variables navin patidar
2014-06-20 14:59 ` [PATCH 40/41] staging: rtl8188eu: rtw_efuse.c: Remove unnecessary comments navin patidar
2014-06-20 14:59 ` [PATCH 41/41] staging: rtl8188eu: Move all efuse related code to rtw_efuse.c navin patidar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1403276387-11841-16-git-send-email-navin.patidar@gmail.com \
--to=navin.patidar@gmail.com \
--cc=Larry.Finger@lwfinger.net \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®