From: Yijing Wang <wangyijing@huawei.com>
To: Bjorn Helgaas <bhelgaas@google.com>
Cc: Jiang Liu <jiang.liu@linux.intel.com>,
<linux-pci@vger.kernel.org>, Yinghai Lu <yinghai@kernel.org>,
<linux-kernel@vger.kernel.org>,
Marc Zyngier <marc.zyngier@arm.com>,
<linux-arm-kernel@lists.infradead.org>,
Russell King <linux@arm.linux.org.uk>, <x86@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>,
Tony Luck <tony.luck@intel.com>, <linux-ia64@vger.kernel.org>,
"David S. Miller" <davem@davemloft.net>,
"Guan Xuetao" <gxt@mprc.pku.edu.cn>,
<linux-alpha@vger.kernel.org>, <linux-m68k@vger.kernel.org>,
Liviu Dudau <liviu@dudau.co.uk>, "Arnd Bergmann" <arnd@arndb.de>,
Geert Uytterhoeven <geert@linux-m68k.org>,
"Yijing Wang" <wangyijing@huawei.com>
Subject: [PATCH 00/28] Refine PCI scan interfaces and make generic pci host bridge
Date: Fri, 16 Jan 2015 09:43:58 +0800 [thread overview]
Message-ID: <1421372666-12288-1-git-send-email-wangyijing@huawei.com> (raw)
This series is based on Bjorn's pci-next branch.
Patch 1-4 ripped out pci_bus_add_devices() from pci scan interfaces
for better pci scan flow.
Patch 5-11 make a generic pci_host_bridge to hold pci_host_bridge
related informations, and introduce a pci_host_bridge_ops to
support platform host drivers provide its own pci_host_bridge
related operations to setup pci_host_bridge during pci enumeration.
Patch 12-28 apply the new pci scan interfaces to platform pci host
bridge drivers.
Now in kernel, we scan pci bus use the following ways:
1. pci_scan_bus.
parent = NULL, default io/mem/bus resources
call pci_bus_add_devices()
2. pci_scan_bus_parented() + pci_bus_add_devices()
default io/mem/bus resources, only used by xen
3. pci_scan_root_bus() + pci_bus_add_devices()
4. pci_create_root_bus() + pci_scan_child_bus() + pci_bus_add_devices()
5. pci_create_root_bus() + xx_of_scan_bus() + pci_bus_add_devices()
And we have a lot of arch specific pci_domain_nr() and other platform
specific weak function like pcibios_root_bridge_prepare().
After applied this series, we have following scan interfaces:
1. pci_scan_bus_legacy()
parent = NULL, default io/mem/bus resources.
for legacy pci scan
2. pci_scan_root_bus()
for callers provide its own parent and io/mem/bus resources
but no platform specific pci_host_bridge operations
3. pci_scan_root_bridge()
for callers provide its own parent and io/mem/bus resources
and pci_host_bridge_ops.
Besides, above pci scan interfaces all need addtionally call pci_bus_add_devices()
to set match_driver true and try to attach drivers.
Also we could eliminate all arch specific pci_domain_nr() after applied this series.
I tested this series on x86 (with or without ACPI).
Comments and tests are warmly welcome!
Arnd Bergmann (1):
xen/PCI: Don't use deprecated function pci_scan_bus_parented()
Yijing Wang (27):
PCI: Rip out pci_bus_add_devices() from pci_scan_bus()
PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus()
PCI: Remove deprecated pci_scan_bus_parented()
PCI: Rename pci_scan_bus() to pci_scan_bus_legacy()
PCI: Combine PCI domain and bus number in u32 arg
PCI: Pass PCI domain number combined with root bus number
PCI: Introduce pci_host_assign_domain_nr() to assign domain
PCI: Separate pci_host_bridge creation out of pci_create_root_bus()
PCI: Save sysdata in pci_host_bridge drvdata
PCI: Introduce pci_host_bridge_ops to setup host bridge
PCI: Introduce new scan function pci_scan_root_bridge()
PCI/x86: Refine pci_acpi_scan_root() with generic pci_host_bridge
PCI/IA64: Refine pci_acpi_scan_root() with generic pci_host_bridge
PCI/powerpc: Rename pcibios_root_bridge_prepare() for better
readability
PCI/powerpc: Use pci_scan_root_bridge() for simplicity
PCI: Remove weak pcibios_root_bridge_prepare()
PCI/sparc: Use pci_scan_root_bridge() for simplicity
PCI: Introduce pci_bus_child_max_busnr()
PCI/Parisc: Use pci_scan_root_bus() for simplicity
PCI/mvebu: Use pci_common_init_dev() to simplify code
PCI/tegra: Remove redundant tegra_pcie_scan_bus()
PCI/designware: Use pci_scan_root_bus() for simplicity
PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus()
PCI: Rename __pci_create_root_bus() to pci_create_root_bus()
PCI: Export find_pci_host_bridge()
PCI: Remove platform specific pci_domain_nr()
PCI: Remove pci_bus_assign_domain_nr()
arch/alpha/include/asm/pci.h | 2 -
arch/alpha/kernel/pci.c | 7 +-
arch/alpha/kernel/sys_nautilus.c | 4 +-
arch/frv/mb93090-mb00/pci-vdk.c | 6 +-
arch/ia64/include/asm/pci.h | 1 -
arch/ia64/pci/pci.c | 34 +++---
arch/ia64/sn/kernel/io_init.c | 6 +-
arch/m68k/coldfire/pci.c | 3 +-
arch/microblaze/pci/pci-common.c | 17 +--
arch/mips/include/asm/pci.h | 2 -
arch/mips/pci/pci.c | 5 +-
arch/mn10300/unit-asb2305/pci.c | 5 +-
arch/powerpc/include/asm/machdep.h | 2 +-
arch/powerpc/kernel/pci-common.c | 73 ++++++-----
arch/powerpc/platforms/pseries/pci.c | 2 +-
arch/powerpc/platforms/pseries/pseries.h | 2 +-
arch/powerpc/platforms/pseries/setup.c | 2 +-
arch/s390/pci/pci.c | 13 +--
arch/sh/drivers/pci/pci.c | 6 +-
arch/sh/include/asm/pci.h | 2 -
arch/sparc/kernel/leon_pci.c | 1 +
arch/sparc/kernel/pci.c | 48 ++++----
arch/sparc/kernel/pcic.c | 4 +-
arch/tile/include/asm/pci.h | 2 -
arch/tile/kernel/pci.c | 6 +-
arch/tile/kernel/pci_gx.c | 7 +-
arch/unicore32/kernel/pci.c | 13 +--
arch/x86/include/asm/pci.h | 6 -
arch/x86/pci/acpi.c | 38 +++---
arch/x86/pci/common.c | 4 +-
arch/xtensa/kernel/pci.c | 2 +
drivers/parisc/dino.c | 11 +--
drivers/parisc/lba_pci.c | 6 +-
drivers/pci/host-bridge.c | 90 +++++++++++++-
drivers/pci/host/pci-mvebu.c | 18 +---
drivers/pci/host/pci-tegra.c | 15 ---
drivers/pci/host/pci-xgene.c | 3 +-
drivers/pci/host/pcie-designware.c | 4 +-
drivers/pci/hotplug/acpiphp_glue.c | 29 +----
drivers/pci/hotplug/ibmphp_core.c | 6 +-
drivers/pci/pci.c | 40 ++++++-
drivers/pci/probe.c | 198 ++++++++++++------------------
drivers/pci/xen-pcifront.c | 11 ++-
include/linux/pci.h | 51 +++++---
include/uapi/linux/pci.h | 3 +
45 files changed, 425 insertions(+), 385 deletions(-)
next reply other threads:[~2015-01-16 3:47 UTC|newest]
Thread overview: 56+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-01-16 1:43 Yijing Wang [this message]
2015-01-16 1:43 ` [PATCH 01/28] PCI: Rip out pci_bus_add_devices() from pci_scan_bus() Yijing Wang
2015-01-16 23:15 ` Yinghai Lu
2015-01-16 23:16 ` Yinghai Lu
2015-01-19 2:04 ` Yijing Wang
2015-01-19 4:59 ` Greg Ungerer
2015-01-19 8:23 ` Arnd Bergmann
2015-01-16 1:44 ` [PATCH 02/28] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() Yijing Wang
2015-01-16 1:44 ` [PATCH 03/28] xen/PCI: Don't use deprecated function pci_scan_bus_parented() Yijing Wang
2015-01-16 1:44 ` [PATCH 04/28] PCI: Remove deprecated pci_scan_bus_parented() Yijing Wang
2015-01-16 1:44 ` [PATCH 05/28] PCI: Rename pci_scan_bus() to pci_scan_bus_legacy() Yijing Wang
2015-01-16 1:44 ` [PATCH 06/28] PCI: Combine PCI domain and bus number in u32 arg Yijing Wang
2015-01-16 1:44 ` [PATCH 07/28] PCI: Pass PCI domain number combined with root bus number Yijing Wang
2015-01-16 1:44 ` [PATCH 08/28] PCI: Introduce pci_host_assign_domain_nr() to assign domain Yijing Wang
2015-01-16 9:08 ` Arnd Bergmann
2015-01-16 9:40 ` Arnd Bergmann
2015-01-19 2:14 ` Yijing Wang
2015-01-19 9:50 ` Arnd Bergmann
2015-01-19 10:56 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 09/28] PCI: Separate pci_host_bridge creation out of pci_create_root_bus() Yijing Wang
2015-01-16 9:14 ` Arnd Bergmann
2015-01-16 9:34 ` Arnd Bergmann
2015-01-19 2:39 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 10/28] PCI: Save sysdata in pci_host_bridge drvdata Yijing Wang
2015-01-16 9:18 ` Arnd Bergmann
2015-01-19 3:12 ` Yijing Wang
2015-01-19 9:52 ` Arnd Bergmann
2015-01-16 1:44 ` [PATCH 11/28] PCI: Introduce pci_host_bridge_ops to setup host bridge Yijing Wang
2015-01-16 9:23 ` Arnd Bergmann
2015-01-16 9:35 ` Arnd Bergmann
2015-01-16 1:44 ` [PATCH 12/28] PCI: Introduce new scan function pci_scan_root_bridge() Yijing Wang
2015-01-16 1:44 ` [PATCH 13/28] PCI/x86: Refine pci_acpi_scan_root() with generic pci_host_bridge Yijing Wang
2015-01-16 1:44 ` [PATCH 14/28] PCI/IA64: " Yijing Wang
2015-01-16 1:44 ` [PATCH 15/28] PCI/powerpc: Rename pcibios_root_bridge_prepare() for better readability Yijing Wang
2015-01-16 1:44 ` [PATCH 16/28] PCI/powerpc: Use pci_scan_root_bridge() for simplicity Yijing Wang
2015-01-16 1:44 ` [PATCH 17/28] PCI: Remove weak pcibios_root_bridge_prepare() Yijing Wang
2015-01-16 1:44 ` [PATCH 18/28] PCI/sparc: Use pci_scan_root_bridge() for simplicity Yijing Wang
2015-01-16 10:01 ` Arnd Bergmann
2015-01-19 3:17 ` Yijing Wang
2015-01-19 8:44 ` Arnd Bergmann
2015-01-19 10:53 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 19/28] PCI: Introduce pci_bus_child_max_busnr() Yijing Wang
2015-01-16 1:44 ` [PATCH 20/28] PCI/Parisc: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-01-16 1:44 ` [PATCH 21/28] PCI/mvebu: Use pci_common_init_dev() to simplify code Yijing Wang
2015-01-16 1:44 ` [PATCH 22/28] PCI/tegra: Remove redundant tegra_pcie_scan_bus() Yijing Wang
2015-01-16 1:44 ` [PATCH 23/28] PCI/designware: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-01-17 16:39 ` Sergei Shtylyov
2015-01-19 3:17 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 24/28] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() Yijing Wang
2015-01-16 1:44 ` [PATCH 25/28] PCI: Rename __pci_create_root_bus() to pci_create_root_bus() Yijing Wang
2015-01-16 1:44 ` [PATCH 26/28] PCI: Export find_pci_host_bridge() Yijing Wang
2015-01-16 1:44 ` [PATCH 27/28] PCI: Remove platform specific pci_domain_nr() Yijing Wang
2015-01-16 9:44 ` Arnd Bergmann
2015-01-19 3:19 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 28/28] PCI: Remove pci_bus_assign_domain_nr() Yijing Wang
2015-01-16 10:12 ` [PATCH 00/28] Refine PCI scan interfaces and make generic pci host bridge Arnd Bergmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1421372666-12288-1-git-send-email-wangyijing@huawei.com \
--to=wangyijing@huawei.com \
--cc=arnd@arndb.de \
--cc=bhelgaas@google.com \
--cc=davem@davemloft.net \
--cc=geert@linux-m68k.org \
--cc=gxt@mprc.pku.edu.cn \
--cc=jiang.liu@linux.intel.com \
--cc=linux-alpha@vger.kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-ia64@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-m68k@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux@arm.linux.org.uk \
--cc=liviu@dudau.co.uk \
--cc=marc.zyngier@arm.com \
--cc=tglx@linutronix.de \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®