From: Yijing Wang <wangyijing@huawei.com>
To: Bjorn Helgaas <bhelgaas@google.com>
Cc: Jiang Liu <jiang.liu@linux.intel.com>,
<linux-pci@vger.kernel.org>, Yinghai Lu <yinghai@kernel.org>,
<linux-kernel@vger.kernel.org>,
Marc Zyngier <marc.zyngier@arm.com>,
<linux-arm-kernel@lists.infradead.org>,
Russell King <linux@arm.linux.org.uk>, <x86@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>,
Tony Luck <tony.luck@intel.com>, <linux-ia64@vger.kernel.org>,
"David S. Miller" <davem@davemloft.net>,
"Guan Xuetao" <gxt@mprc.pku.edu.cn>,
<linux-alpha@vger.kernel.org>, <linux-m68k@vger.kernel.org>,
Liviu Dudau <liviu@dudau.co.uk>, "Arnd Bergmann" <arnd@arndb.de>,
Geert Uytterhoeven <geert@linux-m68k.org>,
"Yijing Wang" <wangyijing@huawei.com>,
Yijing Wang <wangyijing0307@gmail.com>
Subject: [PATCH 14/28] PCI/IA64: Refine pci_acpi_scan_root() with generic pci_host_bridge
Date: Fri, 16 Jan 2015 09:44:12 +0800 [thread overview]
Message-ID: <1421372666-12288-15-git-send-email-wangyijing@huawei.com> (raw)
In-Reply-To: <1421372666-12288-1-git-send-email-wangyijing@huawei.com>
From: Yijing Wang <wangyijing0307@gmail.com>
Signed-off-by: Yijing Wang <wangyijing@huawei.com>
---
arch/ia64/pci/pci.c | 34 ++++++++++++++++++----------------
1 files changed, 18 insertions(+), 16 deletions(-)
diff --git a/arch/ia64/pci/pci.c b/arch/ia64/pci/pci.c
index e457015..7736c02 100644
--- a/arch/ia64/pci/pci.c
+++ b/arch/ia64/pci/pci.c
@@ -420,6 +420,18 @@ probe_pci_root_info(struct pci_root_info *info, struct acpi_device *device,
return 0;
}
+static int pci_host_bridge_prepare(struct pci_host_bridge *bridge)
+{
+ struct pci_sysdata *sd = dev_get_drvdata(&bridge->dev);
+
+ ACPI_COMPANION_SET(&bridge->dev, sd->companion);
+ return 0;
+}
+
+static struct pci_host_bridge_ops phb_ops = {
+ .phb_prepare = pci_host_bridge_prepare,
+};
+
struct pci_bus *pci_acpi_scan_root(struct acpi_pci_root *root)
{
struct acpi_device *device = root->device;
@@ -428,7 +440,7 @@ struct pci_bus *pci_acpi_scan_root(struct acpi_pci_root *root)
struct pci_controller *controller;
struct pci_root_info *info = NULL;
int busnum = root->secondary.start;
- struct pci_bus *pbus;
+ struct pci_host_bridge *host;
int ret;
controller = alloc_pci_controller(domain);
@@ -465,26 +477,16 @@ struct pci_bus *pci_acpi_scan_root(struct acpi_pci_root *root)
* should handle the case here, but it appears that IA64 hasn't
* such quirk. So we just ignore the case now.
*/
- pbus = pci_create_root_bus(NULL, PCI_DOMBUS(domain, bus),
- &pci_root_ops, controller, &info->resources);
- if (!pbus) {
+ host = pci_scan_root_bridge(NULL, PCI_DOMBUS(domain, bus),
+ &pci_root_ops, controller, &info->resources, &phb_ops);
+ if (!host) {
pci_free_resource_list(&info->resources);
__release_pci_root_info(info);
return NULL;
}
- pci_set_host_bridge_release(to_pci_host_bridge(pbus->bridge),
- release_pci_root_info, info);
- pci_scan_child_bus(pbus);
- return pbus;
-}
-
-int pcibios_root_bridge_prepare(struct pci_host_bridge *bridge)
-{
- struct pci_controller *controller = bridge->bus->sysdata;
-
- ACPI_COMPANION_SET(&bridge->dev, controller->companion);
- return 0;
+ pci_set_host_bridge_release(host, release_pci_root_info, info);
+ return host->bus;
}
static int is_valid_resource(struct pci_dev *dev, int idx)
--
1.7.1
next prev parent reply other threads:[~2015-01-16 3:55 UTC|newest]
Thread overview: 56+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-01-16 1:43 [PATCH 00/28] Refine PCI scan interfaces and make generic pci host bridge Yijing Wang
2015-01-16 1:43 ` [PATCH 01/28] PCI: Rip out pci_bus_add_devices() from pci_scan_bus() Yijing Wang
2015-01-16 23:15 ` Yinghai Lu
2015-01-16 23:16 ` Yinghai Lu
2015-01-19 2:04 ` Yijing Wang
2015-01-19 4:59 ` Greg Ungerer
2015-01-19 8:23 ` Arnd Bergmann
2015-01-16 1:44 ` [PATCH 02/28] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() Yijing Wang
2015-01-16 1:44 ` [PATCH 03/28] xen/PCI: Don't use deprecated function pci_scan_bus_parented() Yijing Wang
2015-01-16 1:44 ` [PATCH 04/28] PCI: Remove deprecated pci_scan_bus_parented() Yijing Wang
2015-01-16 1:44 ` [PATCH 05/28] PCI: Rename pci_scan_bus() to pci_scan_bus_legacy() Yijing Wang
2015-01-16 1:44 ` [PATCH 06/28] PCI: Combine PCI domain and bus number in u32 arg Yijing Wang
2015-01-16 1:44 ` [PATCH 07/28] PCI: Pass PCI domain number combined with root bus number Yijing Wang
2015-01-16 1:44 ` [PATCH 08/28] PCI: Introduce pci_host_assign_domain_nr() to assign domain Yijing Wang
2015-01-16 9:08 ` Arnd Bergmann
2015-01-16 9:40 ` Arnd Bergmann
2015-01-19 2:14 ` Yijing Wang
2015-01-19 9:50 ` Arnd Bergmann
2015-01-19 10:56 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 09/28] PCI: Separate pci_host_bridge creation out of pci_create_root_bus() Yijing Wang
2015-01-16 9:14 ` Arnd Bergmann
2015-01-16 9:34 ` Arnd Bergmann
2015-01-19 2:39 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 10/28] PCI: Save sysdata in pci_host_bridge drvdata Yijing Wang
2015-01-16 9:18 ` Arnd Bergmann
2015-01-19 3:12 ` Yijing Wang
2015-01-19 9:52 ` Arnd Bergmann
2015-01-16 1:44 ` [PATCH 11/28] PCI: Introduce pci_host_bridge_ops to setup host bridge Yijing Wang
2015-01-16 9:23 ` Arnd Bergmann
2015-01-16 9:35 ` Arnd Bergmann
2015-01-16 1:44 ` [PATCH 12/28] PCI: Introduce new scan function pci_scan_root_bridge() Yijing Wang
2015-01-16 1:44 ` [PATCH 13/28] PCI/x86: Refine pci_acpi_scan_root() with generic pci_host_bridge Yijing Wang
2015-01-16 1:44 ` Yijing Wang [this message]
2015-01-16 1:44 ` [PATCH 15/28] PCI/powerpc: Rename pcibios_root_bridge_prepare() for better readability Yijing Wang
2015-01-16 1:44 ` [PATCH 16/28] PCI/powerpc: Use pci_scan_root_bridge() for simplicity Yijing Wang
2015-01-16 1:44 ` [PATCH 17/28] PCI: Remove weak pcibios_root_bridge_prepare() Yijing Wang
2015-01-16 1:44 ` [PATCH 18/28] PCI/sparc: Use pci_scan_root_bridge() for simplicity Yijing Wang
2015-01-16 10:01 ` Arnd Bergmann
2015-01-19 3:17 ` Yijing Wang
2015-01-19 8:44 ` Arnd Bergmann
2015-01-19 10:53 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 19/28] PCI: Introduce pci_bus_child_max_busnr() Yijing Wang
2015-01-16 1:44 ` [PATCH 20/28] PCI/Parisc: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-01-16 1:44 ` [PATCH 21/28] PCI/mvebu: Use pci_common_init_dev() to simplify code Yijing Wang
2015-01-16 1:44 ` [PATCH 22/28] PCI/tegra: Remove redundant tegra_pcie_scan_bus() Yijing Wang
2015-01-16 1:44 ` [PATCH 23/28] PCI/designware: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-01-17 16:39 ` Sergei Shtylyov
2015-01-19 3:17 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 24/28] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() Yijing Wang
2015-01-16 1:44 ` [PATCH 25/28] PCI: Rename __pci_create_root_bus() to pci_create_root_bus() Yijing Wang
2015-01-16 1:44 ` [PATCH 26/28] PCI: Export find_pci_host_bridge() Yijing Wang
2015-01-16 1:44 ` [PATCH 27/28] PCI: Remove platform specific pci_domain_nr() Yijing Wang
2015-01-16 9:44 ` Arnd Bergmann
2015-01-19 3:19 ` Yijing Wang
2015-01-16 1:44 ` [PATCH 28/28] PCI: Remove pci_bus_assign_domain_nr() Yijing Wang
2015-01-16 10:12 ` [PATCH 00/28] Refine PCI scan interfaces and make generic pci host bridge Arnd Bergmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1421372666-12288-15-git-send-email-wangyijing@huawei.com \
--to=wangyijing@huawei.com \
--cc=arnd@arndb.de \
--cc=bhelgaas@google.com \
--cc=davem@davemloft.net \
--cc=geert@linux-m68k.org \
--cc=gxt@mprc.pku.edu.cn \
--cc=jiang.liu@linux.intel.com \
--cc=linux-alpha@vger.kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-ia64@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-m68k@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux@arm.linux.org.uk \
--cc=liviu@dudau.co.uk \
--cc=marc.zyngier@arm.com \
--cc=tglx@linutronix.de \
--cc=tony.luck@intel.com \
--cc=wangyijing0307@gmail.com \
--cc=x86@kernel.org \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®