mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Yijing Wang <wangyijing@huawei.com>
To: Bjorn Helgaas <bhelgaas@google.com>
Cc: Jiang Liu <jiang.liu@linux.intel.com>,
	<linux-pci@vger.kernel.org>, Yinghai Lu <yinghai@kernel.org>,
	<linux-kernel@vger.kernel.org>,
	Marc Zyngier <marc.zyngier@arm.com>,
	<linux-arm-kernel@lists.infradead.org>,
	Russell King <linux@arm.linux.org.uk>, <x86@kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	Tony Luck <tony.luck@intel.com>, <linux-ia64@vger.kernel.org>,
	"David S. Miller" <davem@davemloft.net>,
	"Guan Xuetao" <gxt@mprc.pku.edu.cn>,
	<linux-alpha@vger.kernel.org>, <linux-m68k@vger.kernel.org>,
	Liviu Dudau <liviu@dudau.co.uk>, "Arnd Bergmann" <arnd@arndb.de>,
	Geert Uytterhoeven <geert@linux-m68k.org>,
	"Yijing Wang" <wangyijing@huawei.com>,
	<sparclinux@vger.kernel.org>
Subject: [PATCH 01/28] PCI: Rip out pci_bus_add_devices() from pci_scan_bus()
Date: Fri, 16 Jan 2015 09:43:59 +0800	[thread overview]
Message-ID: <1421372666-12288-2-git-send-email-wangyijing@huawei.com> (raw)
In-Reply-To: <1421372666-12288-1-git-send-email-wangyijing@huawei.com>

Pci_bus_add_devices() should not be placed in pci_scan_bus().
Now pci device will be added to driver core once its
creation. All things left in pci_bus_add_devices() are
driver attachment and other trivial sysfs things.
Pci_scan_bus() should be the function responsible for
scanning PCI devices, not including driver attachment.
Other, some callers(m68k,unicore32,alpha) of pci_scan_bus()
will call pci_bus_size_bridges() and pci_bus_assign_resources()
after pci_scan_bus().

E.g.
In m68k
mcf_pci_init()
	pci_scan_bus()
		...
		pci_bus_add_devices() --- try to attach driver
	pci_fixup_irqs()
	pci_bus_size_bridges()
	pci_bus_assign_resources()

It is not correct, resources should be assigned correctly
before attaching driver.
So we should rip out pci_bus_add_devices() for better
code design. After applied this patch, pci_scan_bus()
should be used in flow like:

pci_scan_bus() (mandatory)
pci_fixup_irqs() (optional)
pci_bus_size_bridges() (optional)
pci_pci_bus_assign_resources() (optional)
pci_bus_add_devices() (mandatory)

Signed-off-by: Yijing Wang <wangyijing@huawei.com>
CC: "David S. Miller" <davem@davemloft.net>
CC: Geert Uytterhoeven <geert@linux-m68k.org>
CC: Guan Xuetao <gxt@mprc.pku.edu.cn>
CC: linux-alpha@vger.kernel.org
CC: linux-m68k@lists.linux-m68k.org
CC: sparclinux@vger.kernel.org
---
 arch/alpha/kernel/sys_nautilus.c  |    1 +
 arch/m68k/coldfire/pci.c          |    1 +
 arch/sparc/kernel/pcic.c          |    2 ++
 arch/unicore32/kernel/pci.c       |   11 +++--------
 drivers/pci/hotplug/ibmphp_core.c |    6 ++++--
 drivers/pci/probe.c               |    1 -
 6 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/arch/alpha/kernel/sys_nautilus.c b/arch/alpha/kernel/sys_nautilus.c
index 837c0fa..4ae4a40 100644
--- a/arch/alpha/kernel/sys_nautilus.c
+++ b/arch/alpha/kernel/sys_nautilus.c
@@ -253,6 +253,7 @@ nautilus_init_pci(void)
 	   for the root bus, so just clear it. */
 	bus->self = NULL;
 	pci_fixup_irqs(alpha_mv.pci_swizzle, alpha_mv.pci_map_irq);
+	pci_bus_add_devices(bus);
 }
 
 /*
diff --git a/arch/m68k/coldfire/pci.c b/arch/m68k/coldfire/pci.c
index df96792..d45f087 100644
--- a/arch/m68k/coldfire/pci.c
+++ b/arch/m68k/coldfire/pci.c
@@ -319,6 +319,7 @@ static int __init mcf_pci_init(void)
 	pci_fixup_irqs(pci_common_swizzle, mcf_pci_map_irq);
 	pci_bus_size_bridges(rootbus);
 	pci_bus_assign_resources(rootbus);
+	pci_bus_add_devices(rootbus);
 	return 0;
 }
 
diff --git a/arch/sparc/kernel/pcic.c b/arch/sparc/kernel/pcic.c
index 6cc78c2..7a82fe2 100644
--- a/arch/sparc/kernel/pcic.c
+++ b/arch/sparc/kernel/pcic.c
@@ -391,6 +391,8 @@ static void __init pcic_pbm_scan_bus(struct linux_pcic *pcic)
 	struct linux_pbm_info *pbm = &pcic->pbm;
 
 	pbm->pci_bus = pci_scan_bus(pbm->pci_first_busno, &pcic_ops, pbm);
+	if (pbm->pci_bus)
+		pci_bus_add_devices(pbm->pci_bus);
 #if 0 /* deadwood transplanted from sparc64 */
 	pci_fill_in_pbm_cookies(pbm->pci_bus, pbm, pbm->prom_node);
 	pci_record_assignments(pbm, pbm->pci_bus);
diff --git a/arch/unicore32/kernel/pci.c b/arch/unicore32/kernel/pci.c
index 374a055..3d82024 100644
--- a/arch/unicore32/kernel/pci.c
+++ b/arch/unicore32/kernel/pci.c
@@ -266,17 +266,12 @@ static int __init pci_common_init(void)
 	pci_fixup_irqs(pci_common_swizzle, pci_puv3_map_irq);
 
 	if (!pci_has_flag(PCI_PROBE_ONLY)) {
-		/*
-		 * Size the bridge windows.
-		 */
+		/* Size the bridge windows. */
 		pci_bus_size_bridges(puv3_bus);
-
-		/*
-		 * Assign resources.
-		 */
+		/* Assign resources. */
 		pci_bus_assign_resources(puv3_bus);
 	}
-
+	pci_bus_add_devices(puv3_bus);
 	return 0;
 }
 subsys_initcall(pci_common_init);
diff --git a/drivers/pci/hotplug/ibmphp_core.c b/drivers/pci/hotplug/ibmphp_core.c
index 96c5c72..86e3bfd 100644
--- a/drivers/pci/hotplug/ibmphp_core.c
+++ b/drivers/pci/hotplug/ibmphp_core.c
@@ -738,7 +738,7 @@ static void ibm_unconfigure_device(struct pci_func *func)
  */
 static u8 bus_structure_fixup(u8 busno)
 {
-	struct pci_bus *bus;
+	struct pci_bus *bus, *b;
 	struct pci_dev *dev;
 	u16 l;
 
@@ -765,7 +765,9 @@ static u8 bus_structure_fixup(u8 busno)
 					(l != 0x0000) && (l != 0xffff)) {
 			debug("%s - Inside bus_structure_fixup()\n",
 							__func__);
-			pci_scan_bus(busno, ibmphp_pci_bus->ops, NULL);
+			b = pci_scan_bus(busno, ibmphp_pci_bus->ops, NULL);
+			if (b)
+				pci_bus_add_devices(b);
 			break;
 		}
 	}
diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
index 23212f8..053c0f4 100644
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
@@ -2123,7 +2123,6 @@ struct pci_bus *pci_scan_bus(int bus, struct pci_ops *ops,
 	b = pci_create_root_bus(NULL, bus, ops, sysdata, &resources);
 	if (b) {
 		pci_scan_child_bus(b);
-		pci_bus_add_devices(b);
 	} else {
 		pci_free_resource_list(&resources);
 	}
-- 
1.7.1


  reply	other threads:[~2015-01-16  3:51 UTC|newest]

Thread overview: 56+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-01-16  1:43 [PATCH 00/28] Refine PCI scan interfaces and make generic pci host bridge Yijing Wang
2015-01-16  1:43 ` Yijing Wang [this message]
2015-01-16 23:15   ` [PATCH 01/28] PCI: Rip out pci_bus_add_devices() from pci_scan_bus() Yinghai Lu
2015-01-16 23:16     ` Yinghai Lu
2015-01-19  2:04       ` Yijing Wang
2015-01-19  4:59         ` Greg Ungerer
2015-01-19  8:23       ` Arnd Bergmann
2015-01-16  1:44 ` [PATCH 02/28] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() Yijing Wang
2015-01-16  1:44 ` [PATCH 03/28] xen/PCI: Don't use deprecated function pci_scan_bus_parented() Yijing Wang
2015-01-16  1:44 ` [PATCH 04/28] PCI: Remove deprecated pci_scan_bus_parented() Yijing Wang
2015-01-16  1:44 ` [PATCH 05/28] PCI: Rename pci_scan_bus() to pci_scan_bus_legacy() Yijing Wang
2015-01-16  1:44 ` [PATCH 06/28] PCI: Combine PCI domain and bus number in u32 arg Yijing Wang
2015-01-16  1:44 ` [PATCH 07/28] PCI: Pass PCI domain number combined with root bus number Yijing Wang
2015-01-16  1:44 ` [PATCH 08/28] PCI: Introduce pci_host_assign_domain_nr() to assign domain Yijing Wang
2015-01-16  9:08   ` Arnd Bergmann
2015-01-16  9:40     ` Arnd Bergmann
2015-01-19  2:14       ` Yijing Wang
2015-01-19  9:50         ` Arnd Bergmann
2015-01-19 10:56           ` Yijing Wang
2015-01-16  1:44 ` [PATCH 09/28] PCI: Separate pci_host_bridge creation out of pci_create_root_bus() Yijing Wang
2015-01-16  9:14   ` Arnd Bergmann
2015-01-16  9:34   ` Arnd Bergmann
2015-01-19  2:39     ` Yijing Wang
2015-01-16  1:44 ` [PATCH 10/28] PCI: Save sysdata in pci_host_bridge drvdata Yijing Wang
2015-01-16  9:18   ` Arnd Bergmann
2015-01-19  3:12     ` Yijing Wang
2015-01-19  9:52       ` Arnd Bergmann
2015-01-16  1:44 ` [PATCH 11/28] PCI: Introduce pci_host_bridge_ops to setup host bridge Yijing Wang
2015-01-16  9:23   ` Arnd Bergmann
2015-01-16  9:35     ` Arnd Bergmann
2015-01-16  1:44 ` [PATCH 12/28] PCI: Introduce new scan function pci_scan_root_bridge() Yijing Wang
2015-01-16  1:44 ` [PATCH 13/28] PCI/x86: Refine pci_acpi_scan_root() with generic pci_host_bridge Yijing Wang
2015-01-16  1:44 ` [PATCH 14/28] PCI/IA64: " Yijing Wang
2015-01-16  1:44 ` [PATCH 15/28] PCI/powerpc: Rename pcibios_root_bridge_prepare() for better readability Yijing Wang
2015-01-16  1:44 ` [PATCH 16/28] PCI/powerpc: Use pci_scan_root_bridge() for simplicity Yijing Wang
2015-01-16  1:44 ` [PATCH 17/28] PCI: Remove weak pcibios_root_bridge_prepare() Yijing Wang
2015-01-16  1:44 ` [PATCH 18/28] PCI/sparc: Use pci_scan_root_bridge() for simplicity Yijing Wang
2015-01-16 10:01   ` Arnd Bergmann
2015-01-19  3:17     ` Yijing Wang
2015-01-19  8:44       ` Arnd Bergmann
2015-01-19 10:53         ` Yijing Wang
2015-01-16  1:44 ` [PATCH 19/28] PCI: Introduce pci_bus_child_max_busnr() Yijing Wang
2015-01-16  1:44 ` [PATCH 20/28] PCI/Parisc: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-01-16  1:44 ` [PATCH 21/28] PCI/mvebu: Use pci_common_init_dev() to simplify code Yijing Wang
2015-01-16  1:44 ` [PATCH 22/28] PCI/tegra: Remove redundant tegra_pcie_scan_bus() Yijing Wang
2015-01-16  1:44 ` [PATCH 23/28] PCI/designware: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-01-17 16:39   ` Sergei Shtylyov
2015-01-19  3:17     ` Yijing Wang
2015-01-16  1:44 ` [PATCH 24/28] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() Yijing Wang
2015-01-16  1:44 ` [PATCH 25/28] PCI: Rename __pci_create_root_bus() to pci_create_root_bus() Yijing Wang
2015-01-16  1:44 ` [PATCH 26/28] PCI: Export find_pci_host_bridge() Yijing Wang
2015-01-16  1:44 ` [PATCH 27/28] PCI: Remove platform specific pci_domain_nr() Yijing Wang
2015-01-16  9:44   ` Arnd Bergmann
2015-01-19  3:19     ` Yijing Wang
2015-01-16  1:44 ` [PATCH 28/28] PCI: Remove pci_bus_assign_domain_nr() Yijing Wang
2015-01-16 10:12 ` [PATCH 00/28] Refine PCI scan interfaces and make generic pci host bridge Arnd Bergmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1421372666-12288-2-git-send-email-wangyijing@huawei.com \
    --to=wangyijing@huawei.com \
    --cc=arnd@arndb.de \
    --cc=bhelgaas@google.com \
    --cc=davem@davemloft.net \
    --cc=geert@linux-m68k.org \
    --cc=gxt@mprc.pku.edu.cn \
    --cc=jiang.liu@linux.intel.com \
    --cc=linux-alpha@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-m68k@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linux@arm.linux.org.uk \
    --cc=liviu@dudau.co.uk \
    --cc=marc.zyngier@arm.com \
    --cc=sparclinux@vger.kernel.org \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    --cc=yinghai@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®