From: Ian Kent <ikent@redhat.com>
To: Jeff Layton <jeff.layton@primarydata.com>
Cc: Kernel Mailing List <linux-kernel@vger.kernel.org>,
David Howells <dhowells@redhat.com>,
Oleg Nesterov <onestero@redhat.com>,
Trond Myklebust <trond.myklebust@primarydata.com>,
"J. Bruce Fields" <bfields@fieldses.org>,
Benjamin Coddington <bcodding@redhat.com>,
Al Viro <viro@ZenIV.linux.org.uk>,
"Eric W. Biederman" <ebiederm@xmission.com>
Subject: Re: [RFC PATCH 3/8] kmod - teach call_usermodehelper() to use a namespace
Date: Sun, 08 Feb 2015 11:07:32 +0800 [thread overview]
Message-ID: <1423364852.2641.2.camel@pluto.fritz.box> (raw)
In-Reply-To: <20150206070859.7eb499b0@tlielax.poochiereds.net>
On Fri, 2015-02-06 at 07:08 -0500, Jeff Layton wrote:
> On Thu, 05 Feb 2015 10:34:11 +0800
> Ian Kent <ikent@redhat.com> wrote:
>
> > The call_usermodehelper() function executes all binaries in the
> > global "init" root context. This doesn't allow a binary to be run
> > within a namespace (eg. the namespace of a container).
> >
> > Both containerized NFS client and NFS server need the ability to
> > execute a binary in a container's context. To do this use the init
> > process of the callers environment is used to setup the namespaces
> > in the same way the root init process is used otherwise.
> >
> > Signed-off-by: Ian Kent <ikent@redhat.com>
> > Cc: Benjamin Coddington <bcodding@redhat.com>
> > Cc: Al Viro <viro@ZenIV.linux.org.uk>
> > Cc: J. Bruce Fields <bfields@fieldses.org>
> > Cc: David Howells <dhowells@redhat.com>
> > Cc: Trond Myklebust <trond.myklebust@primarydata.com>
> > Cc: Oleg Nesterov <onestero@redhat.com>
> > Cc: Eric W. Biederman <ebiederm@xmission.com>
> > Cc: Jeff Layton <jeff.layton@primarydata.com>
> > ---
> > include/linux/kmod.h | 16 +++++++
> > kernel/kmod.c | 115 +++++++++++++++++++++++++++++++++++++++++++++++++-
> > 2 files changed, 128 insertions(+), 3 deletions(-)
> >
> > diff --git a/include/linux/kmod.h b/include/linux/kmod.h
> > index 15bdeed..b0f1b3c 100644
> > --- a/include/linux/kmod.h
> > +++ b/include/linux/kmod.h
> > @@ -52,6 +52,7 @@ struct file;
> > #define UMH_WAIT_EXEC 1 /* wait for the exec, but not the process */
> > #define UMH_WAIT_PROC 2 /* wait for the process to complete */
> > #define UMH_KILLABLE 4 /* wait for EXEC/PROC killable */
> > +#define UMH_USE_NS 8 /* exec using caller's init namespace */
> >
> > struct subprocess_info {
> > struct work_struct work;
> > @@ -69,6 +70,21 @@ struct subprocess_info {
> > extern int
> > call_usermodehelper(char *path, char **argv, char **envp, int flags);
> >
> > +#if !defined(CONFIG_PROC_FS) || !defined(CONFIG_NAMESPACES)
> > +inline struct task_struct *umh_get_init_task(void)
> > +{
> > + return ERR_PTR(-ENOTSUP);
> > +}
> > +
> > +inline int umh_enter_ns(struct task_struct *tsk, struct cred *new)
> > +{
> > + return -ENOTSUP;
> > +}
> > +#else
> > +struct task_struct *umh_get_init_pid(void);
> > +int umh_enter_ns(struct task_struct *tsk, struct cred *new);
> > +#endif
> > +
> > extern struct subprocess_info *
> > call_usermodehelper_setup(char *path, char **argv, char **envp, gfp_t gfp_mask,
> > int (*init)(struct subprocess_info *info, struct cred *new),
> > diff --git a/kernel/kmod.c b/kernel/kmod.c
> > index 14c0188..4c649d6 100644
> > --- a/kernel/kmod.c
> > +++ b/kernel/kmod.c
> > @@ -582,6 +582,98 @@ unlock:
> > }
> > EXPORT_SYMBOL(call_usermodehelper_exec);
> >
> > +#if defined(CONFIG_PROC_FS) && defined(CONFIG_NAMESPACES)
> > +#define NS_PATH_MAX 35
> > +#define NS_PATH_FMT "%lu/ns/%s"
> > +
> > +/* Note namespace name order is significant */
> > +static const char *ns_names[] = { "user", "ipc", "uts", "net", "pid", "mnt", NULL };
> > +
> > +struct task_struct *umh_get_init_pid(void)
>
> nit: we're not getting a pid here but a task_struct pointer. Maybe this
> should be called umh_get_init_task?
Ha, yep.
>
> > +{
> > + struct task_struct *tsk;
> > +
> > + rcu_read_lock();
> > + tsk = find_task_by_vpid(1);
> > + if (tsk)
> > + get_task_struct(tsk);
> > + rcu_read_unlock();
>
> I'm not terribly familiar with the task_struct lifetime rules...
>
> I assume that you can be assured that tsk won't go away while you hold
> the rcu_read_lock, but is doing a get_task_struct while holding it
> sufficient to pin it after you drop the lock?
>
> IOW, could the refcount on the task_struct do a 0->1 transition here and
> end up being freed anyway after you've grabbed a reference?
Good point, I thought getting a reference under he read lock would be
enough but maybe I need more checks as I do with dentrys. I'll check
that.
Ian
next prev parent reply other threads:[~2015-02-08 3:07 UTC|newest]
Thread overview: 48+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-02-05 2:33 [RFC PATCH 0/8] v3 contained usermode helper execution Ian Kent
2015-02-05 2:33 ` [RFC PATCH 1/8] nsproxy - refactor setns() Ian Kent
2015-02-05 2:34 ` [RFC PATCH 2/8] kmod - rename call_usermodehelper() flags parameter Ian Kent
2015-02-05 2:34 ` [RFC PATCH 3/8] kmod - teach call_usermodehelper() to use a namespace Ian Kent
2015-02-06 12:08 ` Jeff Layton
2015-02-08 3:07 ` Ian Kent [this message]
2015-02-08 15:22 ` Jeff Layton
2015-02-08 18:12 ` Oleg Nesterov
2015-02-08 19:00 ` Oleg Nesterov
2015-02-09 1:43 ` Ian Kent
2015-02-09 16:03 ` Oleg Nesterov
2015-02-10 0:08 ` Ian Kent
2015-02-10 16:55 ` Oleg Nesterov
2015-02-11 0:40 ` Ian Kent
2015-02-16 6:16 ` Ian Kent
2015-02-16 17:13 ` Oleg Nesterov
2015-02-16 18:24 ` Oleg Nesterov
2015-02-18 2:09 ` Ian Kent
2015-02-18 1:42 ` Ian Kent
2015-02-05 2:34 ` [RFC PATCH 4/8] KEYS - rename call_usermodehelper_keys() flags parameter Ian Kent
2015-02-05 2:34 ` [RFC PATCH 5/8] KEYS: exec request-key within the requesting task's init namespace Ian Kent
2015-02-05 2:34 ` [RFC PATCH 6/8] nfsd - use namespace if not executing in " Ian Kent
2015-02-18 17:37 ` J. Bruce Fields
2015-02-05 2:34 ` [RFC PATCH 7/8] nfs - cache_lib " Ian Kent
2015-02-05 2:34 ` [RFC PATCH 8/8] nfs - objlayout " Ian Kent
2015-02-05 15:01 ` [RFC PATCH 2/8] kmod - rename call_usermodehelper() flags parameter David Howells
2015-02-06 0:01 ` Ian Kent
2015-02-05 15:14 ` [RFC PATCH 5/8] KEYS: exec request-key within the requesting task's init namespace David Howells
2015-02-06 1:47 ` Ian Kent
2015-02-18 17:06 ` J. Bruce Fields
2015-02-18 17:31 ` J. Bruce Fields
2015-02-18 20:59 ` J. Bruce Fields
2015-02-19 0:39 ` Ian Kent
2015-02-19 1:31 ` J. Bruce Fields
2015-02-19 3:18 ` Ian Kent
2015-02-20 9:33 ` Ian Kent
2015-02-20 17:25 ` J. Bruce Fields
2015-02-20 18:07 ` Eric W. Biederman
2015-02-20 18:58 ` Jeff Layton
2015-02-20 19:05 ` J. Bruce Fields
2015-02-21 3:58 ` Ian Kent
2015-02-23 14:52 ` J. Bruce Fields
2015-02-24 0:50 ` Ian Kent
2015-02-24 1:22 ` Benjamin Coddington
2015-02-24 8:01 ` Ian Kent
2015-02-24 15:33 ` J. Bruce Fields
2015-02-25 0:41 ` Benjamin Coddington
2015-02-05 15:24 ` [RFC PATCH 3/8] kmod - teach call_usermodehelper() to use a namespace David Howells
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1423364852.2641.2.camel@pluto.fritz.box \
--to=ikent@redhat.com \
--cc=bcodding@redhat.com \
--cc=bfields@fieldses.org \
--cc=dhowells@redhat.com \
--cc=ebiederm@xmission.com \
--cc=jeff.layton@primarydata.com \
--cc=linux-kernel@vger.kernel.org \
--cc=onestero@redhat.com \
--cc=trond.myklebust@primarydata.com \
--cc=viro@ZenIV.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome