mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Wang Long <long.wanglong@huawei.com>
To: <gaurav.minocha.os@gmail.com>, <robherring2@gmail.com>,
	<pantelis.antoniou@konsulko.com>, <grant.likely@linaro.org>
Cc: <pawel.moll@arm.com>, <mark.rutland@arm.com>,
	<galak@codeaurora.org>, <devicetree@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <peifeiyue@huawei.com>,
	<long.wanglong@huawei.com>, <ijc+devicetree@hellion.org.uk>
Subject: [PATCH v3 0/3] replace 'selftest' with 'unittest' and update the document.
Date: Tue, 17 Mar 2015 03:19:57 +0000	[thread overview]
Message-ID: <1426562400-102415-1-git-send-email-long.wanglong@huawei.com> (raw)

This series patches replace 'selftest' with 'unittest' in the 
OF unittest, and update the document.

the first patch comes from Gaurav Minocha, and i update it. because
it can not apply on linux 4.0-rc4 when using 'git am' command.


* v3 <- v2:
	- Rebase the patch on 4.0-rc4
	- Re-adjust the sequence of the patches

* v2 <- v1:
	- According to Gaurav's advice. make the rename
	file patch correctly.

Wang Long (3):
  of/unittest: replace 'selftest' with 'unittest'
  Documentation: rename of_selftest.txt to of_unittest.txt
  Documentation: update the of_unittest.txt

 Documentation/devicetree/bindings/unittest.txt     |  44 +-
 .../{of_selftest.txt => of_unittest.txt}           |  35 +-
 drivers/of/unittest-data/tests-overlay.dtsi        | 108 ++--
 drivers/of/unittest.c                              | 706 ++++++++++-----------
 4 files changed, 447 insertions(+), 446 deletions(-)
 rename Documentation/devicetree/{of_selftest.txt => of_unittest.txt} (87%)

-- 
1.8.3.4


             reply	other threads:[~2015-03-17  3:20 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-17  3:19 Wang Long [this message]
2015-03-17  3:19 ` [PATCH v3 1/3] of/unittest: replace 'selftest' with 'unittest' Wang Long
2015-03-28  4:09   ` Grant Likely
2015-03-17  3:19 ` [PATCH v3 2/3] Documentation: rename of_selftest.txt to of_unittest.txt Wang Long
2015-03-28  4:11   ` Grant Likely
2015-03-17  3:20 ` [PATCH v3 3/3] Documentation: update the of_unittest.txt Wang Long
2015-03-28  4:11   ` Grant Likely

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1426562400-102415-1-git-send-email-long.wanglong@huawei.com \
    --to=long.wanglong@huawei.com \
    --cc=devicetree@vger.kernel.org \
    --cc=galak@codeaurora.org \
    --cc=gaurav.minocha.os@gmail.com \
    --cc=grant.likely@linaro.org \
    --cc=ijc+devicetree@hellion.org.uk \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=pantelis.antoniou@konsulko.com \
    --cc=pawel.moll@arm.com \
    --cc=peifeiyue@huawei.com \
    --cc=robherring2@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®