From: Bartosz Golaszewski <bgolaszewski@baylibre.com>
To: LKML <linux-kernel@vger.kernel.org>
Cc: Guenter Roeck <linux@roeck-us.net>,
lm-sensors <lm-sensors@lm-sensors.org>,
Andrew Morton <akpm@linux-foundation.org>,
Steven Rostedt <rostedt@goodmis.org>,
Bartosz Golaszewski <bgolaszewski@baylibre.com>
Subject: [PATCH v4 0/5] new macro: find_closest()
Date: Thu, 19 Mar 2015 18:27:40 +0100 [thread overview]
Message-ID: <1426786065-9798-1-git-send-email-bgolaszewski@baylibre.com> (raw)
This series proposes to unduplicate the code used to find the
member in an array closest to 'x'.
The first patch adds a macro implementing the algorithm in two
flavors - for arrays sorted in ascending and descending order.
The second updates Documentation/CodingStyle on the naming
convention for local variables in macros resembling functions.
Other three patches replace duplicated code with calls to one
of these macros in some hwmon drivers.
v4:
- use >= instead of > in find_closest_descending()
- fix kernel docs
- make local variables in added macros less likely to cause namespace
collisions
- use consistent statement expression syntax
v3:
https://lkml.org/lkml/2015/3/19/369
v2:
https://lkml.org/lkml/2015/3/10/582
v1:
https://lkml.org/lkml/2015/2/24/509
Bartosz Golaszewski (5):
util_macros.h: add find_closest() macro
documentation: update CodingStyle on local variables naming in macros
hwmon: (ina2xx) replace ina226_avg_bits() with find_closest()
hwmon: (lm85) use find_closest() in x_TO_REG() functions
hwmon: (w83795) use find_closest_descending() in pwm_freq_to_reg()
Documentation/CodingStyle | 13 +++++++++++++
drivers/hwmon/ina2xx.c | 17 +++--------------
drivers/hwmon/lm85.c | 26 ++++++++------------------
drivers/hwmon/w83795.c | 8 +++-----
include/linux/util_macros.h | 40 ++++++++++++++++++++++++++++++++++++++++
5 files changed, 67 insertions(+), 37 deletions(-)
create mode 100644 include/linux/util_macros.h
--
2.1.4
next reply other threads:[~2015-03-19 17:27 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-03-19 17:27 Bartosz Golaszewski [this message]
2015-03-19 17:27 ` [PATCH v4 1/5] util_macros.h: add find_closest() macro Bartosz Golaszewski
2015-03-20 20:49 ` Andrew Morton
2015-03-19 17:27 ` [PATCH v4 2/5] documentation: update CodingStyle on local variables naming in macros Bartosz Golaszewski
2015-03-19 23:22 ` Joe Perches
2015-03-19 17:27 ` [PATCH v4 3/5] hwmon: (ina2xx) replace ina226_avg_bits() with find_closest() Bartosz Golaszewski
2015-03-19 17:27 ` [PATCH v4 4/5] hwmon: (lm85) use find_closest() in x_TO_REG() functions Bartosz Golaszewski
2015-03-19 17:27 ` [PATCH v4 5/5] hwmon: (w83795) use find_closest_descending() in pwm_freq_to_reg() Bartosz Golaszewski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1426786065-9798-1-git-send-email-bgolaszewski@baylibre.com \
--to=bgolaszewski@baylibre.com \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=lm-sensors@lm-sensors.org \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome