From: John Stultz <john.stultz@linaro.org>
To: linux-kernel@vger.kernel.org
Cc: John Stultz <john.stultz@linaro.org>,
Prarit Bhargava <prarit@redhat.com>,
Daniel Bristot de Oliveira <bristot@redhat.com>,
Richard Cochran <richardcochran@gmail.com>,
Jan Kara <jack@suse.cz>, Jiri Bohac <jbohac@suse.cz>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>
Subject: [PATCH 2/5] ntp: Introduce and use SECS_PER_DAY macro instead of 86400
Date: Thu, 11 Jun 2015 15:54:54 -0700 [thread overview]
Message-ID: <1434063297-28657-3-git-send-email-john.stultz@linaro.org> (raw)
In-Reply-To: <1434063297-28657-1-git-send-email-john.stultz@linaro.org>
Currently the leapsecond logic uses what looks like magic values.
Improve this by defining SECS_PER_DAY and using that macro
to make the logic more clear.
Cc: Prarit Bhargava <prarit@redhat.com>
Cc: Daniel Bristot de Oliveira <bristot@redhat.com>
Cc: Richard Cochran <richardcochran@gmail.com>
Cc: Jan Kara <jack@suse.cz>
Cc: Jiri Bohac <jbohac@suse.cz>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Ingo Molnar <mingo@redhat.com>
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
kernel/time/ntp.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/kernel/time/ntp.c b/kernel/time/ntp.c
index 7a68100..7aa2161 100644
--- a/kernel/time/ntp.c
+++ b/kernel/time/ntp.c
@@ -35,6 +35,7 @@ unsigned long tick_nsec;
static u64 tick_length;
static u64 tick_length_base;
+#define SECS_PER_DAY 86400
#define MAX_TICKADJ 500LL /* usecs */
#define MAX_TICKADJ_SCALED \
(((MAX_TICKADJ * NSEC_PER_USEC) << NTP_SCALE_SHIFT) / NTP_INTERVAL_FREQ)
@@ -390,7 +391,7 @@ int second_overflow(unsigned long secs)
case TIME_INS:
if (!(time_status & STA_INS))
time_state = TIME_OK;
- else if (secs % 86400 == 0) {
+ else if (secs % SECS_PER_DAY == 0) {
leap = -1;
time_state = TIME_OOP;
printk(KERN_NOTICE
@@ -400,7 +401,7 @@ int second_overflow(unsigned long secs)
case TIME_DEL:
if (!(time_status & STA_DEL))
time_state = TIME_OK;
- else if ((secs + 1) % 86400 == 0) {
+ else if ((secs + 1) % SECS_PER_DAY == 0) {
leap = 1;
time_state = TIME_WAIT;
printk(KERN_NOTICE
--
1.9.1
next prev parent reply other threads:[~2015-06-11 22:56 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-06-11 22:54 [PATCH 0/5 v2] Fixes for leapsecond expiring early ABS_TIME CLOCK_REALTIME timers John Stultz
2015-06-11 22:54 ` [PATCH 1/5] time: Move clock_was_set_seq update to before we update the shadow-timekeeper John Stultz
2015-06-12 9:31 ` [tip:timers/core] time: Move clock_was_set_seq update before updating shadow-timekeeper tip-bot for John Stultz
2015-06-11 22:54 ` John Stultz [this message]
2015-06-12 9:31 ` [tip:timers/core] ntp: Introduce and use SECS_PER_DAY macro instead of 86400 tip-bot for John Stultz
2015-06-11 22:54 ` [PATCH 3/5] time: Do leapsecond adjustment to avoid early timer expirations John Stultz
2015-06-12 9:32 ` [tip:timers/core] time: Prevent early expiry of hrtimers[ CLOCK_REALTIME] at the leap second edge tip-bot for John Stultz
2015-06-11 22:54 ` [PATCH 4/5] ntp: Do leapsecond adjustment in adjtimex read path John Stultz
2015-06-12 7:37 ` Richard Cochran
2015-06-12 9:32 ` [tip:timers/core] " tip-bot for John Stultz
2015-06-11 22:54 ` [PATCH 5/5] selftests: timers: Add leap-second timer edge testing to leap-a-day.c John Stultz
2015-06-12 9:32 ` [tip:timers/core] " tip-bot for John Stultz
2015-06-12 14:52 ` [PATCH 0/5 v2] Fixes for leapsecond expiring early ABS_TIME CLOCK_REALTIME timers Dave Jones
2015-06-12 14:55 ` Prarit Bhargava
2015-06-12 14:59 ` Dave Jones
2015-06-12 15:02 ` Prarit Bhargava
2015-06-12 17:58 ` John Stultz
2015-06-12 18:06 ` John Stultz
2015-06-12 18:11 ` Thomas Gleixner
2015-06-13 7:17 ` Ingo Molnar
2015-06-15 13:10 ` Prarit Bhargava
2015-06-15 13:46 ` Prarit Bhargava
2015-06-15 18:55 ` John Stultz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1434063297-28657-3-git-send-email-john.stultz@linaro.org \
--to=john.stultz@linaro.org \
--cc=bristot@redhat.com \
--cc=jack@suse.cz \
--cc=jbohac@suse.cz \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=prarit@redhat.com \
--cc=richardcochran@gmail.com \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®