mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Borislav Petkov <bp@alien8.de>
To: Ingo Molnar <mingo@kernel.org>
Cc: LKML <linux-kernel@vger.kernel.org>
Subject: [PATCH 09/19] staging/lirc_serial: Remove TSC-based timing
Date: Thu, 25 Jun 2015 18:44:03 +0200	[thread overview]
Message-ID: <1435250653-30182-10-git-send-email-bp@alien8.de> (raw)
In-Reply-To: <1435250653-30182-1-git-send-email-bp@alien8.de>

From: Andy Lutomirski <luto@kernel.org>

It wasn't compiled in by default. I suspect that the driver was and
still is broken, though -- it's calling udelay with a parameter that's
derived from loops_per_jiffy.

Signed-off-by: Andy Lutomirski <luto@kernel.org>
Cc: Denys Vlasenko <dvlasenk@redhat.com>
Cc: devel@driverdev.osuosl.org
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Huang Rui <ray.huang@amd.com>
Cc: Jarod Wilson <jarod@wilsonet.com>
Cc: John Stultz <john.stultz@linaro.org>
Cc: kvm ML <kvm@vger.kernel.org>
Cc: Len Brown <lenb@kernel.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Ralf Baechle <ralf@linux-mips.org>
Cc: x86-ml <x86@kernel.org>
Link: http://lkml.kernel.org/r/c95df47c5405b494d19d20b2852a9378c9f661f3.1434501121.git.luto@kernel.org
Signed-off-by: Borislav Petkov <bp@suse.de>
---
 drivers/staging/media/lirc/lirc_serial.c | 63 ++------------------------------
 1 file changed, 4 insertions(+), 59 deletions(-)

diff --git a/drivers/staging/media/lirc/lirc_serial.c b/drivers/staging/media/lirc/lirc_serial.c
index dc7984455c3a..465796a686c4 100644
--- a/drivers/staging/media/lirc/lirc_serial.c
+++ b/drivers/staging/media/lirc/lirc_serial.c
@@ -327,9 +327,6 @@ static void safe_udelay(unsigned long usecs)
  * time
  */
 
-/* So send_pulse can quickly convert microseconds to clocks */
-static unsigned long conv_us_to_clocks;
-
 static int init_timing_params(unsigned int new_duty_cycle,
 		unsigned int new_freq)
 {
@@ -344,7 +341,6 @@ static int init_timing_params(unsigned int new_duty_cycle,
 	/* How many clocks in a microsecond?, avoiding long long divide */
 	work = loops_per_sec;
 	work *= 4295;  /* 4295 = 2^32 / 1e6 */
-	conv_us_to_clocks = work >> 32;
 
 	/*
 	 * Carrier period in clocks, approach good up to 32GHz clock,
@@ -357,10 +353,9 @@ static int init_timing_params(unsigned int new_duty_cycle,
 	pulse_width = period * duty_cycle / 100;
 	space_width = period - pulse_width;
 	dprintk("in init_timing_params, freq=%d, duty_cycle=%d, "
-		"clk/jiffy=%ld, pulse=%ld, space=%ld, "
-		"conv_us_to_clocks=%ld\n",
+		"clk/jiffy=%ld, pulse=%ld, space=%ld\n",
 		freq, duty_cycle, __this_cpu_read(cpu_info.loops_per_jiffy),
-		pulse_width, space_width, conv_us_to_clocks);
+		pulse_width, space_width);
 	return 0;
 }
 #else /* ! USE_RDTSC */
@@ -431,63 +426,14 @@ static long send_pulse_irdeo(unsigned long length)
 	return ret;
 }
 
-#ifdef USE_RDTSC
-/* Version that uses Pentium rdtsc instruction to measure clocks */
-
-/*
- * This version does sub-microsecond timing using rdtsc instruction,
- * and does away with the fudged LIRC_SERIAL_TRANSMITTER_LATENCY
- * Implicitly i586 architecture...  - Steve
- */
-
-static long send_pulse_homebrew_softcarrier(unsigned long length)
-{
-	int flag;
-	unsigned long target, start, now;
-
-	/* Get going quick as we can */
-	rdtscl(start);
-	on();
-	/* Convert length from microseconds to clocks */
-	length *= conv_us_to_clocks;
-	/* And loop till time is up - flipping at right intervals */
-	now = start;
-	target = pulse_width;
-	flag = 1;
-	/*
-	 * FIXME: This looks like a hard busy wait, without even an occasional,
-	 * polite, cpu_relax() call.  There's got to be a better way?
-	 *
-	 * The i2c code has the result of a lot of bit-banging work, I wonder if
-	 * there's something there which could be helpful here.
-	 */
-	while ((now - start) < length) {
-		/* Delay till flip time */
-		do {
-			rdtscl(now);
-		} while ((now - start) < target);
-
-		/* flip */
-		if (flag) {
-			rdtscl(now);
-			off();
-			target += space_width;
-		} else {
-			rdtscl(now); on();
-			target += pulse_width;
-		}
-		flag = !flag;
-	}
-	rdtscl(now);
-	return ((now - start) - length) / conv_us_to_clocks;
-}
-#else /* ! USE_RDTSC */
 /* Version using udelay() */
 
 /*
  * here we use fixed point arithmetic, with 8
  * fractional bits.  that gets us within 0.1% or so of the right average
  * frequency, albeit with some jitter in pulse length - Steve
+ *
+ * This should use ndelay instead.
  */
 
 /* To match 8 fractional bits used for pulse/space length */
@@ -520,7 +466,6 @@ static long send_pulse_homebrew_softcarrier(unsigned long length)
 	}
 	return (actual-length) >> 8;
 }
-#endif /* USE_RDTSC */
 
 static long send_pulse_homebrew(unsigned long length)
 {
-- 
2.3.5


  parent reply	other threads:[~2015-06-25 16:48 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-25 16:43 [PATCH 00/19] tip queue 2015-06-25 (rdtsc cleanup) Borislav Petkov
2015-06-25 16:43 ` [PATCH 01/19] x86/tsc: Inline native_read_tsc() and remove __native_read_tsc() Borislav Petkov
2015-06-25 16:43 ` [PATCH 02/19] x86/msr, kvm: Remove vget_cycles() Borislav Petkov
2015-06-25 16:43 ` [PATCH 03/19] x86/kernel/paravirt: Remove read_tsc() and read_tscp() paravirt hooks Borislav Petkov
2015-06-25 16:43 ` [PATCH 04/19] x86/tsc: Replace rdtscll() with native_read_tsc() Borislav Petkov
2015-06-25 16:43 ` [PATCH 05/19] x86/tsc: Remove the rdtscp() and rdtscpll() macros Borislav Petkov
2015-06-25 16:44 ` [PATCH 06/19] x86/tsc: Use the full 64-bit TSC in delay_tsc() Borislav Petkov
2015-06-25 16:44 ` [PATCH 07/19] x86/cpu/amd: Use the full 64-bit TSC to detect the 2.6.2 bug Borislav Petkov
2015-06-25 16:44 ` [PATCH 08/19] drivers/net/hamradio/baycom_epp: Replace rdtscl() with native_read_tsc() Borislav Petkov
2015-06-25 16:44 ` Borislav Petkov [this message]
2015-06-25 16:44 ` [PATCH 10/19] input/joystick/analog: Switch from rdtscl() to native_read_tsc() Borislav Petkov
2015-06-25 16:44 ` [PATCH 11/19] drivers/input/gameport: Replace rdtscl() with native_read_tsc() Borislav Petkov
2015-06-25 16:44 ` [PATCH 12/19] x86/asm: Remove rdtscl() Borislav Petkov
2015-06-25 16:44 ` [PATCH 13/19] x86: Rename native_read_tsc() to rdtsc() Borislav Petkov
2015-06-25 16:44 ` [PATCH 14/19] x86: Add rdtsc_ordered() and use it in trivial call sites Borislav Petkov
2015-06-25 16:44 ` [PATCH 15/19] x86/tsc_sync: Use rdtsc_ordered() in check_tsc_warp() and drop extra barriers Borislav Petkov
2015-06-25 16:44 ` [PATCH 16/19] x86/tsc: Use rdtsc_ordered() in read_tsc() instead of get_cycles() Borislav Petkov
2015-06-25 16:44 ` [PATCH 17/19] x86/kvm/tsc: Drop extra barrier and use rdtsc_ordered() in kvmclock Borislav Petkov
2015-06-25 16:44 ` [PATCH 18/19] x86/asm: Remove rdtsc_barrier() Borislav Petkov
2015-06-25 16:44 ` [PATCH 19/19] x86/asm: Save an instruction in DECLARE_ARGS users Borislav Petkov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1435250653-30182-10-git-send-email-bp@alien8.de \
    --to=bp@alien8.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome