From: Borislav Petkov <bp@alien8.de>
To: Ingo Molnar <mingo@kernel.org>
Cc: LKML <linux-kernel@vger.kernel.org>
Subject: [PATCH 08/19] drivers/net/hamradio/baycom_epp: Replace rdtscl() with native_read_tsc()
Date: Thu, 25 Jun 2015 18:44:02 +0200 [thread overview]
Message-ID: <1435250653-30182-9-git-send-email-bp@alien8.de> (raw)
In-Reply-To: <1435250653-30182-1-git-send-email-bp@alien8.de>
From: Andy Lutomirski <luto@kernel.org>
This is only used if BAYCOM_DEBUG is defined.
Signed-off-by: Andy Lutomirski <luto@kernel.org>
Acked-by: Thomas Sailer <t.sailer@alumni.ethz.ch
Acked-by: Walter Harms <wharms@bfs.de>
Cc: Denys Vlasenko <dvlasenk@redhat.com>
Cc: Huang Rui <ray.huang@amd.com>
Cc: John Stultz <john.stultz@linaro.org>
Cc: kvm ML <kvm@vger.kernel.org>
Cc: Len Brown <lenb@kernel.org>
Cc: linux-hams@vger.kernel.org
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Ralf Baechle <ralf@linux-mips.org>
Cc: x86-ml <x86@kernel.org>
Link: http://lkml.kernel.org/r/1195ce0c7f34169ff3006341b77806184a46b9bf.1434501121.git.luto@kernel.org
Signed-off-by: Borislav Petkov <bp@suse.de>
---
drivers/net/hamradio/baycom_epp.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/hamradio/baycom_epp.c b/drivers/net/hamradio/baycom_epp.c
index 83c7cce0d172..44e5c3b5e0af 100644
--- a/drivers/net/hamradio/baycom_epp.c
+++ b/drivers/net/hamradio/baycom_epp.c
@@ -638,7 +638,7 @@ static int receive(struct net_device *dev, int cnt)
#define GETTICK(x) \
({ \
if (cpu_has_tsc) \
- rdtscl(x); \
+ x = (unsigned int)native_read_tsc(); \
})
#else /* __i386__ */
#define GETTICK(x)
--
2.3.5
next prev parent reply other threads:[~2015-06-25 16:45 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-06-25 16:43 [PATCH 00/19] tip queue 2015-06-25 (rdtsc cleanup) Borislav Petkov
2015-06-25 16:43 ` [PATCH 01/19] x86/tsc: Inline native_read_tsc() and remove __native_read_tsc() Borislav Petkov
2015-06-25 16:43 ` [PATCH 02/19] x86/msr, kvm: Remove vget_cycles() Borislav Petkov
2015-06-25 16:43 ` [PATCH 03/19] x86/kernel/paravirt: Remove read_tsc() and read_tscp() paravirt hooks Borislav Petkov
2015-06-25 16:43 ` [PATCH 04/19] x86/tsc: Replace rdtscll() with native_read_tsc() Borislav Petkov
2015-06-25 16:43 ` [PATCH 05/19] x86/tsc: Remove the rdtscp() and rdtscpll() macros Borislav Petkov
2015-06-25 16:44 ` [PATCH 06/19] x86/tsc: Use the full 64-bit TSC in delay_tsc() Borislav Petkov
2015-06-25 16:44 ` [PATCH 07/19] x86/cpu/amd: Use the full 64-bit TSC to detect the 2.6.2 bug Borislav Petkov
2015-06-25 16:44 ` Borislav Petkov [this message]
2015-06-25 16:44 ` [PATCH 09/19] staging/lirc_serial: Remove TSC-based timing Borislav Petkov
2015-06-25 16:44 ` [PATCH 10/19] input/joystick/analog: Switch from rdtscl() to native_read_tsc() Borislav Petkov
2015-06-25 16:44 ` [PATCH 11/19] drivers/input/gameport: Replace rdtscl() with native_read_tsc() Borislav Petkov
2015-06-25 16:44 ` [PATCH 12/19] x86/asm: Remove rdtscl() Borislav Petkov
2015-06-25 16:44 ` [PATCH 13/19] x86: Rename native_read_tsc() to rdtsc() Borislav Petkov
2015-06-25 16:44 ` [PATCH 14/19] x86: Add rdtsc_ordered() and use it in trivial call sites Borislav Petkov
2015-06-25 16:44 ` [PATCH 15/19] x86/tsc_sync: Use rdtsc_ordered() in check_tsc_warp() and drop extra barriers Borislav Petkov
2015-06-25 16:44 ` [PATCH 16/19] x86/tsc: Use rdtsc_ordered() in read_tsc() instead of get_cycles() Borislav Petkov
2015-06-25 16:44 ` [PATCH 17/19] x86/kvm/tsc: Drop extra barrier and use rdtsc_ordered() in kvmclock Borislav Petkov
2015-06-25 16:44 ` [PATCH 18/19] x86/asm: Remove rdtsc_barrier() Borislav Petkov
2015-06-25 16:44 ` [PATCH 19/19] x86/asm: Save an instruction in DECLARE_ARGS users Borislav Petkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1435250653-30182-9-git-send-email-bp@alien8.de \
--to=bp@alien8.de \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome