mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
To: linux-kernel@vger.kernel.org
Cc: mingo@kernel.org, laijs@cn.fujitsu.com, dipankar@in.ibm.com,
	akpm@linux-foundation.org, mathieu.desnoyers@efficios.com,
	josh@joshtriplett.org, tglx@linutronix.de, peterz@infradead.org,
	rostedt@goodmis.org, dhowells@redhat.com, edumazet@google.com,
	dvhart@linux.intel.com, fweisbec@gmail.com, oleg@redhat.com,
	bobby.prani@gmail.com, Nicholas Mc Guire <hofrat@osadl.org>,
	"Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Subject: [PATCH tip/core/rcu 03/16] rcu: Change return type to bool
Date: Fri, 17 Jul 2015 15:20:03 -0700	[thread overview]
Message-ID: <1437171616-13832-3-git-send-email-paulmck@linux.vnet.ibm.com> (raw)
In-Reply-To: <1437171616-13832-1-git-send-email-paulmck@linux.vnet.ibm.com>

From: Nicholas Mc Guire <hofrat@osadl.org>

Type-checking coccinelle spatches are being used to locate type mismatches
between function signatures and return values in this case this produced:
./kernel/rcu/srcu.c:271 WARNING: return of wrong type
        int != unsigned long,

srcu_readers_active() returns an int that is the sum of per_cpu unsigned
long but the only user is cleanup_srcu_struct() which is using it as a
boolean (condition) to see if there is any readers rather than actually
using the approximate number of readers. The theoretically possible
unsigned long overflow case does not need to be handled explicitly - if
we had 4G++ readers then something else went wrong a long time ago.

proposal: change the return type to boolean. The function name is left
          unchanged as it fits the naming expectation for a boolean.

patch was compile tested for x86_64_defconfig (implies CONFIG_SRCU=y)

patch is against 4.1-rc5 (localversion-next is -next-20150525)

Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
Signed-off-by: Paul E. McKenney <paulmck@linux.vnet.ibm.com>
---
 kernel/rcu/srcu.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/kernel/rcu/srcu.c b/kernel/rcu/srcu.c
index fb33d35ee0b7..de35087c92a5 100644
--- a/kernel/rcu/srcu.c
+++ b/kernel/rcu/srcu.c
@@ -252,14 +252,15 @@ static bool srcu_readers_active_idx_check(struct srcu_struct *sp, int idx)
 }
 
 /**
- * srcu_readers_active - returns approximate number of readers.
+ * srcu_readers_active - returns true if there are readers. and false
+ *                       otherwise
  * @sp: which srcu_struct to count active readers (holding srcu_read_lock).
  *
  * Note that this is not an atomic primitive, and can therefore suffer
  * severe errors when invoked on an active srcu_struct.  That said, it
  * can be useful as an error check at cleanup time.
  */
-static int srcu_readers_active(struct srcu_struct *sp)
+static bool srcu_readers_active(struct srcu_struct *sp)
 {
 	int cpu;
 	unsigned long sum = 0;
-- 
1.8.1.5


  parent reply	other threads:[~2015-07-17 22:20 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-07-17 22:19 [PATCH tip/core/rcu 0/16] Miscellaneous fixes for 4.3 Paul E. McKenney
2015-07-17 22:20 ` [PATCH tip/core/rcu 01/16] rcu: Drop RCU_USER_QS in favor of NO_HZ_FULL Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 02/16] rcu: Deinline rcu_read_lock_sched_held() if DEBUG_LOCK_ALLOC Paul E. McKenney
2015-07-17 22:20   ` Paul E. McKenney [this message]
2015-07-17 22:20   ` [PATCH tip/core/rcu 04/16] rcu: Add RCU-sched flavors of get-state and cond-sync Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 05/16] rcu: Hide RCU_NOCB_CPU behind RCU_EXPERT Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 06/16] rcu: Use WRITE_ONCE in RCU_INIT_POINTER Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 07/16] rcu: Fix obsolete priority-boosting comment Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 08/16] rcu: Create a synchronize_rcu_mult() Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 09/16] cpu: Wait for RCU grace periods concurrently Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 10/16] rcu: Make rcu_is_watching() really notrace Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 11/16] rcu: Rename rcu_lockdep_assert() to RCU_LOCKDEP_WARN() Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 12/16] rcu: Fix backwards RCU_LOCKDEP_WARN() in synchronize_rcu_tasks() Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 13/16] rcu: Clarify CONFIG_RCU_EQS_DEBUG help text Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 14/16] rcu: update MAINTAINERS entry Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 15/16] scripts: Make checkpatch.pl warn on expedited RCU grace periods Paul E. McKenney
2015-07-17 22:37     ` Joe Perches
2015-07-21  0:41       ` Paul E. McKenney
2015-07-21  0:48         ` Joe Perches
2015-07-21  1:02           ` Paul E. McKenney
2015-07-21  0:55       ` Steven Rostedt
2015-07-21  1:06         ` Joe Perches
2015-07-21  1:15           ` Steven Rostedt
2015-07-21 17:18             ` Joe Perches
2015-07-21 20:11               ` Paul E. McKenney
2015-07-21  1:29           ` Paul E. McKenney
2015-07-21  1:58             ` Joe Perches
2015-07-21  3:24               ` Paul E. McKenney
2015-07-17 22:20   ` [PATCH tip/core/rcu 16/16] rcu: Don't disable CPU hotplug during OOM notifiers Paul E. McKenney

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1437171616-13832-3-git-send-email-paulmck@linux.vnet.ibm.com \
    --to=paulmck@linux.vnet.ibm.com \
    --cc=akpm@linux-foundation.org \
    --cc=bobby.prani@gmail.com \
    --cc=dhowells@redhat.com \
    --cc=dipankar@in.ibm.com \
    --cc=dvhart@linux.intel.com \
    --cc=edumazet@google.com \
    --cc=fweisbec@gmail.com \
    --cc=hofrat@osadl.org \
    --cc=josh@joshtriplett.org \
    --cc=laijs@cn.fujitsu.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=mingo@kernel.org \
    --cc=oleg@redhat.com \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®