From: Mateusz Kulikowski <mateusz.kulikowski@gmail.com>
To: gregkh@linuxfoundation.org
Cc: Mateusz Kulikowski <mateusz.kulikowski@gmail.com>,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: [PATCH 096/102] staging: rtl8192e: Rename rtl8192_hw_to_sleep
Date: Sun, 19 Jul 2015 19:33:52 +0200 [thread overview]
Message-ID: <1437327238-24876-6-git-send-email-mateusz.kulikowski@gmail.com> (raw)
In-Reply-To: <1437327238-24876-1-git-send-email-mateusz.kulikowski@gmail.com>
Use naming schema found in other rtlwifi devices.
Rename rtl8192_hw_to_sleep to rtl92e_enter_sleep.
Signed-off-by: Mateusz Kulikowski <mateusz.kulikowski@gmail.com>
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 2 +-
drivers/staging/rtl8192e/rtl8192e/rtl_ps.c | 2 +-
drivers/staging/rtl8192e/rtl8192e/rtl_ps.h | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
index 5fc2103..ca18640 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
@@ -883,7 +883,7 @@ static void rtl8192_init_priv_handler(struct net_device *dev)
priv->rtllib->stop_send_beacons = rtl8192_stop_beacon;
priv->rtllib->sta_wake_up = rtl8192_hw_wakeup;
- priv->rtllib->enter_sleep_state = rtl8192_hw_to_sleep;
+ priv->rtllib->enter_sleep_state = rtl92e_enter_sleep;
priv->rtllib->ps_is_queue_empty = rtl8192_is_tx_queue_empty;
priv->rtllib->GetNmodeSupportBySecCfg = rtl92e_get_nmode_support_by_sec;
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_ps.c b/drivers/staging/rtl8192e/rtl8192e/rtl_ps.c
index 6bdd0f2..327b2b8 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_ps.c
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_ps.c
@@ -88,7 +88,7 @@ void rtl8192_hw_wakeup_wq(void *data)
#define MIN_SLEEP_TIME 50
#define MAX_SLEEP_TIME 10000
-void rtl8192_hw_to_sleep(struct net_device *dev, u64 time)
+void rtl92e_enter_sleep(struct net_device *dev, u64 time)
{
struct r8192_priv *priv = rtllib_priv(dev);
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_ps.h b/drivers/staging/rtl8192e/rtl8192e/rtl_ps.h
index 250d524..a962e7f 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_ps.h
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_ps.h
@@ -32,7 +32,7 @@ struct net_device;
#define RT_CHECK_FOR_HANG_PERIOD 2
void rtl8192_hw_wakeup(struct net_device *dev);
-void rtl8192_hw_to_sleep(struct net_device *dev, u64 time);
+void rtl92e_enter_sleep(struct net_device *dev, u64 time);
void rtllib_ips_leave_wq(struct net_device *dev);
void rtllib_ips_leave(struct net_device *dev);
void rtl92e_ips_leave_wq(void *data);
--
1.8.4.1
next prev parent reply other threads:[~2015-07-19 17:34 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-07-19 17:33 [PATCH 091/102] staging: rtl8192e: Rename IPSLeave Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 092/102] staging: rtl8192e: Rename IPSLeave_wq Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 093/102] staging: rtl8192e: Rename LeisurePSEnter Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 094/102] staging: rtl8192e: Rename LeisurePSLeave Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 095/102] staging: rtl8192e: Rename rtl8192_hw_sleep_wq Mateusz Kulikowski
2015-07-19 17:33 ` Mateusz Kulikowski [this message]
2015-07-19 17:33 ` [PATCH 097/102] staging: rtl8192e: Rename rtl8192_hw_wakeup Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 098/102] staging: rtl8192e: Rename rtl8192_hw_wakeup_wq Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 099/102] staging: rtl8192e: Rename rtllib_ips_leave Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 100/102] staging: rtl8192e: Rename rtllib_ips_leave_wq Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 101/102] staging: rtl8192e: Rename init_firmware Mateusz Kulikowski
2015-07-19 17:33 ` [PATCH 102/102] staging: rtl8192e: Rename init_hal_dm Mateusz Kulikowski
2015-07-19 17:47 ` [PATCH 091/102] staging: rtl8192e: Rename IPSLeave Mateusz Kulikowski
2015-07-23 4:22 ` Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1437327238-24876-6-git-send-email-mateusz.kulikowski@gmail.com \
--to=mateusz.kulikowski@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®