From: Ashish Kalra <eashishkalra@gmail.com>
To: gregkh@linuxfoundation.org, wsa@the-dreams.de,
driverdev-devel@linuxdriverproject.org,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org,
joe@perches.com, eashishkalra@gmail.com
Subject: [PATCH] staging: ks7010: fix styling WARNINGs
Date: Tue, 1 Aug 2017 17:11:29 +0100 [thread overview]
Message-ID: <1501603889-1988-1-git-send-email-eashishkalra@gmail.com> (raw)
In-Reply-To: <1501470921-1947-1-git-send-email-eashishkalra@gmail.com>
Signed-off-by: Ashish Kalra <eashishkalra@gmail.com>
---
drivers/staging/ks7010/ks7010_sdio.c | 47 +++++++++++++++++++++++++-----------
1 file changed, 33 insertions(+), 14 deletions(-)
Trivial style changes. There are still "line over 80 characters"
checkpatch.pl warnings, but I think they are best left alone as
breaking these could hurt readability
diff --git a/drivers/staging/ks7010/ks7010_sdio.c b/drivers/staging/ks7010/ks7010_sdio.c
index 9b28ee1..274fed8 100644
--- a/drivers/staging/ks7010/ks7010_sdio.c
+++ b/drivers/staging/ks7010/ks7010_sdio.c
@@ -9,7 +9,6 @@
* it under the terms of the GNU General Public License version 2 as
* published by the Free Software Foundation.
*/
-
#include <linux/firmware.h>
#include <linux/mmc/card.h>
#include <linux/mmc/sdio_func.h>
@@ -32,19 +31,39 @@
};
MODULE_DEVICE_TABLE(sdio, ks7010_sdio_ids);
-#define inc_txqhead(priv) \
- (priv->tx_dev.qhead = (priv->tx_dev.qhead + 1) % TX_DEVICE_BUFF_SIZE)
-#define inc_txqtail(priv) \
- (priv->tx_dev.qtail = (priv->tx_dev.qtail + 1) % TX_DEVICE_BUFF_SIZE)
-#define cnt_txqbody(priv) \
- (((priv->tx_dev.qtail + TX_DEVICE_BUFF_SIZE) - (priv->tx_dev.qhead)) % TX_DEVICE_BUFF_SIZE)
-
-#define inc_rxqhead(priv) \
- (priv->rx_dev.qhead = (priv->rx_dev.qhead + 1) % RX_DEVICE_BUFF_SIZE)
-#define inc_rxqtail(priv) \
- (priv->rx_dev.qtail = (priv->rx_dev.qtail + 1) % RX_DEVICE_BUFF_SIZE)
-#define cnt_rxqbody(priv) \
- (((priv->rx_dev.qtail + RX_DEVICE_BUFF_SIZE) - (priv->rx_dev.qhead)) % RX_DEVICE_BUFF_SIZE)
+static int inc_txqhead(struct ks_wlan_private *priv)
+{
+ priv->tx_dev.qhead = (priv->tx_dev.qhead + 1) % TX_DEVICE_BUFF_SIZE;
+ return 0;
+}
+
+static int inc_txqtail(struct ks_wlan_private *priv)
+{
+ priv->tx_dev.qtail = (priv->tx_dev.qtail + 1) % TX_DEVICE_BUFF_SIZE;
+ return 0;
+}
+
+static int inc_rxqtail(struct ks_wlan_private *priv)
+{
+ priv->rx_dev.qtail = (priv->rx_dev.qtail + 1) % RX_DEVICE_BUFF_SIZE;
+ return 0;
+}
+
+static int inc_rxqhead(struct ks_wlan_private *priv)
+{
+ priv->rx_dev.qhead = (priv->rx_dev.qhead + 1) % RX_DEVICE_BUFF_SIZE;
+ return 0;
+}
+
+static int cnt_rxqbody(struct ks_wlan_private *priv)
+{
+ return (((priv->rx_dev.qtail + RX_DEVICE_BUFF_SIZE) - (priv->rx_dev.qhead)) % RX_DEVICE_BUFF_SIZE);
+}
+
+static int cnt_txqbody(struct ks_wlan_private *priv)
+{
+ return (((priv->tx_dev.qtail + TX_DEVICE_BUFF_SIZE) - (priv->tx_dev.qhead)) % TX_DEVICE_BUFF_SIZE);
+}
/* Read single byte from device address into byte (CMD52) */
static int ks7010_sdio_readb(struct ks_wlan_private *priv, unsigned int address,
--
1.9.1
next prev parent reply other threads:[~2017-08-01 16:12 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-07-31 2:20 [PATCH] Removing Check Errors with checkpatch.pl, Converting from macro to function call Ashish Kalra
2017-08-01 0:25 ` Joe Perches
2017-07-31 3:15 ` [PATCH] staging: ks7010: fix styling WARNINGs Ashish Kalra
2017-08-01 1:18 ` Greg KH
2017-08-01 4:29 ` kbuild test robot
2017-08-01 4:31 ` kbuild test robot
2017-08-01 16:11 ` Ashish Kalra [this message]
2017-08-01 16:22 ` Joe Perches
2017-08-01 17:25 ` [PATCH v2]staging: " Ashish Kalra
2017-08-17 17:58 ` Greg KH
2017-08-01 20:28 ` [PATCH] staging: " Dan Carpenter
-- strict thread matches above, loose matches on Subject: below --
2017-06-30 4:52 Mark Rogers
2017-06-30 5:54 ` Frans Klaver
2017-06-30 18:39 ` Mark Rogers
2017-07-11 17:27 ` Greg KH
2017-07-12 8:08 ` Frans Klaver
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1501603889-1988-1-git-send-email-eashishkalra@gmail.com \
--to=eashishkalra@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=driverdev-devel@linuxdriverproject.org \
--cc=gregkh@linuxfoundation.org \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=wsa@the-dreams.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome