From: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
To: Borislav Petkov <bp@suse.de>
Cc: Ingo Molnar <mingo@redhat.com>,
Thomas Gleixner <tglx@linutronix.de>,
"H. Peter Anvin" <hpa@zytor.com>,
Andy Lutomirski <luto@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Andrew Morton <akpm@linux-foundation.org>,
Brian Gerst <brgerst@gmail.com>,
Chris Metcalf <cmetcalf@mellanox.com>,
Dave Hansen <dave.hansen@linux.intel.com>,
Paolo Bonzini <pbonzini@redhat.com>,
Masami Hiramatsu <mhiramat@kernel.org>,
Huang Rui <ray.huang@amd.com>, Jiri Slaby <jslaby@suse.cz>,
Jonathan Corbet <corbet@lwn.net>,
"Michael S. Tsirkin" <mst@redhat.com>,
Paul Gortmaker <paul.gortmaker@windriver.com>,
Vlastimil Babka <vbabka@suse.cz>, Chen Yucong <slaoub@gmail.com>,
"Ravi V. Shankar" <ravi.v.shankar@intel.com>,
Shuah Khan <shuah@kernel.org>,
linux-kernel@vger.kernel.org, x86@kernel.org,
Adam Buchbinder <adam.buchbinder@gmail.com>,
Colin Ian King <colin.king@canonical.com>,
Lorenzo Stoakes <lstoakes@gmail.com>,
Qiaowei Ren <qiaowei.ren@intel.com>,
Arnaldo Carvalho de Melo <acme@redhat.com>,
Adrian Hunter <adrian.hunter@intel.com>,
Kees Cook <keescook@chromium.org>,
Thomas Garnier <thgarnie@google.com>,
Dmitry Vyukov <dvyukov@google.com>
Subject: Re: [PATCH v9 13/29] x86/insn-eval: Add utility functions to get segment selector
Date: Thu, 12 Oct 2017 18:08:17 -0700 [thread overview]
Message-ID: <1507856897.17492.53.camel@linux.intel.com> (raw)
In-Reply-To: <20171012094833.xjk6jg5us3ffkih4@pd.tnic>
On Thu, 2017-10-12 at 11:48 +0200, Borislav Petkov wrote:
> On Wed, Oct 11, 2017 at 06:12:30PM -0700, Ricardo Neri wrote:
> >
> > Shouldn't this function check for a null insn since it is used here?
> I have to say, this whole codepath from insn_get_seg_base() with
> insn==NULL is nasty but I don't see a way around it as we need to know
> how many bytes to copy and from where. Can't think of a better solution
> without duplicating a lot of code. :-\
I have looked at your two proposals. I think I prefer the first one plus a
couple of tweaks.
>
> So how about this?
>
> If the patch is hard to read, you can apply it and look at the code. But
> here's the gist:
>
> * You pull up the rIP check and do that directly in resolve_seg_reg()
> and return INAT_SEG_REG_CS there immediately so you don't have to call
> resolve_default_seg().
In my opinion it would be better to have all the checks in a single place. This
makes the code easier to read that having this special case directly
in resolve_default_seg(). Also, strictly speaking we would need to
return INAT_SEG_REG_IGNORE in long mode. Indeed, insn_get_seg_base() would
return base 0 in such a case, but I feel it is better if this logic is explicit
in resolve_default_seg().
>
> This way, you get the only case out of the way where insn can be NULL.
>
> Then you can do the if (!insn) check once and now you have a valid insn.
Rather than checking for null insn in resolve_seg_reg(), which does not use it,
let the functions it calls do the check if they need to.
>
> check_seg_overrides() can then return simply bool and you can get rid of
> the remaining if (!insn) checks down the road.
>
> But please double-check me if I missed a case - the flow is not trivial.
This is a diff based on your first proposal (I hope text does not wrap). I feel
this makes it clear how resolve_seg_reg() handles errors as well it uses
overridden or default segment register indices. Plus, insn is only checked when
used.
@@ -155,6 +155,16 @@ static int resolve_default_seg(struct insn *insn, struct
pt_regs *regs, int off)
{
if (user_64bit_mode(regs))
return INAT_SEG_REG_IGNORE;
+
+ /*
+ * insn may be null as we may be about to copy the instruction.
+ * However is not needed at all.
+ */
+ if (off == offsetof(struct pt_regs, ip))
+ INAT_SEG_REG_CS;
+
+ if(!insn)
+ return -EINVAL;
/*
* If we are here, we use the default segment register as described
* in the Intel documentation:
@@ -191,9 +201,6 @@ static int resolve_default_seg(struct insn *insn, struct
pt_regs *regs, int off)
case offsetof(struct pt_regs, sp):
return INAT_SEG_REG_SS;
- case offsetof(struct pt_regs, ip):
- return INAT_SEG_REG_CS;
-
default:
return -EINVAL;
}
@@ -254,9 +261,6 @@ static int resolve_seg_reg(struct insn *insn, struct pt_regs
*regs, int regoff)
if (!ret)
return resolve_default_seg(insn, regs, regoff);
- if (!insn)
- return -EINVAL;
-
idx = get_seg_reg_override_idx(insn);
if (idx < 0)
return idx;
Thanks and BR,
Ricardo
next prev parent reply other threads:[~2017-10-13 1:08 UTC|newest]
Thread overview: 71+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-04 3:54 [PATCH v9 00/29] x86: Enable User-Mode Instruction Prevention Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 01/29] x86/mm: Relocate page fault error codes to traps.h Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 02/29] x86/boot: Relocate definition of the initial state of CR0 Ricardo Neri
2017-10-26 7:51 ` Andy Lutomirski
2017-10-26 9:00 ` Borislav Petkov
2017-10-26 9:02 ` Andy Lutomirski
2017-10-26 12:55 ` Borislav Petkov
2017-10-27 19:02 ` Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 03/29] ptrace,x86: Make user_64bit_mode() available to 32-bit builds Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 04/29] uprobes/x86: Use existing definitions for segment override prefixes Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 05/29] x86/mpx: Simplify handling of errors when computing linear addresses Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 06/29] x86/mpx: Use signed variables to compute effective addresses Ricardo Neri
2017-10-05 9:41 ` Borislav Petkov
2017-10-05 17:38 ` Neri, Ricardo
2017-10-04 3:54 ` [PATCH v9 07/29] x86/mpx: Do not use SIB.index if its value is 100b and ModRM.mod is not 11b Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 08/29] x86/mpx: Do not use SIB.base if its value is 101b and ModRM.mod = 0 Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 09/29] x86/mpx, x86/insn: Relocate insn util functions to a new insn-eval file Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 10/29] x86/insn-eval: Do not BUG on invalid register type Ricardo Neri
2017-10-07 16:22 ` Borislav Petkov
2017-10-09 23:56 ` Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 11/29] x86/insn-eval: Add a utility function to get register offsets Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 12/29] x86/insn-eval: Add utility function to identify string instructions Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 13/29] x86/insn-eval: Add utility functions to get segment selector Ricardo Neri
2017-10-10 22:41 ` Borislav Petkov
2017-10-12 1:12 ` Ricardo Neri
2017-10-12 9:48 ` Borislav Petkov
2017-10-13 1:08 ` Ricardo Neri [this message]
2017-10-13 11:37 ` Borislav Petkov
2017-10-13 18:43 ` Ricardo Neri
2017-10-17 9:35 ` Borislav Petkov
2017-10-17 20:31 ` Ricardo Neri
2017-10-18 20:29 ` Borislav Petkov
2017-10-19 6:30 ` Ricardo Neri
2017-10-20 7:55 ` Borislav Petkov
2017-10-20 18:05 ` Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 14/29] x86/insn-eval: Add utility function to get segment descriptor Ricardo Neri
2017-10-11 14:57 ` Borislav Petkov
2017-10-12 0:45 ` Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 15/29] x86/insn-eval: Add utility functions to get segment descriptor base address and limit Ricardo Neri
2017-10-11 15:15 ` Borislav Petkov
2017-10-11 19:57 ` Ricardo Neri
2017-10-11 20:16 ` Borislav Petkov
2017-10-12 1:24 ` Ricardo Neri
2017-10-12 16:02 ` Borislav Petkov
2017-10-04 3:54 ` [PATCH v9 16/29] x86/insn-eval: Add function to get default params of code segment Ricardo Neri
2017-10-12 16:31 ` Borislav Petkov
2017-10-12 18:27 ` Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 17/29] x86/insn-eval: Indicate a 32-bit displacement if ModRM.mod is 0 and ModRM.rm is 101b Ricardo Neri
2017-10-20 15:44 ` Borislav Petkov
2017-10-20 18:07 ` Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 18/29] x86/insn-eval: Incorporate segment base in linear address computation Ricardo Neri
2017-10-20 16:08 ` Borislav Petkov
2017-10-20 18:10 ` Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 19/29] x86/insn-eval: Add support to resolve 32-bit address encodings Ricardo Neri
2017-10-20 17:12 ` Borislav Petkov
2017-10-20 18:24 ` Ricardo Neri
2017-10-20 18:38 ` Borislav Petkov
2017-10-20 19:16 ` Ricardo Neri
2017-10-20 22:04 ` Borislav Petkov
2017-10-04 3:54 ` [PATCH v9 20/29] x86/insn-eval: Add wrapper function for 32 and 64-bit addresses Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 21/29] x86/insn-eval: Handle 32-bit address encodings in virtual-8086 mode Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 22/29] x86/insn-eval: Add support to resolve 16-bit addressing encodings Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 23/29] x86/cpufeature: Add User-Mode Instruction Prevention definitions Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 24/29] x86: Add emulation code for UMIP instructions Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 25/29] x86/umip: Force a page fault when unable to copy emulated result to user Ricardo Neri
2017-10-26 7:59 ` Andy Lutomirski
2017-10-27 21:46 ` Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 26/29] x86: Enable User-Mode Instruction Prevention Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 27/29] x86/traps: Fixup general protection faults caused by UMIP Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 28/29] selftests/x86: Add tests for User-Mode Instruction Prevention Ricardo Neri
2017-10-04 3:54 ` [PATCH v9 29/29] selftests/x86: Add tests for instruction str and sldt Ricardo Neri
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1507856897.17492.53.camel@linux.intel.com \
--to=ricardo.neri-calderon@linux.intel.com \
--cc=acme@redhat.com \
--cc=adam.buchbinder@gmail.com \
--cc=adrian.hunter@intel.com \
--cc=akpm@linux-foundation.org \
--cc=bp@suse.de \
--cc=brgerst@gmail.com \
--cc=cmetcalf@mellanox.com \
--cc=colin.king@canonical.com \
--cc=corbet@lwn.net \
--cc=dave.hansen@linux.intel.com \
--cc=dvyukov@google.com \
--cc=hpa@zytor.com \
--cc=jslaby@suse.cz \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lstoakes@gmail.com \
--cc=luto@kernel.org \
--cc=mhiramat@kernel.org \
--cc=mingo@redhat.com \
--cc=mst@redhat.com \
--cc=paul.gortmaker@windriver.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=qiaowei.ren@intel.com \
--cc=ravi.v.shankar@intel.com \
--cc=ray.huang@amd.com \
--cc=shuah@kernel.org \
--cc=slaoub@gmail.com \
--cc=tglx@linutronix.de \
--cc=thgarnie@google.com \
--cc=vbabka@suse.cz \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome