From: Christophe Leroy <christophe.leroy@csgroup.eu>
To: K Prateek Nayak <kprateek.nayak@amd.com>,
Madhavan Srinivasan <maddy@linux.ibm.com>,
Michael Ellerman <mpe@ellerman.id.au>,
Nicholas Piggin <npiggin@gmail.com>,
Heiko Carstens <hca@linux.ibm.com>,
Vasily Gorbik <gor@linux.ibm.com>,
Alexander Gordeev <agordeev@linux.ibm.com>,
Christian Borntraeger <borntraeger@linux.ibm.com>,
Sven Schnelle <svens@linux.ibm.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
x86@kernel.org, "H. Peter Anvin" <hpa@zytor.com>,
Peter Zijlstra <peterz@infradead.org>,
Juri Lelli <juri.lelli@redhat.com>,
Vincent Guittot <vincent.guittot@linaro.org>,
linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org,
linux-s390@vger.kernel.org
Cc: Dietmar Eggemann <dietmar.eggemann@arm.com>,
Steven Rostedt <rostedt@goodmis.org>,
Ben Segall <bsegall@google.com>, Mel Gorman <mgorman@suse.de>,
Valentin Schneider <vschneid@redhat.com>,
thomas.weissschuh@linutronix.de,
Li Chen <chenl311@chinatelecom.cn>,
Bibo Mao <maobibo@loongson.cn>, Mete Durlu <meted@linux.ibm.com>,
Tobias Huschle <huschle@linux.ibm.com>,
Easwar Hariharan <easwar.hariharan@linux.microsoft.com>,
Guo Weikang <guoweikang.kernel@gmail.com>,
"Rafael J. Wysocki" <rafael.j.wysocki@intel.com>,
Brian Gerst <brgerst@gmail.com>,
Patryk Wlazlyn <patryk.wlazlyn@linux.intel.com>,
Swapnil Sapkal <swapnil.sapkal@amd.com>,
"Yury Norov [NVIDIA]" <yury.norov@gmail.com>,
Sudeep Holla <sudeep.holla@arm.com>,
Jonathan Cameron <Jonathan.Cameron@huawei.com>,
Andrea Righi <arighi@nvidia.com>,
Yicong Yang <yangyicong@hisilicon.com>,
Ricardo Neri <ricardo.neri-calderon@linux.intel.com>,
Tim Chen <tim.c.chen@linux.intel.com>,
Vinicius Costa Gomes <vinicius.gomes@intel.com>
Subject: Re: [PATCH v7 8/8] sched/topology: Unify tl_pkg_mask() across core and all arch
Date: Tue, 26 Aug 2025 07:16:25 +0200 [thread overview]
Message-ID: <154fd466-5305-431f-b49a-a5ccec81507a@csgroup.eu> (raw)
In-Reply-To: <20250826041319.1284-9-kprateek.nayak@amd.com>
Le 26/08/2025 à 06:13, K Prateek Nayak a écrit :
> Unify the tl_pkg_mask() wrapper around cpu_nod_mask() across core, x86,
> powerpc, and s390.
>
> No functional changes intended.
>
> Signed-off-by: K Prateek Nayak <kprateek.nayak@amd.com>
> ---
> arch/powerpc/kernel/smp.c | 7 +------
> arch/s390/kernel/topology.c | 7 +------
> arch/x86/kernel/smpboot.c | 5 -----
> include/linux/sched/topology.h | 6 ++++++
> kernel/sched/topology.c | 5 -----
> 5 files changed, 8 insertions(+), 22 deletions(-)
>
> diff --git a/arch/powerpc/kernel/smp.c b/arch/powerpc/kernel/smp.c
> index 40719679385b..8e869c13f7ed 100644
> --- a/arch/powerpc/kernel/smp.c
> +++ b/arch/powerpc/kernel/smp.c
> @@ -1064,11 +1064,6 @@ const struct cpumask *cpu_coregroup_mask(int cpu)
> }
> #endif
>
> -static const struct cpumask *cpu_pkg_mask(struct sched_domain_topology_level *tl, int cpu)
> -{
> - return cpu_node_mask(cpu);
> -}
> -
> static int __init init_big_cores(void)
> {
> int cpu;
> @@ -1728,7 +1723,7 @@ static void __init build_sched_topology(void)
> }
> #endif
>
> - powerpc_topology[i++] = SDTL_INIT(cpu_pkg_mask, powerpc_shared_proc_flags, PKG);
> + powerpc_topology[i++] = SDTL_INIT(tl_pkg_mask, powerpc_shared_proc_flags, PKG);
>
> /* There must be one trailing NULL entry left. */
> BUG_ON(i >= ARRAY_SIZE(powerpc_topology) - 1);
> diff --git a/arch/s390/kernel/topology.c b/arch/s390/kernel/topology.c
> index 8dbf32f362e1..8f5b6ecc055f 100644
> --- a/arch/s390/kernel/topology.c
> +++ b/arch/s390/kernel/topology.c
> @@ -524,17 +524,12 @@ static const struct cpumask *cpu_drawer_mask(struct sched_domain_topology_level
> return &cpu_topology[cpu].drawer_mask;
> }
>
> -static const struct cpumask *cpu_pkg_mask(struct sched_domain_topology_level *tl, int cpu)
> -{
> - return cpu_node_mask(cpu);
> -}
> -
> static struct sched_domain_topology_level s390_topology[] = {
> SDTL_INIT(tl_smt_mask, cpu_smt_flags, SMT),
> SDTL_INIT(tl_mc_mask, cpu_core_flags, MC),
> SDTL_INIT(cpu_book_mask, NULL, BOOK),
> SDTL_INIT(cpu_drawer_mask, NULL, DRAWER),
> - SDTL_INIT(cpu_pkg_mask, NULL, PKG),
> + SDTL_INIT(tl_pkg_mask, NULL, PKG),
> { NULL, },
> };
>
> diff --git a/arch/x86/kernel/smpboot.c b/arch/x86/kernel/smpboot.c
> index bfbcac9a73d1..6c0ab30a80e2 100644
> --- a/arch/x86/kernel/smpboot.c
> +++ b/arch/x86/kernel/smpboot.c
> @@ -472,11 +472,6 @@ static int x86_cluster_flags(void)
> }
> #endif
>
> -static const struct cpumask *tl_pkg_mask(struct sched_domain_topology_level *tl, int cpu)
> -{
> - return cpu_node_mask(cpu);
> -}
> -
> /*
> * Set if a package/die has multiple NUMA nodes inside.
> * AMD Magny-Cours, Intel Cluster-on-Die, and Intel
> diff --git a/include/linux/sched/topology.h b/include/linux/sched/topology.h
> index 075d1f063668..807603bfe8ff 100644
> --- a/include/linux/sched/topology.h
> +++ b/include/linux/sched/topology.h
> @@ -71,6 +71,12 @@ struct cpumask *tl_mc_mask(struct sched_domain_topology_level *tl, int cpu)
> }
> #endif /* CONFIG_SCHED_MC */
>
> +static const __maybe_unused
Same as the three previous patches, __maybe_unused shouldn't be required.
> +struct cpumask *tl_pkg_mask(struct sched_domain_topology_level *tl, int cpu)
> +{
> + return cpu_node_mask(cpu);
> +}
> +
> #ifdef CONFIG_NUMA
> static inline int cpu_numa_flags(void)
> {
> diff --git a/kernel/sched/topology.c b/kernel/sched/topology.c
> index 77d14430c5e1..18889bd97e22 100644
> --- a/kernel/sched/topology.c
> +++ b/kernel/sched/topology.c
> @@ -1724,11 +1724,6 @@ sd_init(struct sched_domain_topology_level *tl,
> return sd;
> }
>
> -static const struct cpumask *tl_pkg_mask(struct sched_domain_topology_level *tl, int cpu)
> -{
> - return cpu_node_mask(cpu);
> -}
> -
> /*
> * Topology list, bottom-up.
> */
next prev parent reply other threads:[~2025-08-26 5:50 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-08-26 4:13 [PATCH v7 0/8] sched/fair: Get rid of sched_domains_curr_level hack for tl->cpumask() K Prateek Nayak
2025-08-26 4:13 ` [PATCH v7 1/8] " K Prateek Nayak
2025-08-28 23:06 ` Tim Chen
2025-08-26 4:13 ` [PATCH v7 2/8] powerpc/smp: Rename cpu_corgroup_* to cpu_corgrp_* K Prateek Nayak
2025-08-26 5:02 ` Christophe Leroy
2025-09-01 3:05 ` K Prateek Nayak
2025-08-26 4:13 ` [PATCH v7 3/8] powerpc/smp: Export cpu_coregroup_mask() K Prateek Nayak
2025-08-26 4:54 ` Christophe Leroy
2025-08-26 4:13 ` [PATCH v7 4/8] powerpc/smp: Introduce CONFIG_SCHED_MC to guard MC scheduling bits K Prateek Nayak
2025-08-26 4:49 ` Christophe Leroy
2025-08-26 8:07 ` Peter Zijlstra
2025-08-26 9:43 ` Peter Zijlstra
2025-08-26 9:59 ` Peter Zijlstra
2025-08-28 14:43 ` Shrikanth Hegde
2025-09-01 8:35 ` Peter Zijlstra
2025-09-01 8:52 ` Peter Zijlstra
2025-09-03 8:05 ` [tip: sched/core] sched: Unify the SCHED_{SMT,CLUSTER,MC} Kconfig tip-bot2 for Peter Zijlstra
2025-10-14 9:25 ` [PATCH v7 4/8] powerpc/smp: Introduce CONFIG_SCHED_MC to guard MC scheduling bits Geert Uytterhoeven
2025-10-14 9:42 ` Peter Zijlstra
2025-10-14 12:37 ` Geert Uytterhoeven
2025-10-14 14:17 ` Peter Zijlstra
2025-10-14 15:04 ` Geert Uytterhoeven
2025-08-26 9:27 ` Shrikanth Hegde
2025-09-01 3:57 ` K Prateek Nayak
2025-09-01 4:50 ` K Prateek Nayak
2025-08-26 4:13 ` [PATCH v7 5/8] sched/topology: Unify tl_smt_mask() across core and all arch K Prateek Nayak
2025-08-26 5:13 ` Christophe Leroy
2025-08-26 8:01 ` Peter Zijlstra
2025-08-26 8:11 ` Christophe Leroy
2025-08-26 8:24 ` Peter Zijlstra
2025-08-26 4:13 ` [PATCH v7 6/8] sched/topology: Unify tl_cls_mask() across core and x86 K Prateek Nayak
2025-08-26 5:14 ` Christophe Leroy
2025-08-26 4:13 ` [PATCH v7 7/8] sched/topology: Unify tl_mc_mask() across core and all arch K Prateek Nayak
2025-08-26 5:15 ` Christophe Leroy
2025-08-26 4:13 ` [PATCH v7 8/8] sched/topology: Unify tl_pkg_mask() " K Prateek Nayak
2025-08-26 5:16 ` Christophe Leroy [this message]
2025-08-26 10:05 ` [PATCH v7 0/8] sched/fair: Get rid of sched_domains_curr_level hack for tl->cpumask() Shrikanth Hegde
2025-08-26 10:13 ` Peter Zijlstra
2025-08-29 7:53 ` Valentin Schneider
2025-08-29 8:53 ` Shrikanth Hegde
2025-09-01 4:39 ` K Prateek Nayak
2025-09-01 8:58 ` Peter Zijlstra
2025-09-01 17:06 ` Shrikanth Hegde
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=154fd466-5305-431f-b49a-a5ccec81507a@csgroup.eu \
--to=christophe.leroy@csgroup.eu \
--cc=Jonathan.Cameron@huawei.com \
--cc=agordeev@linux.ibm.com \
--cc=arighi@nvidia.com \
--cc=borntraeger@linux.ibm.com \
--cc=bp@alien8.de \
--cc=brgerst@gmail.com \
--cc=bsegall@google.com \
--cc=chenl311@chinatelecom.cn \
--cc=dave.hansen@linux.intel.com \
--cc=dietmar.eggemann@arm.com \
--cc=easwar.hariharan@linux.microsoft.com \
--cc=gor@linux.ibm.com \
--cc=guoweikang.kernel@gmail.com \
--cc=hca@linux.ibm.com \
--cc=hpa@zytor.com \
--cc=huschle@linux.ibm.com \
--cc=juri.lelli@redhat.com \
--cc=kprateek.nayak@amd.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-s390@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=maddy@linux.ibm.com \
--cc=maobibo@loongson.cn \
--cc=meted@linux.ibm.com \
--cc=mgorman@suse.de \
--cc=mingo@redhat.com \
--cc=mpe@ellerman.id.au \
--cc=npiggin@gmail.com \
--cc=patryk.wlazlyn@linux.intel.com \
--cc=peterz@infradead.org \
--cc=rafael.j.wysocki@intel.com \
--cc=ricardo.neri-calderon@linux.intel.com \
--cc=rostedt@goodmis.org \
--cc=sudeep.holla@arm.com \
--cc=svens@linux.ibm.com \
--cc=swapnil.sapkal@amd.com \
--cc=tglx@linutronix.de \
--cc=thomas.weissschuh@linutronix.de \
--cc=tim.c.chen@linux.intel.com \
--cc=vincent.guittot@linaro.org \
--cc=vinicius.gomes@intel.com \
--cc=vschneid@redhat.com \
--cc=x86@kernel.org \
--cc=yangyicong@hisilicon.com \
--cc=yury.norov@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®