From: Christophe Leroy <christophe.leroy@csgroup.eu>
To: K Prateek Nayak <kprateek.nayak@amd.com>,
Madhavan Srinivasan <maddy@linux.ibm.com>,
Michael Ellerman <mpe@ellerman.id.au>,
Nicholas Piggin <npiggin@gmail.com>,
Heiko Carstens <hca@linux.ibm.com>,
Vasily Gorbik <gor@linux.ibm.com>,
Alexander Gordeev <agordeev@linux.ibm.com>,
Christian Borntraeger <borntraeger@linux.ibm.com>,
Sven Schnelle <svens@linux.ibm.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
x86@kernel.org, "H. Peter Anvin" <hpa@zytor.com>,
Peter Zijlstra <peterz@infradead.org>,
Juri Lelli <juri.lelli@redhat.com>,
Vincent Guittot <vincent.guittot@linaro.org>,
linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org,
linux-s390@vger.kernel.org
Cc: Dietmar Eggemann <dietmar.eggemann@arm.com>,
Steven Rostedt <rostedt@goodmis.org>,
Ben Segall <bsegall@google.com>, Mel Gorman <mgorman@suse.de>,
Valentin Schneider <vschneid@redhat.com>,
thomas.weissschuh@linutronix.de,
Li Chen <chenl311@chinatelecom.cn>,
Bibo Mao <maobibo@loongson.cn>, Mete Durlu <meted@linux.ibm.com>,
Tobias Huschle <huschle@linux.ibm.com>,
Easwar Hariharan <easwar.hariharan@linux.microsoft.com>,
Guo Weikang <guoweikang.kernel@gmail.com>,
"Rafael J. Wysocki" <rafael.j.wysocki@intel.com>,
Brian Gerst <brgerst@gmail.com>,
Patryk Wlazlyn <patryk.wlazlyn@linux.intel.com>,
Swapnil Sapkal <swapnil.sapkal@amd.com>,
"Yury Norov [NVIDIA]" <yury.norov@gmail.com>,
Sudeep Holla <sudeep.holla@arm.com>,
Jonathan Cameron <Jonathan.Cameron@huawei.com>,
Andrea Righi <arighi@nvidia.com>,
Yicong Yang <yangyicong@hisilicon.com>,
Ricardo Neri <ricardo.neri-calderon@linux.intel.com>,
Tim Chen <tim.c.chen@linux.intel.com>,
Vinicius Costa Gomes <vinicius.gomes@intel.com>
Subject: Re: [PATCH v7 2/8] powerpc/smp: Rename cpu_corgroup_* to cpu_corgrp_*
Date: Tue, 26 Aug 2025 07:02:48 +0200 [thread overview]
Message-ID: <6e197065-a782-4e24-bf38-5e423d0509ff@csgroup.eu> (raw)
In-Reply-To: <20250826041319.1284-3-kprateek.nayak@amd.com>
Le 26/08/2025 à 06:13, K Prateek Nayak a écrit :
> Rename cpu_corgroup_{map,mask} to cpu_corgrp_{map,mask} to free up the
> cpu_corgroup_* namespace. cpu_corgroup_mask() will be added back in the
> subsequent commit for CONFIG_SCHED_MC enablement.
This renaming seems odd and uncomplete. For instance
update_coregroup_mask() should probably be renamed as well shoudln't it ?
When you say cpu_corgroup_mask() will be added back, you mean the same
function or a completely different function but with the same name ?
What's really the difference between corgrp and coregroup ?
Shouldn't also has_coregroup_support() now be renamed has_corgrp_support() ?
Christophe
>
> No functional changes intended.
>
> Signed-off-by: K Prateek Nayak <kprateek.nayak@amd.com>
> ---
> arch/powerpc/kernel/smp.c | 26 +++++++++++++-------------
> 1 file changed, 13 insertions(+), 13 deletions(-)
>
> diff --git a/arch/powerpc/kernel/smp.c b/arch/powerpc/kernel/smp.c
> index 862f50c09539..4f48262658cc 100644
> --- a/arch/powerpc/kernel/smp.c
> +++ b/arch/powerpc/kernel/smp.c
> @@ -87,7 +87,7 @@ DEFINE_PER_CPU(cpumask_var_t, cpu_sibling_map);
> DEFINE_PER_CPU(cpumask_var_t, cpu_smallcore_map);
> DEFINE_PER_CPU(cpumask_var_t, cpu_l2_cache_map);
> DEFINE_PER_CPU(cpumask_var_t, cpu_core_map);
> -static DEFINE_PER_CPU(cpumask_var_t, cpu_coregroup_map);
> +static DEFINE_PER_CPU(cpumask_var_t, cpu_corgrp_map);
>
> EXPORT_PER_CPU_SYMBOL(cpu_sibling_map);
> EXPORT_PER_CPU_SYMBOL(cpu_l2_cache_map);
> @@ -1045,9 +1045,9 @@ static const struct cpumask *tl_smt_mask(struct sched_domain_topology_level *tl,
> }
> #endif
>
> -static struct cpumask *cpu_coregroup_mask(int cpu)
> +static struct cpumask *cpu_corgrp_mask(int cpu)
> {
> - return per_cpu(cpu_coregroup_map, cpu);
> + return per_cpu(cpu_corgrp_map, cpu);
> }
>
> static bool has_coregroup_support(void)
> @@ -1061,7 +1061,7 @@ static bool has_coregroup_support(void)
>
> static const struct cpumask *cpu_mc_mask(struct sched_domain_topology_level *tl, int cpu)
> {
> - return cpu_coregroup_mask(cpu);
> + return cpu_corgrp_mask(cpu);
> }
>
> static const struct cpumask *cpu_pkg_mask(struct sched_domain_topology_level *tl, int cpu)
> @@ -1124,7 +1124,7 @@ void __init smp_prepare_cpus(unsigned int max_cpus)
> zalloc_cpumask_var_node(&per_cpu(cpu_core_map, cpu),
> GFP_KERNEL, cpu_to_node(cpu));
> if (has_coregroup_support())
> - zalloc_cpumask_var_node(&per_cpu(cpu_coregroup_map, cpu),
> + zalloc_cpumask_var_node(&per_cpu(cpu_corgrp_map, cpu),
> GFP_KERNEL, cpu_to_node(cpu));
>
> #ifdef CONFIG_NUMA
> @@ -1145,7 +1145,7 @@ void __init smp_prepare_cpus(unsigned int max_cpus)
> cpumask_set_cpu(boot_cpuid, cpu_core_mask(boot_cpuid));
>
> if (has_coregroup_support())
> - cpumask_set_cpu(boot_cpuid, cpu_coregroup_mask(boot_cpuid));
> + cpumask_set_cpu(boot_cpuid, cpu_corgrp_mask(boot_cpuid));
>
> init_big_cores();
> if (has_big_cores) {
> @@ -1510,8 +1510,8 @@ static void remove_cpu_from_masks(int cpu)
> set_cpus_unrelated(cpu, i, cpu_core_mask);
>
> if (has_coregroup_support()) {
> - for_each_cpu(i, cpu_coregroup_mask(cpu))
> - set_cpus_unrelated(cpu, i, cpu_coregroup_mask);
> + for_each_cpu(i, cpu_corgrp_mask(cpu))
> + set_cpus_unrelated(cpu, i, cpu_corgrp_mask);
> }
> }
> #endif
> @@ -1543,7 +1543,7 @@ static void update_coregroup_mask(int cpu, cpumask_var_t *mask)
> if (!*mask) {
> /* Assume only siblings are part of this CPU's coregroup */
> for_each_cpu(i, submask_fn(cpu))
> - set_cpus_related(cpu, i, cpu_coregroup_mask);
> + set_cpus_related(cpu, i, cpu_corgrp_mask);
>
> return;
> }
> @@ -1551,18 +1551,18 @@ static void update_coregroup_mask(int cpu, cpumask_var_t *mask)
> cpumask_and(*mask, cpu_online_mask, cpu_node_mask(cpu));
>
> /* Update coregroup mask with all the CPUs that are part of submask */
> - or_cpumasks_related(cpu, cpu, submask_fn, cpu_coregroup_mask);
> + or_cpumasks_related(cpu, cpu, submask_fn, cpu_corgrp_mask);
>
> /* Skip all CPUs already part of coregroup mask */
> - cpumask_andnot(*mask, *mask, cpu_coregroup_mask(cpu));
> + cpumask_andnot(*mask, *mask, cpu_corgrp_mask(cpu));
>
> for_each_cpu(i, *mask) {
> /* Skip all CPUs not part of this coregroup */
> if (coregroup_id == cpu_to_coregroup_id(i)) {
> - or_cpumasks_related(cpu, i, submask_fn, cpu_coregroup_mask);
> + or_cpumasks_related(cpu, i, submask_fn, cpu_corgrp_mask);
> cpumask_andnot(*mask, *mask, submask_fn(i));
> } else {
> - cpumask_andnot(*mask, *mask, cpu_coregroup_mask(i));
> + cpumask_andnot(*mask, *mask, cpu_corgrp_mask(i));
> }
> }
> }
next prev parent reply other threads:[~2025-08-26 5:25 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-08-26 4:13 [PATCH v7 0/8] sched/fair: Get rid of sched_domains_curr_level hack for tl->cpumask() K Prateek Nayak
2025-08-26 4:13 ` [PATCH v7 1/8] " K Prateek Nayak
2025-08-28 23:06 ` Tim Chen
2025-08-26 4:13 ` [PATCH v7 2/8] powerpc/smp: Rename cpu_corgroup_* to cpu_corgrp_* K Prateek Nayak
2025-08-26 5:02 ` Christophe Leroy [this message]
2025-09-01 3:05 ` K Prateek Nayak
2025-08-26 4:13 ` [PATCH v7 3/8] powerpc/smp: Export cpu_coregroup_mask() K Prateek Nayak
2025-08-26 4:54 ` Christophe Leroy
2025-08-26 4:13 ` [PATCH v7 4/8] powerpc/smp: Introduce CONFIG_SCHED_MC to guard MC scheduling bits K Prateek Nayak
2025-08-26 4:49 ` Christophe Leroy
2025-08-26 8:07 ` Peter Zijlstra
2025-08-26 9:43 ` Peter Zijlstra
2025-08-26 9:59 ` Peter Zijlstra
2025-08-28 14:43 ` Shrikanth Hegde
2025-09-01 8:35 ` Peter Zijlstra
2025-09-01 8:52 ` Peter Zijlstra
2025-09-03 8:05 ` [tip: sched/core] sched: Unify the SCHED_{SMT,CLUSTER,MC} Kconfig tip-bot2 for Peter Zijlstra
2025-10-14 9:25 ` [PATCH v7 4/8] powerpc/smp: Introduce CONFIG_SCHED_MC to guard MC scheduling bits Geert Uytterhoeven
2025-10-14 9:42 ` Peter Zijlstra
2025-10-14 12:37 ` Geert Uytterhoeven
2025-10-14 14:17 ` Peter Zijlstra
2025-10-14 15:04 ` Geert Uytterhoeven
2025-08-26 9:27 ` Shrikanth Hegde
2025-09-01 3:57 ` K Prateek Nayak
2025-09-01 4:50 ` K Prateek Nayak
2025-08-26 4:13 ` [PATCH v7 5/8] sched/topology: Unify tl_smt_mask() across core and all arch K Prateek Nayak
2025-08-26 5:13 ` Christophe Leroy
2025-08-26 8:01 ` Peter Zijlstra
2025-08-26 8:11 ` Christophe Leroy
2025-08-26 8:24 ` Peter Zijlstra
2025-08-26 4:13 ` [PATCH v7 6/8] sched/topology: Unify tl_cls_mask() across core and x86 K Prateek Nayak
2025-08-26 5:14 ` Christophe Leroy
2025-08-26 4:13 ` [PATCH v7 7/8] sched/topology: Unify tl_mc_mask() across core and all arch K Prateek Nayak
2025-08-26 5:15 ` Christophe Leroy
2025-08-26 4:13 ` [PATCH v7 8/8] sched/topology: Unify tl_pkg_mask() " K Prateek Nayak
2025-08-26 5:16 ` Christophe Leroy
2025-08-26 10:05 ` [PATCH v7 0/8] sched/fair: Get rid of sched_domains_curr_level hack for tl->cpumask() Shrikanth Hegde
2025-08-26 10:13 ` Peter Zijlstra
2025-08-29 7:53 ` Valentin Schneider
2025-08-29 8:53 ` Shrikanth Hegde
2025-09-01 4:39 ` K Prateek Nayak
2025-09-01 8:58 ` Peter Zijlstra
2025-09-01 17:06 ` Shrikanth Hegde
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6e197065-a782-4e24-bf38-5e423d0509ff@csgroup.eu \
--to=christophe.leroy@csgroup.eu \
--cc=Jonathan.Cameron@huawei.com \
--cc=agordeev@linux.ibm.com \
--cc=arighi@nvidia.com \
--cc=borntraeger@linux.ibm.com \
--cc=bp@alien8.de \
--cc=brgerst@gmail.com \
--cc=bsegall@google.com \
--cc=chenl311@chinatelecom.cn \
--cc=dave.hansen@linux.intel.com \
--cc=dietmar.eggemann@arm.com \
--cc=easwar.hariharan@linux.microsoft.com \
--cc=gor@linux.ibm.com \
--cc=guoweikang.kernel@gmail.com \
--cc=hca@linux.ibm.com \
--cc=hpa@zytor.com \
--cc=huschle@linux.ibm.com \
--cc=juri.lelli@redhat.com \
--cc=kprateek.nayak@amd.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-s390@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=maddy@linux.ibm.com \
--cc=maobibo@loongson.cn \
--cc=meted@linux.ibm.com \
--cc=mgorman@suse.de \
--cc=mingo@redhat.com \
--cc=mpe@ellerman.id.au \
--cc=npiggin@gmail.com \
--cc=patryk.wlazlyn@linux.intel.com \
--cc=peterz@infradead.org \
--cc=rafael.j.wysocki@intel.com \
--cc=ricardo.neri-calderon@linux.intel.com \
--cc=rostedt@goodmis.org \
--cc=sudeep.holla@arm.com \
--cc=svens@linux.ibm.com \
--cc=swapnil.sapkal@amd.com \
--cc=tglx@linutronix.de \
--cc=thomas.weissschuh@linutronix.de \
--cc=tim.c.chen@linux.intel.com \
--cc=vincent.guittot@linaro.org \
--cc=vinicius.gomes@intel.com \
--cc=vschneid@redhat.com \
--cc=x86@kernel.org \
--cc=yangyicong@hisilicon.com \
--cc=yury.norov@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®