From: Nicholas Piggin <npiggin@gmail.com>
To: Waiman Long <longman@redhat.com>, Peter Zijlstra <peterz@infradead.org>
Cc: Boqun Feng <boqun.feng@gmail.com>,
linux-kernel@vger.kernel.org, Ingo Molnar <mingo@redhat.com>,
Will Deacon <will@kernel.org>
Subject: Re: [PATCH 05/13] locking/qspinlock: be less clever with the preprocessor
Date: Tue, 12 Jul 2022 10:33:57 +1000 [thread overview]
Message-ID: <1657585768.2fggybh789.astroid@bobo.none> (raw)
In-Reply-To: <9bb0e3b3-288f-31d2-ef82-684386265b3e@redhat.com>
Excerpts from Waiman Long's message of July 6, 2022 6:02 am:
> On 7/4/22 10:38, Nicholas Piggin wrote:
>> Stop qspinlock.c including itself and avoid most of the function
>> renaming with the preprocessor.
>>
>> This is mostly done by having the common slowpath code take a 'bool
>> paravirt' argument and adjusting code based on that.
>>
>> Signed-off-by: Nicholas Piggin <npiggin@gmail.com>
>> ---
>> kernel/locking/qspinlock.c | 116 ++++++++++++----------------
>> kernel/locking/qspinlock_paravirt.h | 10 +--
>> 2 files changed, 52 insertions(+), 74 deletions(-)
>>
>> diff --git a/kernel/locking/qspinlock.c b/kernel/locking/qspinlock.c
>> index 8f2173e22479..b96c58ca51de 100644
>> --- a/kernel/locking/qspinlock.c
>> +++ b/kernel/locking/qspinlock.c
>> @@ -11,8 +11,6 @@
>> * Peter Zijlstra <peterz@infradead.org>
>> */
>>
>> -#ifndef _GEN_PV_LOCK_SLOWPATH
>> -
>> #include <linux/smp.h>
>> #include <linux/bug.h>
>> #include <linux/cpumask.h>
>> @@ -285,35 +283,21 @@ static __always_inline void set_locked(struct qspinlock *lock)
>> WRITE_ONCE(lock->locked, _Q_LOCKED_VAL);
>> }
>>
>> -
>> -/*
>> - * Generate the native code for queued_spin_unlock_slowpath(); provide NOPs for
>> - * all the PV callbacks.
>> - */
>> -
>> -static __always_inline void __pv_init_node(struct qnode *node) { }
>> -static __always_inline void __pv_wait_node(struct qnode *node,
>> - struct qnode *prev) { }
>> -static __always_inline void __pv_kick_node(struct qspinlock *lock,
>> - struct qnode *node) { }
>> -static __always_inline u32 __pv_wait_head_or_lock(struct qspinlock *lock,
>> - struct qnode *node)
>> - { return 0; }
>> -
>> -#define pv_enabled() false
>> -
>> -#define pv_init_node __pv_init_node
>> -#define pv_wait_node __pv_wait_node
>> -#define pv_kick_node __pv_kick_node
>> -#define pv_wait_head_or_lock __pv_wait_head_or_lock
>> -
>> #ifdef CONFIG_PARAVIRT_SPINLOCKS
>> -#define queued_spin_lock_slowpath native_queued_spin_lock_slowpath
>> -#endif
>> -
>> -#endif /* _GEN_PV_LOCK_SLOWPATH */
>> +#include "qspinlock_paravirt.h"
>> +#else /* CONFIG_PARAVIRT_SPINLOCKS */
>> +static __always_inline void pv_init_node(struct qnode *node) { }
>> +static __always_inline void pv_wait_node(struct qnode *node,
>> + struct qnode *prev) { }
>> +static __always_inline void pv_kick_node(struct qspinlock *lock,
>> + struct qnode *node) { }
>> +static __always_inline u32 pv_wait_head_or_lock(struct qspinlock *lock,
>> + struct qnode *node)
>> + { return 0; }
>> +static __always_inline bool pv_hybrid_queued_unfair_trylock(struct qspinlock *lock) { BUILD_BUG(); }
>> +#endif /* CONFIG_PARAVIRT_SPINLOCKS */
>>
>> -static inline void queued_spin_lock_mcs_queue(struct qspinlock *lock)
>> +static inline void queued_spin_lock_mcs_queue(struct qspinlock *lock, bool paravirt)
>
> Using "const bool paravirt" may help the compiler generating better code
> by eliminating dead one, if it is not doing that already.
I think adding always_inline per Peter's suggestion should be enough.
The compiler should be able to see it's constant. Actually I'm surprised
attribute pure is helpful within a compilation unit, I would think the
compiler should be able to deduce that too.
That said, no problem with massaging things to help the compiler DTRT.
>
>> {
>> struct qnode *prev, *next, *node;
>> u32 val, old, tail;
>> @@ -338,8 +322,13 @@ static inline void queued_spin_lock_mcs_queue(struct qspinlock *lock)
>> */
>> if (unlikely(idx >= MAX_NODES)) {
>> lockevent_inc(lock_no_node);
>> - while (!queued_spin_trylock(lock))
>> - cpu_relax();
>> + if (paravirt) {
>> + while (!pv_hybrid_queued_unfair_trylock(lock))
>> + cpu_relax();
>> + } else {
>> + while (!queued_spin_trylock(lock))
>> + cpu_relax();
>> + }
>
> The code will look a bit better if you add the following helper function
> and use it instead.
>
> static inline bool queued_spin_trylock_common(struct qspinlock *lock,
> const bool paravirt)
> {
> if (paravirt)
> return pv_hybrid_queued_unfair_trylock(lock);
> else
> return queued_spin_trylock(lock);
> }
I did change that later on actually to always just use the basic
trylock. This was trying to be a more mechanical conversion that didn't
change too much.
Thanks,
Nick
next prev parent reply other threads:[~2022-07-12 0:34 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-07-04 14:38 [PATCH 00/13] locking/qspinlock: simplify code generation Nicholas Piggin
2022-07-04 14:38 ` [PATCH 01/13] locking/qspinlock: remove pv_node abstraction Nicholas Piggin
2022-07-06 23:23 ` Boqun Feng
2022-07-04 14:38 ` [PATCH 02/13] locking/qspinlock: inline mcs_spinlock functions into qspinlock Nicholas Piggin
2022-07-05 16:57 ` Peter Zijlstra
2022-07-12 0:06 ` Nicholas Piggin
2022-07-04 14:38 ` [PATCH 03/13] locking/qspinlock: split common mcs queueing code into its own function Nicholas Piggin
2022-07-05 17:01 ` Peter Zijlstra
2022-07-12 0:10 ` Nicholas Piggin
2022-07-04 14:38 ` [PATCH 04/13] locking/qspinlock: move pv lock word helpers into qspinlock.c Nicholas Piggin
2022-07-05 19:34 ` Waiman Long
2022-07-12 0:11 ` Nicholas Piggin
2022-07-04 14:38 ` [PATCH 05/13] locking/qspinlock: be less clever with the preprocessor Nicholas Piggin
2022-07-05 17:08 ` Peter Zijlstra
2022-07-12 0:29 ` Nicholas Piggin
2022-07-05 20:02 ` Waiman Long
2022-07-12 0:33 ` Nicholas Piggin [this message]
2022-07-04 14:38 ` [PATCH 06/13] locking/qspinlock: merge qspinlock_paravirt.h into qspinlock.c Nicholas Piggin
2022-07-05 17:20 ` Peter Zijlstra
2022-07-05 17:36 ` Peter Zijlstra
2022-07-12 0:46 ` Nicholas Piggin
2022-07-06 13:35 ` Waiman Long
2022-07-06 14:16 ` Peter Zijlstra
2022-07-04 14:38 ` [PATCH 07/13] locking/qspinlock: remove arch qspinlock_paravirt.h includes Nicholas Piggin
2022-07-04 14:38 ` [PATCH 08/13] locking/qspinlock: stop renaming queued_spin_lock_slowpath to native_queued_spin_lock_slowpath Nicholas Piggin
2022-07-05 17:28 ` Peter Zijlstra
2022-07-04 14:38 ` [PATCH 09/13] locking/qspinlock: rename __pv_init_lock_hash to pv_spinlocks_init Nicholas Piggin
2022-07-04 14:38 ` [PATCH 10/13] locking/qspinlock: paravirt use simple trylock in case idx overflows Nicholas Piggin
2022-07-04 14:38 ` [PATCH 11/13] locking/qspinlock: Use queued_spin_trylock in pv_hybrid_queued_unfair_trylock Nicholas Piggin
2022-07-05 17:31 ` Peter Zijlstra
2022-07-05 20:15 ` Waiman Long
2022-07-12 0:48 ` Nicholas Piggin
2022-07-04 14:38 ` [PATCH 12/13] locking/qspinlock: separate pv_wait_node from the non-paravirt path Nicholas Piggin
2022-07-05 17:34 ` Peter Zijlstra
2022-07-12 0:50 ` Nicholas Piggin
2022-07-04 14:38 ` [PATCH 13/13] locking/qspinlock: simplify pv_wait_head_or_lock calling scheme Nicholas Piggin
2022-07-05 17:59 ` [PATCH 00/13] locking/qspinlock: simplify code generation Peter Zijlstra
2022-07-12 0:56 ` Nicholas Piggin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1657585768.2fggybh789.astroid@bobo.none \
--to=npiggin@gmail.com \
--cc=boqun.feng@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=longman@redhat.com \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®