From: Jeff Moyer <jmoyer@redhat.com>
To: Ian Kent <raven@themaw.net>
Cc: autofs@linux.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: autofs4 looks up wrong path element when ghosting is enabled
Date: Sat, 24 Sep 2005 16:51:12 -0400 [thread overview]
Message-ID: <17205.48192.180623.885538@segfault.boston.redhat.com> (raw)
In-Reply-To: <Pine.LNX.4.63.0509241644420.2069@donald.themaw.net>
==> Regarding Re: autofs4 looks up wrong path element when ghosting is enabled; Ian Kent <raven@themaw.net> adds:
raven> On Thu, 22 Sep 2005, Jeff Moyer wrote:
>> ==> Regarding Re: autofs4 looks up wrong path element when ghosting is
>> enabled; Ian Kent <raven@themaw.net> adds:
>>
raven> On Tue, 20 Sep 2005, Jeff Moyer wrote:
>> >> Hi, Ian, list,
>> >>
>> >> I have a bug filed against autofs when ghosting is enabled. The best
>> way >> to describe the bug is to walk through the reproducer, I guess.
>> >>
>> >> Take the following maps, for example:
>> >>
>> >> auto.master >> /sbox auto.sbox
>> >>
>> >> auto.sbox: >> src segfault:/sbox/src/
>> >>
>> >> Let's say that there is a file, id3_0.12.orig.tar.gz, in
>> segfault:/sbox/src/.
>> >>
>> >> To reproduce the problem, stop the nfs service on the server.
>> >>
>> >> On the client, do an 'ls /sbox/src/id3_012.orig.tar.gz'. This will
>> fail, >> as well it should. However, if we look in the logs, we find
>> this:
>> >>
>> >> automount[1182]: handle_packet_missing: token 1, name src >>
>> automount[1182]: attempting to mount entry /sbox/src >> ... >>
>> automount[1481]: mount(nfs): calling mkdir_path /sbox/src >>
>> automount[1481]: mount(nfs): calling mount -t nfs -s-o
>> tcp,intr,timeo=600,rsize=8192,wsize=8192,retrans=5 segfault:/sbox/src
>> /sbox/src >> automount[1481]: >> mount: RPC: Program not registered >>
>> automount[1481]: mount(nfs): add_bad_host: segfault:/sbox/src >>
>> automount[1481]: mount(nfs): nfs: mount failure segfault:/sbox/src on
>> /sbox/src >> automount[1481]: failed to mount /sbox/src >> ... >>
>> automount[1182]: send_fail: token=1 >> automount[1182]: handle_packet:
>> type = 0 >> automount[1182]: handle_packet_missing: token 2, name
>> src/id3_0.12.orig.tar.gz >> automount[1182]: attempting to mount entry
>> /sbox/src/id3_0.12.orig.tar.gz
>> >>
>> >> Noteworthy are these last two lines! Even though the mount failed,
>> we are >> continuing the lookup. The culprit is here, in cached_lookup:
>> >>
>> >> if (!dentry->d_op->d_revalidate(dentry, flags) &&
>> !d_invalidate(dentry)) { >> dput(dentry); >> dentry = NULL; >> }
>> >>
>> >> d_revalidate points to autofs4_revalidate, which calls
>> try_to_fill_dentry, >> which will return a status of 0. Since ghosting
>> is enabled, >> d_invalidate(dentry) will return -EBUSY, and so we return
>> the dentry to
raven> the
>> >> caller, which then continues the lookup.
>> >>
>> >> Ian, I'm not really sure how we can address this issue without VFS >>
>> changes. Any ideas?
>> >>
>>
raven> I'm aware of this problem. I'm not sure how to deal with it yet.
raven> The case above is probably not that difficult to solve but if the
raven> last component is a directory it's hard to work out it's a problem.
>> Ugh. If you're thinking what I think you're thinking, that's an ugly
>> hack.
raven> Don't think so.
raven> I've been seeing this for a while. I wasn't quite sure of the source
raven> but, for some reason your report has cleared that up.
raven> The problem is not so much the success returned on the failed mount
raven> (revalidate). It's the return from the following lookup. This is a
raven> lookup in a non-root directory. I replaced the non-root lookup with
raven> the root lookup a while ago and I think this is an unexpected side
raven> affect of that. Becuase of other changes that lead to that decision
raven> I think that it should be now be OK to put back the null function
raven> (always return a negative dentry) that was there before I started
raven> working on the browable maps feature.
raven> I'll change the module I use here and test it out for a while. If
raven> you have time I could make a patch for the 2.4 code and send it over
raven> so that you could test it out a bit as well.
Just send along the 2.6 patch, since I have to deal with that, too. I'll
go through the trouble of backporting it.
>>
raven> There's more information here than I've gathhered so far.
>> >> Oh, also note that, once the nfs service is started up again on the
>> server, >> the lookup of a specific file name will still fail! In this
>> case, the >> daemon won't even be called.
>>
raven> I'll have to check this out. It could be helpful.
>> Well, I've provided a reproducer. If you'd like log output from the
>> kernel side, let me know. I can certainly provide that.
raven> Don't think I need it. I'm fairly sure I understand what's
raven> happening here now. As I said above.
Cool. Thanks!
Jeff
next prev parent reply other threads:[~2005-09-24 20:51 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-09-20 19:02 Jeff Moyer
2005-09-21 1:25 ` Ian Kent
2005-09-22 21:09 ` Jeff Moyer
2005-09-24 8:59 ` Ian Kent
2005-09-24 20:51 ` Jeff Moyer [this message]
2005-09-25 1:25 ` Ian Kent
2005-09-26 15:14 ` Jeff Moyer
2005-09-27 4:21 ` Ian Kent
2005-09-26 20:57 ` Jeff Moyer
2005-09-27 4:34 ` Ian Kent
2005-10-08 5:43 ` Ian Kent
2005-10-08 12:50 ` Jeff Moyer
2005-10-09 4:29 ` Ian Kent
2005-10-15 12:30 ` Ian Kent
2005-10-19 20:49 ` Jeff Moyer
2005-10-20 0:50 ` Ian Kent
2005-10-29 7:42 ` Ian Kent
2005-10-31 11:33 ` Jeff Moyer
2005-10-31 13:27 ` Ian Kent
2005-11-05 9:50 ` [autofs] " Ian Kent
2005-11-10 23:51 ` Jeff Moyer
2005-11-11 14:53 ` Ian Kent
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=17205.48192.180623.885538@segfault.boston.redhat.com \
--to=jmoyer@redhat.com \
--cc=autofs@linux.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=raven@themaw.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®