mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Vegard Nossum" <vegard.nossum@gmail.com>
To: "Jeremy Fitzhardinge" <jeremy@goop.org>
Cc: "Sam Ravnborg" <sam@ravnborg.org>,
	"H. Peter Anvin" <hpa@zytor.com>,
	"Steve French" <smfrench@gmail.com>,
	lkml <linux-kernel@vger.kernel.org>
Subject: Re: kernel coding style for if ... else which cross #ifdef
Date: Sat, 24 May 2008 17:57:25 +0200	[thread overview]
Message-ID: <19f34abd0805240857l57e667fdicb240baf898f6296@mail.gmail.com> (raw)
In-Reply-To: <48383830.6060504@goop.org>

On Sat, May 24, 2008 at 5:45 PM, Jeremy Fitzhardinge <jeremy@goop.org> wrote:
> Sam Ravnborg wrote:
>>
>> We should actually do as you intially suggested and alwyas
>> define CONFIG_FOO no matter if FOO is built-in or module.
>> Because we do only want to distingush between the two in rare cases.
>>
>> But that is a separate patch and lets not do the same
>> mistage with CFG_*
>>
>
> I think pretty strongly that CFG_ and CONFIG_ should be exactly parallel.
>  If you want to change the meaning of CONFIG_X in the presence of modules,
> then change CFG_X at the same time.  Making them have different meanings
> will just confuse anyone wanting to convert #ifdef CONFIG_ code into
> if(CFG_) code.
>
>> I cooked up following patch - but I have not test-build a kernel yet.
>> We may use CFG_* here and there and clash is not good.
>>
>
> I have to say I'm not very keen on the CFG_* prefix.  It doesn't have any
> inherent meaning and just looks like a redundant abbreviation of CONFIG_;
> something which actually expresses the notion that it's always a
> compile-time constant would be better.  Not that I have any particularly
> good alternatives: CONST_? CCONST_? CONFIG_X_VAL? KCONFIG_? KONFIG_?
> KCONST_?

Don't know if this is really my place, but I could not agree more with
your characterisation of the CFG_* prefix and I will make the
following suggestion:

Why not use all-lowercase config_* names? It seems elegant, and fits
in with the notion that these are to be used not as macros, but as
ordinary constants.

(The only disadvantage I can see is that they will stand out less. But
I don't know how great the disadvantage is.)

You could even go further and make them real constants, something
along the lines of:

enum config_value { no, yes, mod };

static const enum config_value config_lockdep_support = yes;

(I believe the "static const" will prevent emission of this symbol in
the object file -- though I am not certain.)

You can now also test for specific values, e.g. if
(config_scsi_wait_scan == mod), in addition to simply testing the
truth value.

That concludes my suggestion.


Vegard

-- 
"The animistic metaphor of the bug that maliciously sneaked in while
the programmer was not looking is intellectually dishonest as it
disguises that the error is the programmer's own creation."
	-- E. W. Dijkstra, EWD1036

  reply	other threads:[~2008-05-24 15:57 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-05-23 19:11 Steve French
2008-05-23 20:42 ` Willy Tarreau
2008-05-23 20:49   ` Adrian Bunk
2008-05-23 21:05     ` Willy Tarreau
2008-05-23 23:03 ` H. Peter Anvin
2008-05-24  5:43   ` Sam Ravnborg
2008-05-24  5:42     ` H. Peter Anvin
2008-05-24  6:42       ` Sam Ravnborg
2008-05-24 10:06         ` Jeremy Fitzhardinge
2008-05-24 10:49           ` Adrian Bunk
2008-05-24 11:27           ` Sam Ravnborg
2008-05-24 14:35             ` Jeremy Fitzhardinge
2008-05-24 14:39               ` Willy Tarreau
2008-05-24 14:41                 ` Jeremy Fitzhardinge
2008-05-24 14:46                   ` Willy Tarreau
2008-05-24 15:36               ` Sam Ravnborg
2008-05-24 15:45                 ` Jeremy Fitzhardinge
2008-05-24 15:57                   ` Vegard Nossum [this message]
2008-05-24 16:02                     ` Jeremy Fitzhardinge
2008-05-24 16:40                       ` Tom Spink
2008-05-24 16:42                         ` Tom Spink
2008-05-24 20:38                         ` Jeremy Fitzhardinge
2008-05-24 20:43                           ` H. Peter Anvin
2008-05-24 20:51                             ` Jeremy Fitzhardinge
2008-05-24 20:54                               ` H. Peter Anvin
2008-05-24 21:15                                 ` Jeremy Fitzhardinge
2008-05-25 23:57                                   ` Adrian Bunk
2008-05-26  0:27                                     ` H. Peter Anvin
2008-05-24 18:12                     ` H. Peter Anvin
2008-05-24 18:12                   ` H. Peter Anvin
2008-05-24 18:51                   ` Sam Ravnborg
2008-05-24 18:08         ` H. Peter Anvin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=19f34abd0805240857l57e667fdicb240baf898f6296@mail.gmail.com \
    --to=vegard.nossum@gmail.com \
    --cc=hpa@zytor.com \
    --cc=jeremy@goop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sam@ravnborg.org \
    --cc=smfrench@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®