mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Daniel Lezcano <daniel.lezcano@linaro.org>
To: Daniel Lezcano <daniel.lezcano@linexp.org>, rafael@kernel.org
Cc: rui.zhang@intel.com, linux-pm@vger.kernel.org,
	linux-kernel@vger.kernel.org, khilman@baylibre.com,
	abailon@baylibre.com, lukasz.luba@arm.com
Subject: Re: [PATCH v6 00/12] thermal OF rework
Date: Mon, 25 Jul 2022 18:34:03 +0200	[thread overview]
Message-ID: <1aa3ae56-84ae-8a96-7a52-3181c47dcb07@linaro.org> (raw)
In-Reply-To: <20220722200007.1839356-1-daniel.lezcano@linexp.org>


Hi Rafael,

On 22/07/2022 21:59, Daniel Lezcano wrote:
> The thermal framework initialization with the device tree appears to
> be complicated and hard to make it to evolve.
> 
> It contains duplication of almost the same thermal generic structures
> and has an assymetric initialization making hard any kind of serious
> changes for more complex features. One of them is the multiple sensors
> support per thermal zone.
> 
> In order to set the scene for the aforementioned feature with generic
> code, we need to cleanup and rework the device tree initialization.
> 
> However this rework is not obvious because of the multiple components
> entering in the composition of a thermal zone and being initialized at
> different moments. For instance, a cooling device can be initialized
> before a sensor, so the thermal zones must exist before the cooling
> device as well as the sensor. This asynchronous initialization forces
> the thermal zone to be created with fake ops because they are
> mandotory and build a list of cooling devices which is used to lookup
> afterwards when the cooling device driver is registering itself.
> 
> As there could be a large number of changes, this first series provide
> some steps forward for a simpler device tree initialization.
> 
> More series for cleanup and code duplication removal will follow.
> 
> Changelog:
> 
>   - v6:
>      - Folded patches 8, 9, 10
>      - Removed thermal_zone_get_trips() and thermal_zone_get_num_trips()
>      - Moved tz->ntrips => tz->num_trips changes into patch 11 to fix the
>        git bisecting
> 

I believe all the comments were addressed, is it fine if I merge this 
series ?


-- 
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs

Follow Linaro:  <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog

  parent reply	other threads:[~2022-07-25 16:34 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-22 19:59 Daniel Lezcano
2022-07-22 19:59 ` [PATCH v6 01/10] thermal/core: Remove duplicate information when an error occurs Daniel Lezcano
2022-07-22 19:59 ` [PATCH v6 02/10] thermal/of: Replace device node match with device node search Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 03/10] thermal/of: Remove the device node pointer for thermal_trip Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 04/10] thermal/of: Move thermal_trip structure to thermal.h Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 05/10] thermal/core: Remove unneeded EXPORT_SYMBOLS Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 06/10] thermal/core: Move thermal_set_delay_jiffies to static Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 07/10] thermal/core: Rename 'trips' to 'num_trips' Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 08/10] thermal/core: Add thermal_trip in thermal_zone Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 09/10] thermal/of: Use thermal trips stored in the thermal zone Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 10/10] thermal/of: Initialize trip points separately Daniel Lezcano
2022-07-25 16:34 ` Daniel Lezcano [this message]
2022-07-25 18:32   ` [PATCH v6 00/12] thermal OF rework Rafael J. Wysocki
2022-07-26  7:47   ` Lukasz Luba

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1aa3ae56-84ae-8a96-7a52-3181c47dcb07@linaro.org \
    --to=daniel.lezcano@linaro.org \
    --cc=abailon@baylibre.com \
    --cc=daniel.lezcano@linexp.org \
    --cc=khilman@baylibre.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=lukasz.luba@arm.com \
    --cc=rafael@kernel.org \
    --cc=rui.zhang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®