From: Daniel Lezcano <daniel.lezcano@linexp.org>
To: daniel.lezcano@linaro.org, rafael@kernel.org
Cc: rui.zhang@intel.com, linux-pm@vger.kernel.org,
linux-kernel@vger.kernel.org, khilman@baylibre.com,
abailon@baylibre.com, lukasz.luba@arm.com,
Amit Kucheria <amitk@kernel.org>
Subject: [PATCH v6 01/10] thermal/core: Remove duplicate information when an error occurs
Date: Fri, 22 Jul 2022 21:59:58 +0200 [thread overview]
Message-ID: <20220722200007.1839356-2-daniel.lezcano@linexp.org> (raw)
In-Reply-To: <20220722200007.1839356-1-daniel.lezcano@linexp.org>
The pr_err already tells it is an error, it is pointless to add the
'Error:' string in the messages. Remove them.
Cc: Alexandre Bailon <abailon@baylibre.com>
Cc: Kevin Hilman <khilman@baylibre.com>
Signed-off-by: Daniel Lezcano <daniel.lezcano@linexp.org>
Reviewed-by: Lukasz Luba <lukasz.luba@arm.com>
---
drivers/thermal/thermal_core.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/thermal/thermal_core.c b/drivers/thermal/thermal_core.c
index cdc0552e8c42..e22e7d939c54 100644
--- a/drivers/thermal/thermal_core.c
+++ b/drivers/thermal/thermal_core.c
@@ -1198,23 +1198,23 @@ thermal_zone_device_register(const char *type, int trips, int mask,
struct thermal_governor *governor;
if (!type || strlen(type) == 0) {
- pr_err("Error: No thermal zone type defined\n");
+ pr_err("No thermal zone type defined\n");
return ERR_PTR(-EINVAL);
}
if (type && strlen(type) >= THERMAL_NAME_LENGTH) {
- pr_err("Error: Thermal zone name (%s) too long, should be under %d chars\n",
+ pr_err("Thermal zone name (%s) too long, should be under %d chars\n",
type, THERMAL_NAME_LENGTH);
return ERR_PTR(-EINVAL);
}
if (trips > THERMAL_MAX_TRIPS || trips < 0 || mask >> trips) {
- pr_err("Error: Incorrect number of thermal trips\n");
+ pr_err("Incorrect number of thermal trips\n");
return ERR_PTR(-EINVAL);
}
if (!ops) {
- pr_err("Error: Thermal zone device ops not defined\n");
+ pr_err("Thermal zone device ops not defined\n");
return ERR_PTR(-EINVAL);
}
--
2.25.1
next prev parent reply other threads:[~2022-07-22 20:00 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-07-22 19:59 [PATCH v6 00/12] thermal OF rework Daniel Lezcano
2022-07-22 19:59 ` Daniel Lezcano [this message]
2022-07-22 19:59 ` [PATCH v6 02/10] thermal/of: Replace device node match with device node search Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 03/10] thermal/of: Remove the device node pointer for thermal_trip Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 04/10] thermal/of: Move thermal_trip structure to thermal.h Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 05/10] thermal/core: Remove unneeded EXPORT_SYMBOLS Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 06/10] thermal/core: Move thermal_set_delay_jiffies to static Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 07/10] thermal/core: Rename 'trips' to 'num_trips' Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 08/10] thermal/core: Add thermal_trip in thermal_zone Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 09/10] thermal/of: Use thermal trips stored in the thermal zone Daniel Lezcano
2022-07-22 20:00 ` [PATCH v6 10/10] thermal/of: Initialize trip points separately Daniel Lezcano
2022-07-25 16:34 ` [PATCH v6 00/12] thermal OF rework Daniel Lezcano
2022-07-25 18:32 ` Rafael J. Wysocki
2022-07-26 7:47 ` Lukasz Luba
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20220722200007.1839356-2-daniel.lezcano@linexp.org \
--to=daniel.lezcano@linexp.org \
--cc=abailon@baylibre.com \
--cc=amitk@kernel.org \
--cc=daniel.lezcano@linaro.org \
--cc=khilman@baylibre.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=lukasz.luba@arm.com \
--cc=rafael@kernel.org \
--cc=rui.zhang@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®