mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Tom Rini <trini@kernel.crashing.org>
To: Andi Kleen <ak@suse.de>
Cc: akpm@osdl.org, linux-kernel@vger.kernel.org,
	amitkale@linsyssoft.com, Bob Picco <bob.picco@hp.com>
Subject: Re: [patch 08/16] Add support for X86_64 platforms to KGDB
Date: Mon, 29 Aug 2005 10:45:25 -0700	[thread overview]
Message-ID: <20050829174525.GD3827@smtp.west.cox.net> (raw)
In-Reply-To: <200508291913.48648.ak@suse.de>

On Mon, Aug 29, 2005 at 07:13:47PM +0200, Andi Kleen wrote:
> On Monday 29 August 2005 18:10, Tom Rini wrote:
> 
> > +void __init early_setup_per_cpu_area(void)
> > +{
> > +	static char cpu0[PERCPU_ENOUGH_ROOM]
> > +		__attribute__ ((aligned (SMP_CACHE_BYTES)));
> > +	char *ptr = cpu0;
> > +
> > +	cpu_pda[0].data_offset = ptr - __per_cpu_start;
> > +	memcpy(ptr, __per_cpu_start, __per_cpu_end - __per_cpu_start);
> > +}
> 
> What is that?  It looks totally bogus. Can you tell exactly where you
> believe early per cpu data is needed?

Bob did this part (forgot to CC him, oops).  But I believe it's needed
for setting traps so much earlier.

> > +
> >  /*
> >   * Great future plan:
> >   * Declare PDA itself and support (irqstack,tss,pgd) as per cpu data.
> > @@ -97,7 +107,9 @@ void __init setup_per_cpu_areas(void)
> >  	for (i = 0; i < NR_CPUS; i++) {
> >  		char *ptr;
> >
> > -		if (!NODE_DATA(cpu_to_node(i))) {
> > +		if (cpu_pda[i].data_offset)
> > +			continue;
> 
> And that looks broken too.

I believe that's to takecare of the case where something is covered in
early_setup_cpu_areas().

> In general I would also advise to mix any other changes outside kgdb* into the 
> x86-64 kgdb patch. Either the patch should be merged into mainline in a 
> separate patch or kgdb reworked to not need this.

ok.

> > +	if (notify_die(DIE_PAGE_FAULT, "no context", regs, error_code, 14,
> > +				SIGSEGV) == NOTIFY_STOP)
> > +		return;
> > +
> 
> I can see the point of that. It's ok if you submit it as a separate patch.

I can split that out into one that follows the KDB_VECTOR rename easily
enough.

> Regarding early trap init: I would have no problem to move all of traps_init
> into setup_arch (and leave traps_init empty for generic code). I actually
> don't know why it runs so late. But doing it half way is ugly.

Should I make setup_per_cpu_area and trap_init empty and turn the real
ones into early_foo?

-- 
Tom Rini
http://gate.crashing.org/~trini/

  reply	other threads:[~2005-08-29 17:45 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-08-29 16:08 [patch 01/16] Add a KGDB core Tom Rini
     [not found] ` <1.2982005.trini@kernel.crashing.org>
2005-08-29 16:09   ` [patch 02/16] Add support for i386 platforms to KGDB Tom Rini
2005-08-29 19:55     ` [patch 2/3] x86_64: Run setup_per_cpu_areas and trap_init sooner Andi Kleen
2005-08-29 20:03       ` Tom Rini
2005-08-29 16:09   ` [patch 03/16] Add support for PowerPC32 platforms to KGDB Tom Rini
2005-08-29 16:09   ` [patch 04/16] I/O driver for 8250-compatible UARTs Tom Rini
2005-08-29 16:18     ` Russell King
2005-08-29 16:28       ` Tom Rini
2005-08-31 19:38     ` Bjorn Helgaas
2005-08-31 20:10       ` Tom Rini
2005-08-31 21:03         ` Russell King
2005-08-31 21:23           ` Tom Rini
2005-08-31 21:19         ` Bjorn Helgaas
2005-08-31 22:15           ` Tom Rini
2005-08-29 16:09   ` [patch 05/16] Add support for MIPS platforms to KGDB Tom Rini
2005-08-29 16:10   ` [patch 06/16] Add support for IA64 " Tom Rini
2005-08-29 16:10   ` [patch 07/16] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR Tom Rini
2005-08-29 16:10   ` [patch 08/16] Add support for X86_64 platforms to KGDB Tom Rini
2005-08-29 17:13     ` Andi Kleen
2005-08-29 17:45       ` Tom Rini [this message]
2005-08-29 18:46         ` Andi Kleen
2005-08-29 18:49           ` Tom Rini
2005-08-29 16:10   ` [patch 09/16] Add support for SuperH " Tom Rini
2005-08-29 16:10   ` [patch 10/16] Add support for ARM " Tom Rini
2005-08-29 16:11   ` [patch 11/16] Add support for PowerPC64 " Tom Rini
2005-08-29 16:11   ` [patch 12/16] KGDBoE I/O driver Tom Rini
2005-08-29 16:11   ` [patch 13/16] Add CFI DWARF2 annotation support Tom Rini
2005-08-29 16:11   ` [patch 14/16] Minor SysRq keyboard bugfix for KGDB Tom Rini
2005-08-29 16:11   ` [patch 15/16] Allow KGDB to work well with loaded modules Tom Rini
2005-08-29 16:12   ` [patch 16/16] Add hardware breakpoint support for i386 Tom Rini
2005-08-29 21:23     ` Andi Kleen
2005-08-31 14:39       ` Tom Rini
2005-08-30  1:06     ` Keith Owens
2005-08-30  7:33 ` [patch 1/3] x86_64: Add a notify_die() call to the "no context" part of do_page_fault() George Anzinger
2005-08-30 14:06   ` Tom Rini
2005-08-30 14:50     ` George Anzinger
2005-08-30 19:53       ` Tom Rini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050829174525.GD3827@smtp.west.cox.net \
    --to=trini@kernel.crashing.org \
    --cc=ak@suse.de \
    --cc=akpm@osdl.org \
    --cc=amitkale@linsyssoft.com \
    --cc=bob.picco@hp.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome