From: Tom Rini <trini@kernel.crashing.org>
To: Bjorn Helgaas <bjorn.helgaas@hp.com>
Cc: akpm@osdl.org, linux-kernel@vger.kernel.org, rmk@arm.linux.org.uk
Subject: Re: [patch 04/16] I/O driver for 8250-compatible UARTs
Date: Wed, 31 Aug 2005 15:15:52 -0700 [thread overview]
Message-ID: <20050831221552.GO3966@smtp.west.cox.net> (raw)
In-Reply-To: <200508311519.37523.bjorn.helgaas@hp.com>
On Wed, Aug 31, 2005 at 03:19:37PM -0600, Bjorn Helgaas wrote:
> On Wednesday 31 August 2005 2:10 pm, Tom Rini wrote:
> > On Wed, Aug 31, 2005 at 01:38:52PM -0600, Bjorn Helgaas wrote:
> > > On Monday 29 August 2005 10:09 am, Tom Rini wrote:
> > I've tried intentionally to not mention 'ttyS' anywhere (exposed to the
> > user) because it's really not 'ttySN' but it is the port registered to
> > us.
>
> So kgdb's port N is different from ttySN? That sounds really
> confusing. And KGDB_SIMPLE_SERIAL does mention "ttyS".
It's not intentionally different, and really only might be different in
the we have ttySX case, but ttySX isn't registered to KGDB case.
> > There's really two cases we have to deal with. The first case is a
> > known at compile time or can be registered at boot-time easily port (ie
> > dumb old PC or ARM boards). The second case is "serial port over
> > there". Perhaps we should change the kgdb8250 arg to be an override of
> > the default port, so:
> > kgdb8250={io,mmio},<irq>,<token>,<baud rate>
>
> That makes sense. But I'd make it {io,mmio},<token>,<baud>,<irq>
> so it's more like the existing "console=uart" argument.
ok.
> > > > + printk(KERN_ERR "kgdb8250: argument error, usage: "
> > > > + "kgdb8250=<port number>,<baud rate>");
> > > > +#ifdef CONFIG_IA64
> > > > + printk(",<irq>,<iomem base>");
> > > > +#endif
> > >
> > > This isn't ia64-specific.
> >
> > It is and it isn't. Since no one's tried a PCI card uart for KGDB nor
> > had a case where we have to pass in the mmio addr except on ia64, it is
> > ia64-specific.
>
> Maybe it's only been *tested* on ia64, but I don't think that's a
> reason to make it compiled only on ia64.
It's only been needed on ia64. But it's moot since I've reworked things
for kgdb8250= is always a complete override.
> Actually, I think KGDB_SIMPLE_SERIAL, KGDB_*BAUD, KGDB_PORT_*,
> KGDB_PORT, and KGDB_IRQ are overkill. Could they all be nuked
> in favor of a KGDB_8250_DEVICE that could be set to things like
> "ttyS0,115200" or "io,0x3f8,115200,49"?
Hmm. I'll give that a shot momentarily... That sounds like a good idea
'tho..
--
Tom Rini
http://gate.crashing.org/~trini/
next prev parent reply other threads:[~2005-08-31 22:15 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-08-29 16:08 [patch 01/16] Add a KGDB core Tom Rini
[not found] ` <1.2982005.trini@kernel.crashing.org>
2005-08-29 16:09 ` [patch 02/16] Add support for i386 platforms to KGDB Tom Rini
2005-08-29 19:55 ` [patch 2/3] x86_64: Run setup_per_cpu_areas and trap_init sooner Andi Kleen
2005-08-29 20:03 ` Tom Rini
2005-08-29 16:09 ` [patch 03/16] Add support for PowerPC32 platforms to KGDB Tom Rini
2005-08-29 16:09 ` [patch 04/16] I/O driver for 8250-compatible UARTs Tom Rini
2005-08-29 16:18 ` Russell King
2005-08-29 16:28 ` Tom Rini
2005-08-31 19:38 ` Bjorn Helgaas
2005-08-31 20:10 ` Tom Rini
2005-08-31 21:03 ` Russell King
2005-08-31 21:23 ` Tom Rini
2005-08-31 21:19 ` Bjorn Helgaas
2005-08-31 22:15 ` Tom Rini [this message]
2005-08-29 16:09 ` [patch 05/16] Add support for MIPS platforms to KGDB Tom Rini
2005-08-29 16:10 ` [patch 06/16] Add support for IA64 " Tom Rini
2005-08-29 16:10 ` [patch 07/16] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR Tom Rini
2005-08-29 16:10 ` [patch 08/16] Add support for X86_64 platforms to KGDB Tom Rini
2005-08-29 17:13 ` Andi Kleen
2005-08-29 17:45 ` Tom Rini
2005-08-29 18:46 ` Andi Kleen
2005-08-29 18:49 ` Tom Rini
2005-08-29 16:10 ` [patch 09/16] Add support for SuperH " Tom Rini
2005-08-29 16:10 ` [patch 10/16] Add support for ARM " Tom Rini
2005-08-29 16:11 ` [patch 11/16] Add support for PowerPC64 " Tom Rini
2005-08-29 16:11 ` [patch 12/16] KGDBoE I/O driver Tom Rini
2005-08-29 16:11 ` [patch 13/16] Add CFI DWARF2 annotation support Tom Rini
2005-08-29 16:11 ` [patch 14/16] Minor SysRq keyboard bugfix for KGDB Tom Rini
2005-08-29 16:11 ` [patch 15/16] Allow KGDB to work well with loaded modules Tom Rini
2005-08-29 16:12 ` [patch 16/16] Add hardware breakpoint support for i386 Tom Rini
2005-08-29 21:23 ` Andi Kleen
2005-08-31 14:39 ` Tom Rini
2005-08-30 1:06 ` Keith Owens
2005-08-30 7:33 ` [patch 1/3] x86_64: Add a notify_die() call to the "no context" part of do_page_fault() George Anzinger
2005-08-30 14:06 ` Tom Rini
2005-08-30 14:50 ` George Anzinger
2005-08-30 19:53 ` Tom Rini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20050831221552.GO3966@smtp.west.cox.net \
--to=trini@kernel.crashing.org \
--cc=akpm@osdl.org \
--cc=bjorn.helgaas@hp.com \
--cc=linux-kernel@vger.kernel.org \
--cc=rmk@arm.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®