mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Tom Rini <trini@kernel.crashing.org>
To: George Anzinger <george@mvista.com>
Cc: akpm@osdl.org, linux-kernel@vger.kernel.org
Subject: Re: [patch 1/3] x86_64: Add a notify_die() call to the "no context" part of do_page_fault()
Date: Tue, 30 Aug 2005 12:53:41 -0700	[thread overview]
Message-ID: <20050830195341.GE3966@smtp.west.cox.net> (raw)
In-Reply-To: <43147237.5030108@mvista.com>

On Tue, Aug 30, 2005 at 07:50:31AM -0700, George Anzinger wrote:
> Tom Rini wrote:
[snip]
> >"no context" is the label we're in, in the code.  What it's actually
> >used for is "hey, we (== kgdb) tried to read/write a very very bogus
> >addr, time to longjmp".  If it's not true that kgdb is at fault then we
> >drop to the debugger anyhow, and the user can see where they came from.
> >
> No.  What the user sees is the offending code (i.e. prior to the trap to 
> page_fault), NOT how kgdb happend to be called.  The "no_context" is IN 
> the _context_ of page_fault, but that is lost by the time you get to 
> kgdb and ask to see _why_ (via, hint, hint: "p kgdb_info").

So you're suggesting changing what we pass in so that if we also modify
kgdb_info to contain the 'where' thing you talked about before, it would
be more useful, yes?  If so, I think that can wait just a bit. :)

-- 
Tom Rini
http://gate.crashing.org/~trini/

      reply	other threads:[~2005-08-30 19:53 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-08-29 16:08 [patch 01/16] Add a KGDB core Tom Rini
     [not found] ` <1.2982005.trini@kernel.crashing.org>
2005-08-29 16:09   ` [patch 02/16] Add support for i386 platforms to KGDB Tom Rini
2005-08-29 19:55     ` [patch 2/3] x86_64: Run setup_per_cpu_areas and trap_init sooner Andi Kleen
2005-08-29 20:03       ` Tom Rini
2005-08-29 16:09   ` [patch 03/16] Add support for PowerPC32 platforms to KGDB Tom Rini
2005-08-29 16:09   ` [patch 04/16] I/O driver for 8250-compatible UARTs Tom Rini
2005-08-29 16:18     ` Russell King
2005-08-29 16:28       ` Tom Rini
2005-08-31 19:38     ` Bjorn Helgaas
2005-08-31 20:10       ` Tom Rini
2005-08-31 21:03         ` Russell King
2005-08-31 21:23           ` Tom Rini
2005-08-31 21:19         ` Bjorn Helgaas
2005-08-31 22:15           ` Tom Rini
2005-08-29 16:09   ` [patch 05/16] Add support for MIPS platforms to KGDB Tom Rini
2005-08-29 16:10   ` [patch 06/16] Add support for IA64 " Tom Rini
2005-08-29 16:10   ` [patch 07/16] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR Tom Rini
2005-08-29 16:10   ` [patch 08/16] Add support for X86_64 platforms to KGDB Tom Rini
2005-08-29 17:13     ` Andi Kleen
2005-08-29 17:45       ` Tom Rini
2005-08-29 18:46         ` Andi Kleen
2005-08-29 18:49           ` Tom Rini
2005-08-29 16:10   ` [patch 09/16] Add support for SuperH " Tom Rini
2005-08-29 16:10   ` [patch 10/16] Add support for ARM " Tom Rini
2005-08-29 16:11   ` [patch 11/16] Add support for PowerPC64 " Tom Rini
2005-08-29 16:11   ` [patch 12/16] KGDBoE I/O driver Tom Rini
2005-08-29 16:11   ` [patch 13/16] Add CFI DWARF2 annotation support Tom Rini
2005-08-29 16:11   ` [patch 14/16] Minor SysRq keyboard bugfix for KGDB Tom Rini
2005-08-29 16:11   ` [patch 15/16] Allow KGDB to work well with loaded modules Tom Rini
2005-08-29 16:12   ` [patch 16/16] Add hardware breakpoint support for i386 Tom Rini
2005-08-29 21:23     ` Andi Kleen
2005-08-31 14:39       ` Tom Rini
2005-08-30  1:06     ` Keith Owens
2005-08-30  7:33 ` [patch 1/3] x86_64: Add a notify_die() call to the "no context" part of do_page_fault() George Anzinger
2005-08-30 14:06   ` Tom Rini
2005-08-30 14:50     ` George Anzinger
2005-08-30 19:53       ` Tom Rini [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050830195341.GE3966@smtp.west.cox.net \
    --to=trini@kernel.crashing.org \
    --cc=akpm@osdl.org \
    --cc=george@mvista.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome