mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 1/2] Make x86_64 udelay() round up instead of down.
@ 2006-10-29 20:07 Paolo 'Blaisorblade' Giarrusso
  2006-10-29 20:07 ` [PATCH 2/2] i386, x86_64: comment magic constants in delay.h Paolo 'Blaisorblade' Giarrusso
  2006-11-01 16:30 ` [PATCH 1/2] Make x86_64 udelay() round up instead of down Pavel Machek
  0 siblings, 2 replies; 8+ messages in thread
From: Paolo 'Blaisorblade' Giarrusso @ 2006-10-29 20:07 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Andi Kleen, linux-kernel

From: Paolo 'Blaisorblade' Giarrusso <blaisorblade@yahoo.it>

Port two patches from i386 to x86_64 delay.c to make sure all rounding is done
upward instead of downward.

There is no sign in commit messages that the mismatch was done on purpose, and
"delay() guarantees sleeping at least for the specified time" is still a valid
rule IMHO.

The original x86 patches are both from pre-GIT era, i.e.:

"[PATCH] round up  in __udelay()" in commit
54c7e1f5cc6771ff644d7bc21a2b829308bd126f

"[PATCH] add 1 in __const_udelay()" in commit
42c77a9801b8877d8b90f65f75db758822a0bccc

(both commits are from converted BK repository to x86_64).

Signed-off-by: Paolo 'Blaisorblade' Giarrusso <blaisorblade@yahoo.it>
---

 arch/x86_64/lib/delay.c    |    4 ++--
 include/asm-x86_64/delay.h |    2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/x86_64/lib/delay.c b/arch/x86_64/lib/delay.c
index 50be909..7514df0 100644
--- a/arch/x86_64/lib/delay.c
+++ b/arch/x86_64/lib/delay.c
@@ -40,13 +40,13 @@ EXPORT_SYMBOL(__delay);
 
 inline void __const_udelay(unsigned long xloops)
 {
-	__delay((xloops * HZ * cpu_data[raw_smp_processor_id()].loops_per_jiffy) >> 32);
+	__delay((xloops * HZ * cpu_data[raw_smp_processor_id()].loops_per_jiffy) >> 32 + 1);
 }
 EXPORT_SYMBOL(__const_udelay);
 
 void __udelay(unsigned long usecs)
 {
-	__const_udelay(usecs * 0x000010c6);  /* 2**32 / 1000000 */
+	__const_udelay(usecs * 0x000010c7);  /* 2**32 / 1000000 (rounded up) */
 }
 EXPORT_SYMBOL(__udelay);
 
diff --git a/include/asm-x86_64/delay.h b/include/asm-x86_64/delay.h
index 65f64ac..40146f6 100644
--- a/include/asm-x86_64/delay.h
+++ b/include/asm-x86_64/delay.h
@@ -16,7 +16,7 @@ extern void __const_udelay(unsigned long
 extern void __delay(unsigned long loops);
 
 #define udelay(n) (__builtin_constant_p(n) ? \
-	((n) > 20000 ? __bad_udelay() : __const_udelay((n) * 0x10c6ul)) : \
+	((n) > 20000 ? __bad_udelay() : __const_udelay((n) * 0x10c7ul)) : \
 	__udelay(n))
 
 #define ndelay(n) (__builtin_constant_p(n) ? \
Chiacchiera con i tuoi amici in tempo reale! 
 http://it.yahoo.com/mail_it/foot/*http://it.messenger.yahoo.com 

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2006-11-17 22:18 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-10-29 20:07 [PATCH 1/2] Make x86_64 udelay() round up instead of down Paolo 'Blaisorblade' Giarrusso
2006-10-29 20:07 ` [PATCH 2/2] i386, x86_64: comment magic constants in delay.h Paolo 'Blaisorblade' Giarrusso
2006-11-01 16:30 ` [PATCH 1/2] Make x86_64 udelay() round up instead of down Pavel Machek
2006-11-10 22:16   ` Blaisorblade
2006-11-17 19:30   ` [PATCH 1/2] Make x86_64 udelay() round up instead of down - try2 Paolo 'Blaisorblade' Giarrusso
2006-11-17 22:00     ` Andrew Morton
2006-11-17 22:18       ` Blaisorblade
2006-11-17 19:30   ` [PATCH 2/2] i386, x86_64: comment magic constants in delay.h Paolo 'Blaisorblade' Giarrusso

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®