From: Vivek Goyal <vgoyal@in.ibm.com>
To: linux kernel mailing list <linux-kernel@vger.kernel.org>
Cc: Reloc Kernel List <fastboot@lists.osdl.org>,
ebiederm@xmission.com, akpm@osdl.org, ak@suse.de, hpa@zytor.com,
magnus.damm@gmail.com, lwang@redhat.com, dzickus@redhat.com,
pavel@suse.cz, rjw@sisk.pl
Subject: [PATCH 10/20] x86_64: wakeup.S Remove dead code
Date: Fri, 17 Nov 2006 17:47:02 -0500 [thread overview]
Message-ID: <20061117224702.GK15449@in.ibm.com> (raw)
In-Reply-To: <20061117223432.GA15449@in.ibm.com>
o Get rid of dead code in wakeup.S
o We never restore from saved_gdt, saved_idt, saved_ltd, saved_tss, saved_cr3,
saved_cr4, saved_cr0, real_save_gdt, saved_efer, saved_efer2. Get rid
of of associated code.
o Get rid of bogus_magic, bogus_31_magic and bogus_magic2. No longer being
used.
Signed-off-by: Eric W. Biederman <ebiederm@xmission.com>
Signed-off-by: Vivek Goyal <vgoyal@in.ibm.com>
---
arch/x86_64/kernel/acpi/wakeup.S | 57 ---------------------------------------
1 file changed, 1 insertion(+), 56 deletions(-)
diff -puN arch/x86_64/kernel/acpi/wakeup.S~x86_64-get-rid-of-dead-code-in-suspend-resume arch/x86_64/kernel/acpi/wakeup.S
--- linux-2.6.19-rc6-reloc/arch/x86_64/kernel/acpi/wakeup.S~x86_64-get-rid-of-dead-code-in-suspend-resume 2006-11-17 00:09:05.000000000 -0500
+++ linux-2.6.19-rc6-reloc-root/arch/x86_64/kernel/acpi/wakeup.S 2006-11-17 00:09:05.000000000 -0500
@@ -258,8 +258,6 @@ gdt_48a:
.word 0, 0 # gdt base (filled in later)
-real_save_gdt: .word 0
- .quad 0
real_magic: .quad 0
video_mode: .quad 0
video_flags: .quad 0
@@ -272,10 +270,6 @@ bogus_32_magic:
movb $0xb3,%al ; outb %al,$0x80
jmp bogus_32_magic
-bogus_31_magic:
- movb $0xb1,%al ; outb %al,$0x80
- jmp bogus_31_magic
-
bogus_cpu:
movb $0xbc,%al ; outb %al,$0x80
jmp bogus_cpu
@@ -346,16 +340,6 @@ check_vesaa:
_setbada: jmp setbada
- .code64
-bogus_magic:
- movw $0x0e00 + 'B', %ds:(0xb8018)
- jmp bogus_magic
-
-bogus_magic2:
- movw $0x0e00 + '2', %ds:(0xb8018)
- jmp bogus_magic2
-
-
wakeup_stack_begin: # Stack grows down
.org 0xff0
@@ -373,28 +357,11 @@ ENTRY(wakeup_end)
#
# Returned address is location of code in low memory (past data and stack)
#
+ .code64
ENTRY(acpi_copy_wakeup_routine)
pushq %rax
- pushq %rcx
pushq %rdx
- sgdt saved_gdt
- sidt saved_idt
- sldt saved_ldt
- str saved_tss
-
- movq %cr3, %rdx
- movq %rdx, saved_cr3
- movq %cr4, %rdx
- movq %rdx, saved_cr4
- movq %cr0, %rdx
- movq %rdx, saved_cr0
- sgdt real_save_gdt - wakeup_start (,%rdi)
- movl $MSR_EFER, %ecx
- rdmsr
- movl %eax, saved_efer
- movl %edx, saved_efer2
-
movl saved_video_mode, %edx
movl %edx, video_mode - wakeup_start (,%rdi)
movl acpi_video_flags, %edx
@@ -407,17 +374,8 @@ ENTRY(acpi_copy_wakeup_routine)
cmpl $0x9abcdef0, %eax
jne bogus_32_magic
- # make sure %cr4 is set correctly (features, etc)
- movl saved_cr4 - __START_KERNEL_map, %eax
- movq %rax, %cr4
-
- movl saved_cr0 - __START_KERNEL_map, %eax
- movq %rax, %cr0
- jmp 1f # Flush pipelines
-1:
# restore the regs we used
popq %rdx
- popq %rcx
popq %rax
ENTRY(do_suspend_lowlevel_s4bios)
ret
@@ -512,16 +470,3 @@ ENTRY(saved_eip) .quad 0
ENTRY(saved_esp) .quad 0
ENTRY(saved_magic) .quad 0
-
-ALIGN
-# saved registers
-saved_gdt: .quad 0,0
-saved_idt: .quad 0,0
-saved_ldt: .quad 0
-saved_tss: .quad 0
-
-saved_cr0: .quad 0
-saved_cr3: .quad 0
-saved_cr4: .quad 0
-saved_efer: .quad 0
-saved_efer2: .quad 0
_
next prev parent reply other threads:[~2006-11-18 0:07 UTC|newest]
Thread overview: 57+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-11-17 22:34 [RFC][PATCH 0/20] x86_64: Relocatable bzImage (V3) Vivek Goyal
2006-11-17 22:36 ` [PATCH 1/20] x86_64: Align data segment to PAGE_SIZE boundary Vivek Goyal
2006-11-17 22:37 ` [PATCH 2/20] x86_64: Assembly safe page.h and pgtable.h Vivek Goyal
2006-11-18 8:49 ` Andi Kleen
2006-11-18 13:19 ` Vivek Goyal
2006-11-17 22:38 ` [PATCH 3/20] x86_64: Kill temp_boot_pmds Vivek Goyal
2006-11-17 22:39 ` [PATCH 4/20] x86_64: Cleanup the early boot page table Vivek Goyal
2006-11-17 22:40 ` [PATCH 5/20] x86_64: Fix early printk to use standard ISA mapping Vivek Goyal
2006-11-17 22:41 ` [PATCH 6/20] x86_64: Modify copy bootdata to use virtual addresses Vivek Goyal
2006-11-17 22:42 ` [PATCH 7/20] x86_64: cleanup segments Vivek Goyal
2006-11-17 22:44 ` [PATCH 8/20] x86_64: Add EFER to the set registers saved by save_processor_state Vivek Goyal
2006-11-18 0:11 ` Pavel Machek
2006-11-17 22:45 ` [PATCH 9/20] x86_64: 64bit PIC SMP trampoline Vivek Goyal
2006-11-18 0:27 ` Pavel Machek
2006-11-18 0:33 ` Vivek Goyal
2006-11-18 0:38 ` Pavel Machek
2006-11-17 22:47 ` Vivek Goyal [this message]
2006-11-18 0:14 ` [PATCH 10/20] x86_64: wakeup.S Remove dead code Pavel Machek
2006-11-17 22:48 ` [PATCH 11/20] x86_64: wakeup.S Rename labels to reflect right register names Vivek Goyal
2006-11-18 0:15 ` Pavel Machek
2006-11-17 22:49 ` [PATCH 12/20] x86_64: wakeup.S Misc cleanup Vivek Goyal
2006-11-18 0:19 ` Pavel Machek
2006-11-18 1:25 ` Vivek Goyal
2006-11-17 22:51 ` [PATCH 13/20] x86_64: 64bit PIC ACPI wakeup trampoline Vivek Goyal
2006-11-18 0:20 ` Pavel Machek
2006-11-17 22:52 ` [PATCH 14/20] x86_64: Modify discover_ebda to use virtual address Vivek Goyal
2006-11-17 22:54 ` [PATCH 15/20] x86_64: Remove the identity mapping as early as possible Vivek Goyal
2006-11-17 22:55 ` [PATCH 16/20] x86_64: __pa and __pa_symbol address space separation Vivek Goyal
2006-11-17 22:56 ` [PATCH 17/20] x86_64: Remove CONFIG_PHYSICAL_START Vivek Goyal
2006-11-18 1:14 ` Magnus Damm
2006-11-18 2:45 ` Vivek Goyal
2006-11-20 10:02 ` Magnus Damm
2006-11-17 22:57 ` [PATCH 18/20] x86_64: Relocatable kernel support Vivek Goyal
2006-11-18 5:49 ` Oleg Verych
2006-11-18 6:49 ` Andi Kleen
2006-11-17 22:58 ` [PATCH 19/20] x86_64: Extend bzImage protocol for relocatable kernel Vivek Goyal
2006-11-18 0:30 ` H. Peter Anvin
2006-11-18 0:37 ` Vivek Goyal
2006-11-18 0:45 ` H. Peter Anvin
2006-11-18 1:47 ` Vivek Goyal
2006-11-17 22:59 ` [PATCH 20/20] x86_64: Move CPU verification code to common file Vivek Goyal
2006-11-18 5:21 ` Oleg Verych
2006-11-18 6:38 ` Andi Kleen
2006-11-18 6:41 ` H. Peter Anvin
[not found] ` <20061118070101.GA14673@flower.upol.cz>
2006-11-18 6:59 ` H. Peter Anvin
2006-11-18 7:22 ` Oleg Verych
2006-11-18 7:32 ` H. Peter Anvin
2006-11-18 8:10 ` reboot, not loop forever (Re: [PATCH 20/20] x86_64: Move CPU verification code to common file) Oleg Verych
2006-11-18 8:06 ` [PATCH 20/20] x86_64: Move CPU verification code to common file Andi Kleen
2006-11-18 8:16 ` H. Peter Anvin
2006-11-18 8:29 ` Andi Kleen
2006-11-18 10:55 ` Paul Mackerras
2006-11-18 10:58 ` Andi Kleen
2006-11-18 12:59 ` Vivek Goyal
2006-11-18 17:46 ` Pavel Machek
2006-11-18 8:52 ` [RFC][PATCH 0/20] x86_64: Relocatable bzImage (V3) Andi Kleen
2006-11-18 13:14 ` Vivek Goyal
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20061117224702.GK15449@in.ibm.com \
--to=vgoyal@in.ibm.com \
--cc=ak@suse.de \
--cc=akpm@osdl.org \
--cc=dzickus@redhat.com \
--cc=ebiederm@xmission.com \
--cc=fastboot@lists.osdl.org \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lwang@redhat.com \
--cc=magnus.damm@gmail.com \
--cc=pavel@suse.cz \
--cc=rjw@sisk.pl \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome