From: Pavel Machek <pavel@ucw.cz>
To: Vivek Goyal <vgoyal@in.ibm.com>
Cc: linux kernel mailing list <linux-kernel@vger.kernel.org>,
Reloc Kernel List <fastboot@lists.osdl.org>,
ebiederm@xmission.com, akpm@osdl.org, ak@suse.de, hpa@zytor.com,
magnus.damm@gmail.com, lwang@redhat.com, dzickus@redhat.com,
rjw@sisk.pl
Subject: Re: [PATCH 11/20] x86_64: wakeup.S Rename labels to reflect right register names
Date: Sat, 18 Nov 2006 01:15:07 +0100 [thread overview]
Message-ID: <20061118001507.GC9188@elf.ucw.cz> (raw)
In-Reply-To: <20061117224822.GL15449@in.ibm.com>
On Fri 2006-11-17 17:48:22, Vivek Goyal wrote:
>
>
> o Use appropriate names for 64bit regsiters.
>
> Signed-off-by: Eric W. Biederman <ebiederm@xmission.com>
> Signed-off-by: Vivek Goyal <vgoyal@in.ibm.com>
ACK.
> --- linux-2.6.19-rc6-reloc/arch/x86_64/kernel/acpi/wakeup.S~x86_64-wakeup.S-rename-registers-to-reflect-right-names 2006-11-17 00:09:29.000000000 -0500
> +++ linux-2.6.19-rc6-reloc-root/arch/x86_64/kernel/acpi/wakeup.S 2006-11-17 00:09:29.000000000 -0500
> @@ -211,16 +211,16 @@ wakeup_long64:
> movw %ax, %es
> movw %ax, %fs
> movw %ax, %gs
> - movq saved_esp, %rsp
> + movq saved_rsp, %rsp
>
> movw $0x0e00 + 'x', %ds:(0xb8018)
> - movq saved_ebx, %rbx
> - movq saved_edi, %rdi
> - movq saved_esi, %rsi
> - movq saved_ebp, %rbp
> + movq saved_rbx, %rbx
> + movq saved_rdi, %rdi
> + movq saved_rsi, %rsi
> + movq saved_rbp, %rbp
>
> movw $0x0e00 + '!', %ds:(0xb801a)
> - movq saved_eip, %rax
> + movq saved_rip, %rax
> jmp *%rax
>
> .code32
> @@ -408,13 +408,13 @@ do_suspend_lowlevel:
> movq %r15, saved_context_r15(%rip)
> pushfq ; popq saved_context_eflags(%rip)
>
> - movq $.L97, saved_eip(%rip)
> + movq $.L97, saved_rip(%rip)
>
> - movq %rsp,saved_esp
> - movq %rbp,saved_ebp
> - movq %rbx,saved_ebx
> - movq %rdi,saved_edi
> - movq %rsi,saved_esi
> + movq %rsp,saved_rsp
> + movq %rbp,saved_rbp
> + movq %rbx,saved_rbx
> + movq %rdi,saved_rdi
> + movq %rsi,saved_rsi
>
> addq $8, %rsp
> movl $3, %edi
> @@ -461,12 +461,12 @@ do_suspend_lowlevel:
>
> .data
> ALIGN
> -ENTRY(saved_ebp) .quad 0
> -ENTRY(saved_esi) .quad 0
> -ENTRY(saved_edi) .quad 0
> -ENTRY(saved_ebx) .quad 0
> +ENTRY(saved_rbp) .quad 0
> +ENTRY(saved_rsi) .quad 0
> +ENTRY(saved_rdi) .quad 0
> +ENTRY(saved_rbx) .quad 0
>
> -ENTRY(saved_eip) .quad 0
> -ENTRY(saved_esp) .quad 0
> +ENTRY(saved_rip) .quad 0
> +ENTRY(saved_rsp) .quad 0
>
> ENTRY(saved_magic) .quad 0
> diff -puN include/asm-x86_64/suspend.h~x86_64-wakeup.S-rename-registers-to-reflect-right-names include/asm-x86_64/suspend.h
> --- linux-2.6.19-rc6-reloc/include/asm-x86_64/suspend.h~x86_64-wakeup.S-rename-registers-to-reflect-right-names 2006-11-17 00:09:29.000000000 -0500
> +++ linux-2.6.19-rc6-reloc-root/include/asm-x86_64/suspend.h 2006-11-17 00:09:29.000000000 -0500
> @@ -45,12 +45,12 @@ extern unsigned long saved_context_eflag
> extern void fix_processor_context(void);
>
> #ifdef CONFIG_ACPI_SLEEP
> -extern unsigned long saved_eip;
> -extern unsigned long saved_esp;
> -extern unsigned long saved_ebp;
> -extern unsigned long saved_ebx;
> -extern unsigned long saved_esi;
> -extern unsigned long saved_edi;
> +extern unsigned long saved_rip;
> +extern unsigned long saved_rsp;
> +extern unsigned long saved_rbp;
> +extern unsigned long saved_rbx;
> +extern unsigned long saved_rsi;
> +extern unsigned long saved_rdi;
>
> /* routines for saving/restoring kernel state */
> extern int acpi_save_state_mem(void);
> _
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
next prev parent reply other threads:[~2006-11-18 0:15 UTC|newest]
Thread overview: 57+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-11-17 22:34 [RFC][PATCH 0/20] x86_64: Relocatable bzImage (V3) Vivek Goyal
2006-11-17 22:36 ` [PATCH 1/20] x86_64: Align data segment to PAGE_SIZE boundary Vivek Goyal
2006-11-17 22:37 ` [PATCH 2/20] x86_64: Assembly safe page.h and pgtable.h Vivek Goyal
2006-11-18 8:49 ` Andi Kleen
2006-11-18 13:19 ` Vivek Goyal
2006-11-17 22:38 ` [PATCH 3/20] x86_64: Kill temp_boot_pmds Vivek Goyal
2006-11-17 22:39 ` [PATCH 4/20] x86_64: Cleanup the early boot page table Vivek Goyal
2006-11-17 22:40 ` [PATCH 5/20] x86_64: Fix early printk to use standard ISA mapping Vivek Goyal
2006-11-17 22:41 ` [PATCH 6/20] x86_64: Modify copy bootdata to use virtual addresses Vivek Goyal
2006-11-17 22:42 ` [PATCH 7/20] x86_64: cleanup segments Vivek Goyal
2006-11-17 22:44 ` [PATCH 8/20] x86_64: Add EFER to the set registers saved by save_processor_state Vivek Goyal
2006-11-18 0:11 ` Pavel Machek
2006-11-17 22:45 ` [PATCH 9/20] x86_64: 64bit PIC SMP trampoline Vivek Goyal
2006-11-18 0:27 ` Pavel Machek
2006-11-18 0:33 ` Vivek Goyal
2006-11-18 0:38 ` Pavel Machek
2006-11-17 22:47 ` [PATCH 10/20] x86_64: wakeup.S Remove dead code Vivek Goyal
2006-11-18 0:14 ` Pavel Machek
2006-11-17 22:48 ` [PATCH 11/20] x86_64: wakeup.S Rename labels to reflect right register names Vivek Goyal
2006-11-18 0:15 ` Pavel Machek [this message]
2006-11-17 22:49 ` [PATCH 12/20] x86_64: wakeup.S Misc cleanup Vivek Goyal
2006-11-18 0:19 ` Pavel Machek
2006-11-18 1:25 ` Vivek Goyal
2006-11-17 22:51 ` [PATCH 13/20] x86_64: 64bit PIC ACPI wakeup trampoline Vivek Goyal
2006-11-18 0:20 ` Pavel Machek
2006-11-17 22:52 ` [PATCH 14/20] x86_64: Modify discover_ebda to use virtual address Vivek Goyal
2006-11-17 22:54 ` [PATCH 15/20] x86_64: Remove the identity mapping as early as possible Vivek Goyal
2006-11-17 22:55 ` [PATCH 16/20] x86_64: __pa and __pa_symbol address space separation Vivek Goyal
2006-11-17 22:56 ` [PATCH 17/20] x86_64: Remove CONFIG_PHYSICAL_START Vivek Goyal
2006-11-18 1:14 ` Magnus Damm
2006-11-18 2:45 ` Vivek Goyal
2006-11-20 10:02 ` Magnus Damm
2006-11-17 22:57 ` [PATCH 18/20] x86_64: Relocatable kernel support Vivek Goyal
2006-11-18 5:49 ` Oleg Verych
2006-11-18 6:49 ` Andi Kleen
2006-11-17 22:58 ` [PATCH 19/20] x86_64: Extend bzImage protocol for relocatable kernel Vivek Goyal
2006-11-18 0:30 ` H. Peter Anvin
2006-11-18 0:37 ` Vivek Goyal
2006-11-18 0:45 ` H. Peter Anvin
2006-11-18 1:47 ` Vivek Goyal
2006-11-17 22:59 ` [PATCH 20/20] x86_64: Move CPU verification code to common file Vivek Goyal
2006-11-18 5:21 ` Oleg Verych
2006-11-18 6:38 ` Andi Kleen
2006-11-18 6:41 ` H. Peter Anvin
[not found] ` <20061118070101.GA14673@flower.upol.cz>
2006-11-18 6:59 ` H. Peter Anvin
2006-11-18 7:22 ` Oleg Verych
2006-11-18 7:32 ` H. Peter Anvin
2006-11-18 8:10 ` reboot, not loop forever (Re: [PATCH 20/20] x86_64: Move CPU verification code to common file) Oleg Verych
2006-11-18 8:06 ` [PATCH 20/20] x86_64: Move CPU verification code to common file Andi Kleen
2006-11-18 8:16 ` H. Peter Anvin
2006-11-18 8:29 ` Andi Kleen
2006-11-18 10:55 ` Paul Mackerras
2006-11-18 10:58 ` Andi Kleen
2006-11-18 12:59 ` Vivek Goyal
2006-11-18 17:46 ` Pavel Machek
2006-11-18 8:52 ` [RFC][PATCH 0/20] x86_64: Relocatable bzImage (V3) Andi Kleen
2006-11-18 13:14 ` Vivek Goyal
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20061118001507.GC9188@elf.ucw.cz \
--to=pavel@ucw.cz \
--cc=ak@suse.de \
--cc=akpm@osdl.org \
--cc=dzickus@redhat.com \
--cc=ebiederm@xmission.com \
--cc=fastboot@lists.osdl.org \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lwang@redhat.com \
--cc=magnus.damm@gmail.com \
--cc=rjw@sisk.pl \
--cc=vgoyal@in.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome