mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Pavel Machek <pavel@ucw.cz>
To: Vivek Goyal <vgoyal@in.ibm.com>
Cc: linux kernel mailing list <linux-kernel@vger.kernel.org>,
	Reloc Kernel List <fastboot@lists.osdl.org>,
	ebiederm@xmission.com, akpm@osdl.org, ak@suse.de, hpa@zytor.com,
	magnus.damm@gmail.com, lwang@redhat.com, dzickus@redhat.com,
	rjw@sisk.pl
Subject: Re: [PATCH 12/20] x86_64: wakeup.S Misc cleanup
Date: Sat, 18 Nov 2006 01:19:07 +0100	[thread overview]
Message-ID: <20061118001907.GD9188@elf.ucw.cz> (raw)
In-Reply-To: <20061117224940.GM15449@in.ibm.com>

Hi!

> o Various cleanups. One of the main purpose of cleanups is that make
>   wakeup.S as close as possible to trampoline.S.
> 
> o Following are the changes
> 	- Indentations for comments.
> 	- Changed the gdt table to compact form and to resemble the
> 	  one in trampoline.S
> 	- Take the jump to 32bit from real mode using ljmpl. Makes code
> 	  more readable.
> 	- After enabling long mode, directly take a long jump for 64bit
> 	  mode. No need to take an extra jump to "reach_comaptibility_mode"
> 	- Stack is not used after real mode. So don't load stack in
>  	  32 bit mode.
> 	- No need to enable PGE here.
> 	- No need to do extra EFER read, anyway we trash the read contents.
> 	- No need to enable system call (EFER_SCE). Anyway it will be 
> 	  enabled when original EFER is restored.
> 	- No need to set MP, ET, NE, WP, AM bits in cr0. Very soon we will
>   	  reload the original cr0 while restroing the processor state.
> 
> Signed-off-by: Eric W. Biederman <ebiederm@xmission.com>
> Signed-off-by: Vivek Goyal <vgoyal@in.ibm.com>

ACK, minor nitpicks:

> +	/* ??? Why I need the accessed bit set in order for this to work? */

Yes, I'd like to know :-).

> +	.quad   0x00cf9b000000ffff              # __KERNEL32_CS
> +	.quad   0x00af9b000000ffff              # __KERNEL_CS
> +	.quad   0x00cf93000000ffff              # __KERNEL_DS

Can we get a comment telling us what to keep it in sync with?

									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

  reply	other threads:[~2006-11-18  0:19 UTC|newest]

Thread overview: 57+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-11-17 22:34 [RFC][PATCH 0/20] x86_64: Relocatable bzImage (V3) Vivek Goyal
2006-11-17 22:36 ` [PATCH 1/20] x86_64: Align data segment to PAGE_SIZE boundary Vivek Goyal
2006-11-17 22:37 ` [PATCH 2/20] x86_64: Assembly safe page.h and pgtable.h Vivek Goyal
2006-11-18  8:49   ` Andi Kleen
2006-11-18 13:19     ` Vivek Goyal
2006-11-17 22:38 ` [PATCH 3/20] x86_64: Kill temp_boot_pmds Vivek Goyal
2006-11-17 22:39 ` [PATCH 4/20] x86_64: Cleanup the early boot page table Vivek Goyal
2006-11-17 22:40 ` [PATCH 5/20] x86_64: Fix early printk to use standard ISA mapping Vivek Goyal
2006-11-17 22:41 ` [PATCH 6/20] x86_64: Modify copy bootdata to use virtual addresses Vivek Goyal
2006-11-17 22:42 ` [PATCH 7/20] x86_64: cleanup segments Vivek Goyal
2006-11-17 22:44 ` [PATCH 8/20] x86_64: Add EFER to the set registers saved by save_processor_state Vivek Goyal
2006-11-18  0:11   ` Pavel Machek
2006-11-17 22:45 ` [PATCH 9/20] x86_64: 64bit PIC SMP trampoline Vivek Goyal
2006-11-18  0:27   ` Pavel Machek
2006-11-18  0:33     ` Vivek Goyal
2006-11-18  0:38       ` Pavel Machek
2006-11-17 22:47 ` [PATCH 10/20] x86_64: wakeup.S Remove dead code Vivek Goyal
2006-11-18  0:14   ` Pavel Machek
2006-11-17 22:48 ` [PATCH 11/20] x86_64: wakeup.S Rename labels to reflect right register names Vivek Goyal
2006-11-18  0:15   ` Pavel Machek
2006-11-17 22:49 ` [PATCH 12/20] x86_64: wakeup.S Misc cleanup Vivek Goyal
2006-11-18  0:19   ` Pavel Machek [this message]
2006-11-18  1:25     ` Vivek Goyal
2006-11-17 22:51 ` [PATCH 13/20] x86_64: 64bit PIC ACPI wakeup trampoline Vivek Goyal
2006-11-18  0:20   ` Pavel Machek
2006-11-17 22:52 ` [PATCH 14/20] x86_64: Modify discover_ebda to use virtual address Vivek Goyal
2006-11-17 22:54 ` [PATCH 15/20] x86_64: Remove the identity mapping as early as possible Vivek Goyal
2006-11-17 22:55 ` [PATCH 16/20] x86_64: __pa and __pa_symbol address space separation Vivek Goyal
2006-11-17 22:56 ` [PATCH 17/20] x86_64: Remove CONFIG_PHYSICAL_START Vivek Goyal
2006-11-18  1:14   ` Magnus Damm
2006-11-18  2:45     ` Vivek Goyal
2006-11-20 10:02       ` Magnus Damm
2006-11-17 22:57 ` [PATCH 18/20] x86_64: Relocatable kernel support Vivek Goyal
2006-11-18  5:49   ` Oleg Verych
2006-11-18  6:49     ` Andi Kleen
2006-11-17 22:58 ` [PATCH 19/20] x86_64: Extend bzImage protocol for relocatable kernel Vivek Goyal
2006-11-18  0:30   ` H. Peter Anvin
2006-11-18  0:37     ` Vivek Goyal
2006-11-18  0:45       ` H. Peter Anvin
2006-11-18  1:47         ` Vivek Goyal
2006-11-17 22:59 ` [PATCH 20/20] x86_64: Move CPU verification code to common file Vivek Goyal
2006-11-18  5:21   ` Oleg Verych
2006-11-18  6:38     ` Andi Kleen
2006-11-18  6:41       ` H. Peter Anvin
     [not found]       ` <20061118070101.GA14673@flower.upol.cz>
2006-11-18  6:59         ` H. Peter Anvin
2006-11-18  7:22           ` Oleg Verych
2006-11-18  7:32             ` H. Peter Anvin
2006-11-18  8:10               ` reboot, not loop forever (Re: [PATCH 20/20] x86_64: Move CPU verification code to common file) Oleg Verych
2006-11-18  8:06           ` [PATCH 20/20] x86_64: Move CPU verification code to common file Andi Kleen
2006-11-18  8:16             ` H. Peter Anvin
2006-11-18  8:29   ` Andi Kleen
2006-11-18 10:55     ` Paul Mackerras
2006-11-18 10:58       ` Andi Kleen
2006-11-18 12:59         ` Vivek Goyal
2006-11-18 17:46           ` Pavel Machek
2006-11-18  8:52 ` [RFC][PATCH 0/20] x86_64: Relocatable bzImage (V3) Andi Kleen
2006-11-18 13:14   ` Vivek Goyal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20061118001907.GD9188@elf.ucw.cz \
    --to=pavel@ucw.cz \
    --cc=ak@suse.de \
    --cc=akpm@osdl.org \
    --cc=dzickus@redhat.com \
    --cc=ebiederm@xmission.com \
    --cc=fastboot@lists.osdl.org \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lwang@redhat.com \
    --cc=magnus.damm@gmail.com \
    --cc=rjw@sisk.pl \
    --cc=vgoyal@in.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome