* [PATCH 04/68] 0 -> NULL, for arch/blackfin
@ 2007-07-27 9:44 Yoann Padioleau
2007-07-27 10:23 ` Bryan Wu
0 siblings, 1 reply; 3+ messages in thread
From: Yoann Padioleau @ 2007-07-27 9:44 UTC (permalink / raw)
To: kernel-janitors; +Cc: aubrey.li, bryan.wu, akpm, linux-kernel
When comparing a pointer, it's clearer to compare it to NULL than to 0.
Here is an excerpt of the semantic patch:
@@
expression *E;
@@
E ==
- 0
+ NULL
@@
expression *E;
@@
E !=
- 0
+ NULL
Signed-off-by: Yoann Padioleau <padator@wanadoo.fr>
Cc: aubrey.li@analog.com
Cc: bryan.wu@analog.com
Cc: akpm@linux-foundation.org
---
traps.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/blackfin/kernel/traps.c b/arch/blackfin/kernel/traps.c
index 3909f5b..691c66d 100644
--- a/arch/blackfin/kernel/traps.c
+++ b/arch/blackfin/kernel/traps.c
@@ -546,7 +546,7 @@ void dump_bfin_regs(struct pt_regs *fp,
}
printk(KERN_EMERG "return address: [0x%p]; contents of:", retaddr);
- if (retaddr != 0 && retaddr <= (void *)physical_mem_end
+ if (retaddr != NULL && retaddr <= (void *)physical_mem_end
#if L1_CODE_LENGTH != 0
/* FIXME: Copy the code out of L1 Instruction SRAM through dma
memcpy. */
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 04/68] 0 -> NULL, for arch/blackfin
2007-07-27 9:44 [PATCH 04/68] 0 -> NULL, for arch/blackfin Yoann Padioleau
@ 2007-07-27 10:23 ` Bryan Wu
2007-07-27 13:17 ` Uli Luckas
0 siblings, 1 reply; 3+ messages in thread
From: Bryan Wu @ 2007-07-27 10:23 UTC (permalink / raw)
To: Yoann Padioleau; +Cc: kernel-janitors, aubrey.li, bryan.wu, akpm, linux-kernel
On Fri, 2007-07-27 at 11:44 +0200, Yoann Padioleau wrote:
> When comparing a pointer, it's clearer to compare it to NULL than to 0.
>
> Here is an excerpt of the semantic patch:
>
> @@
> expression *E;
> @@
>
> E ==
> - 0
> + NULL
>
> @@
> expression *E;
> @@
>
> E !=
> - 0
> + NULL
>
> Signed-off-by: Yoann Padioleau <padator@wanadoo.fr>
> Cc: aubrey.li@analog.com
> Cc: bryan.wu@analog.com
> Cc: akpm@linux-foundation.org
> ---
>
> traps.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/blackfin/kernel/traps.c b/arch/blackfin/kernel/traps.c
> index 3909f5b..691c66d 100644
> --- a/arch/blackfin/kernel/traps.c
> +++ b/arch/blackfin/kernel/traps.c
> @@ -546,7 +546,7 @@ void dump_bfin_regs(struct pt_regs *fp,
> }
>
> printk(KERN_EMERG "return address: [0x%p]; contents of:", retaddr);
> - if (retaddr != 0 && retaddr <= (void *)physical_mem_end
> + if (retaddr != NULL && retaddr <= (void *)physical_mem_end
> #if L1_CODE_LENGTH != 0
> /* FIXME: Copy the code out of L1 Instruction SRAM through dma
> memcpy. */
Why not just use " if (!E)" instead of " if (E != NULL)"?
more readable?
Thanks
- Bryan Wu
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 04/68] 0 -> NULL, for arch/blackfin
2007-07-27 10:23 ` Bryan Wu
@ 2007-07-27 13:17 ` Uli Luckas
0 siblings, 0 replies; 3+ messages in thread
From: Uli Luckas @ 2007-07-27 13:17 UTC (permalink / raw)
To: LKML, bryan.wu; +Cc: Yoann Padioleau, kernel-janitors, aubrey.li, akpm
On Friday, 27. July 2007, Bryan Wu wrote:
> On Fri, 2007-07-27 at 11:44 +0200, Yoann Padioleau wrote:
> > When comparing a pointer, it's clearer to compare it to NULL than to 0.
> >
> > Here is an excerpt of the semantic patch:
> >
> > @@
> > expression *E;
> > @@
> >
> > E ==
> > - 0
> > + NULL
> >
> > @@
> > expression *E;
> > @@
> >
> > E !=
> > - 0
> > + NULL
> >
> > Signed-off-by: Yoann Padioleau <padator@wanadoo.fr>
> > Cc: aubrey.li@analog.com
> > Cc: bryan.wu@analog.com
> > Cc: akpm@linux-foundation.org
> > ---
> >
> > traps.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/arch/blackfin/kernel/traps.c b/arch/blackfin/kernel/traps.c
> > index 3909f5b..691c66d 100644
> > --- a/arch/blackfin/kernel/traps.c
> > +++ b/arch/blackfin/kernel/traps.c
> > @@ -546,7 +546,7 @@ void dump_bfin_regs(struct pt_regs *fp,
> > }
> >
> > printk(KERN_EMERG "return address: [0x%p]; contents of:", retaddr);
> > - if (retaddr != 0 && retaddr <= (void *)physical_mem_end
> > + if (retaddr != NULL && retaddr <= (void *)physical_mem_end
> > #if L1_CODE_LENGTH != 0
> > /* FIXME: Copy the code out of L1 Instruction SRAM through dma
> > memcpy. */
>
> Why not just use " if (!E)" instead of " if (E != NULL)"?
> more readable?
>
Or even "if (E)"
Uli
--
------- ROAD ...the handyPC Company - - - ) ) )
Uli Luckas
Software Development
ROAD GmbH
Bennigsenstr. 14 | 12159 Berlin | Germany
fon: +49 (30) 230069 - 64 | fax: +49 (30) 230069 - 69
url: www.road.de
Amtsgericht Charlottenburg: HRB 96688 B
Managing directors: Hans-Peter Constien, Hubertus von Streit
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2007-07-27 13:18 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-07-27 9:44 [PATCH 04/68] 0 -> NULL, for arch/blackfin Yoann Padioleau
2007-07-27 10:23 ` Bryan Wu
2007-07-27 13:17 ` Uli Luckas
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®