From: "Darrick J. Wong" <djwong@us.ibm.com>
To: Jean Delvare <khali@linux-fr.org>
Cc: "Mark M. Hoffman" <mhoffman@lightlink.com>,
Henrique de Moraes Holschuh <hmh@hmh.eng.br>,
linux-kernel@vger.kernel.org, lm-sensors@lm-sensors.org,
haveblue@us.ibm.com
Subject: Re: [PATCH v2] hwmon: Update Documentation/hwmon/sysfs-interface
Date: Mon, 17 Sep 2007 11:43:11 -0700 [thread overview]
Message-ID: <20070917184310.GN30825@tree.beaverton.ibm.com> (raw)
In-Reply-To: <20070917192808.44ad60cc@hyperion.delvare>
[-- Attachment #1: Type: text/plain, Size: 2204 bytes --]
On Mon, Sep 17, 2007 at 07:28:08PM +0200, Jean Delvare wrote:
> Thanks for the update. I have some more comments. And sorry if it looks
> like nitpicking, but this is a standard interface we're defining so we
> better make sure that we get it right.
Agreed. :)
>
> First of all, please think of a better subject line for this patch.
> "Update Documentation/hwmon/sysfs-interface" is too vague when your
> patch is rather specific.
Will change to:
"Add power meter spec to Documentation/hwmon/sysfs-interface"
> > +power[1-*]_average_lowest Historical average minimum power use
> > + Unit: microWatt
> > + RO
>
> How useful are historical extremes of an average?
I don't know if anybody ever really requires this data, but the device
I'm talking to records the extremes in hardware, so I put it in the driver.
> > +power[1-*]_high_low_reset Reset input_highest/input_lowest.
> > + WO
>
> I don't much like this name. It sounds like a name crafted for the
> specific feature of a given chip, while we try to use generic names for
Guilty as charged. Since ibmpex is the only on-board power meter hardware
to which I have access, the interface proposal includes the various odd
pieces that the hardware provides in addition to the meters. I
could take the historical extreme and reset bits out of the proposal and
put them in something like Documentation/hwmon/ibmpex.txt as extra
chip-specific features if people prefer that.
> the standard interface. I would rather go for power[1-*]_reset_history
Me too.
> if we have a single file for resetting all the extremes of a given
> channel, or power[1-*]_input_lowest_reset and
> power[1-*]_input_highest_reset if we go for a per-value reset.
The ibmpex hardware only knows how to reset all of them.
> Alternatively, we could simply make the power[1-*]_input_lowest and
> power[1-*]_input_highest files writable, and "cat power1_input >
> power1_input_lowest" (or any write?) would reset the history.
I'd prefer to leave it explicitly called out as a separate sysfs knob,
unless there are established precedents for resetting a sensor by
writing something to its sysfs file.
--D
[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 189 bytes --]
next prev parent reply other threads:[~2007-09-17 18:44 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-08-27 21:14 [PATCH] v1 of IBM power meter driver Darrick J. Wong
2007-08-28 1:50 ` Henrique de Moraes Holschuh
2007-08-28 11:19 ` [lm-sensors] " Jean Delvare
2007-08-28 16:28 ` Darrick J. Wong
2007-08-29 9:49 ` Jean Delvare
2007-08-29 12:45 ` Frank Phillips
2007-08-28 16:44 ` [PATCH] hwmon: Add power meters to Documentation/hwmon/sysfs-interface Darrick J. Wong
2007-08-29 9:10 ` Jean Delvare
2007-08-29 14:50 ` Darrick J. Wong
2007-08-30 9:57 ` Jean Delvare
2007-09-11 16:43 ` Darrick J. Wong
2007-09-01 17:10 ` Pavel Machek
2007-09-01 18:05 ` Shem Multinymous
2007-09-01 19:44 ` [lm-sensors] " Henrique de Moraes Holschuh
2007-09-02 19:38 ` Jean Delvare
2007-09-03 2:02 ` Henrique de Moraes Holschuh
2007-09-03 16:06 ` Jean Delvare
2007-09-03 23:22 ` Henrique de Moraes Holschuh
2007-09-06 9:34 ` Jean Delvare
2007-09-06 16:29 ` Henrique de Moraes Holschuh
2007-08-28 16:49 ` [PATCH] v2 of IBM power meter driver Darrick J. Wong
2007-08-28 23:25 ` [PATCH] v3 " Darrick J. Wong
2007-09-11 13:23 ` Mark M. Hoffman
2007-09-11 13:59 ` Jean Delvare
2007-09-12 1:11 ` Darrick J. Wong
2007-09-14 19:29 ` [PATCH v2] hwmon: Update Documentation/hwmon/sysfs-interface Darrick J. Wong
2007-09-17 17:28 ` Jean Delvare
2007-09-17 18:43 ` Darrick J. Wong [this message]
2007-09-21 8:43 ` Jean Delvare
2007-09-14 19:33 ` [PATCH v4] IBM power meter driver Darrick J. Wong
2007-10-09 12:00 ` Mark M. Hoffman
2007-10-09 16:44 ` Roel Kluin
2007-10-09 20:40 ` Darrick J. Wong
2007-10-09 22:08 ` [PATCH] ibmpex: Release IPMI user if hwmon registration fails Darrick J. Wong
2007-10-11 11:45 ` Mark M. Hoffman
2007-10-13 0:29 ` [PATCH v4] IBM power meter driver Darrick J. Wong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070917184310.GN30825@tree.beaverton.ibm.com \
--to=djwong@us.ibm.com \
--cc=haveblue@us.ibm.com \
--cc=hmh@hmh.eng.br \
--cc=khali@linux-fr.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lm-sensors@lm-sensors.org \
--cc=mhoffman@lightlink.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®