mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Paul Jackson <pj@sgi.com>
To: Mike Travis <travis@sgi.com>
Cc: mingo@elte.hu, bert.wesarg@googlemail.com, tglx@linutronix.de,
	hpa@zytor.com, akpm@linux-foundation.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/3] x86: modify show_shared_cpu_map in intel_cacheinfo v3
Date: Thu, 10 Apr 2008 08:57:40 -0500	[thread overview]
Message-ID: <20080410085740.a7e08672.pj@sgi.com> (raw)
In-Reply-To: <20080408184301.842103000@polaris-admin.engr.sgi.com>

Mike wrote:
+		n = type?
+			cpulist_scnprintf(buf, len-2, *mask):
+			cpumask_scnprintf(buf, len-2, *mask);

I suspect most of us would find the following variant easier to read:

		if (type)
			n = cpulist_scnprintf(buf, len - 2, *mask);
		else
			n = cpumask_scnprintf(buf, len - 2, *mask);


Then, going further, the rather too vague "type" parameter name,
without comment and taking just bare constant values 0 or 1, seems
more opaque than necessary.

I can imagine this being easier to read as something like:


typedef enum { print_as_mask, print_as_list } map_printer_t;

static ssize_t show_shared_cpu_map_func(struct _cpuid4_info *this_leaf,
				       map_printer_t mpt, char *buf)
{
       ptrdiff_t len = PTR_ALIGN(buf + PAGE_SIZE - 1, PAGE_SIZE) - buf;
       int n = 0;

       if (len > 1) {
		cpumask_t *mask = &this_leaf->shared_cpu_map;

		if (mpt == print_as_mask)
			n = cpumask_scnprintf(buf, len - 2, *mask);
		else
			n = cpulist_scnprintf(buf, len - 2, *mask);
		buf[n++] = '\n';
		buf[n] = '\0';
       }
       return n;
}

static inline ssize_t show_shared_cpu_map(struct _cpuid4_info *leaf, char *buf)
{
       return show_shared_cpu_map_func(leaf, print_as_mask, buf);
}

static inline ssize_t show_shared_cpu_list(struct _cpuid4_info *leaf, char *buf)
{
       return show_shared_cpu_map_func(leaf, print_as_list, buf);
}



-- 
                  I won't rest till it's the best ...
                  Programmer, Linux Scalability
                  Paul Jackson <pj@sgi.com> 1.940.382.4214

  parent reply	other threads:[~2008-04-10 13:57 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-04-08 18:43 [PATCH 0/3] x86: add cpus_scnprintf function v3 Mike Travis
2008-04-08 18:43 ` [PATCH 1/3] x86: modify show_shared_cpu_map in intel_cacheinfo v3 Mike Travis
2008-04-08 19:36   ` Bert Wesarg
2008-04-08 20:44     ` Mike Travis
2008-04-10 14:03       ` Paul Jackson
2008-04-10 17:24       ` Bert Wesarg
2008-04-10 17:36         ` Paul Jackson
2008-04-10 13:57   ` Paul Jackson [this message]
2008-04-08 18:43 ` [PATCH 2/3] cpumask: use new cpus_scnprintf function v3 Mike Travis
2008-04-08 19:40   ` Bert Wesarg
2008-04-08 20:46     ` Mike Travis
2008-04-09 15:53       ` Bert Wesarg
2008-04-10 12:49         ` Paul Jackson
2008-04-10  0:32   ` Paul Jackson
2008-04-10 12:13   ` Paul Jackson
2008-04-10 14:05   ` Paul Jackson
2008-04-08 18:43 ` [PATCH 3/3] cpumask: add show cpu map functions v2 Mike Travis
2008-04-08 19:32   ` Bert Wesarg
2008-04-08 20:52     ` Mike Travis
2008-04-09 17:39       ` Bert Wesarg
2008-04-10  0:29         ` Paul Jackson
2008-04-10  6:05           ` Bert Wesarg
2008-04-10 14:13   ` Paul Jackson
2008-04-08 19:33 ` [PATCH 0/3] x86: add cpus_scnprintf function v3 Bert Wesarg
2008-04-08 20:54   ` Mike Travis
2008-04-10 15:03     ` Paul Jackson
2008-04-09 15:11 ` Ingo Molnar
2008-04-09 17:51 ` Bert Wesarg
2008-04-09 20:39   ` Greg KH
2008-04-09 20:52     ` Bert Wesarg
2008-04-09 21:14       ` Greg KH
2008-04-09 21:21         ` Bert Wesarg
2008-04-09 20:59     ` Mike Travis
2008-04-09 21:02       ` Bert Wesarg
2008-04-09 21:15       ` Greg KH
2008-04-10  0:18       ` Paul Jackson
2008-04-10 12:10   ` Paul Jackson
2008-04-10 16:14     ` Bert Wesarg
2008-04-10 16:27       ` Paul Jackson
2008-04-10 17:30       ` Greg KH
2008-04-10 17:36         ` Bert Wesarg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080410085740.a7e08672.pj@sgi.com \
    --to=pj@sgi.com \
    --cc=akpm@linux-foundation.org \
    --cc=bert.wesarg@googlemail.com \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=tglx@linutronix.de \
    --cc=travis@sgi.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome