mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Henrique de Moraes Holschuh <hmh@hmh.eng.br>
To: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Cc: linux-kernel@vger.kernel.org, Ivo van Doorn <IvDoorn@gmail.com>,
	"John W. Linville" <linville@tuxdriver.com>
Subject: Re: [PATCH 3/8] rfkill: handle KEY_RADIO and SW_RADIO events
Date: Sat, 12 Apr 2008 15:02:19 -0300	[thread overview]
Message-ID: <20080412180219.GI3402@khazad-dum.debian.net> (raw)
In-Reply-To: <20080412154711.GA3221@anvil.corenet.prv>

On Sat, 12 Apr 2008, Dmitry Torokhov wrote:
> On Fri, Apr 11, 2008 at 05:37:19PM -0300, Henrique de Moraes Holschuh wrote:
> > The *_RADIO input events are related to all radios in a system.  There are
> > two: KEY_RADIO and SW_RADIO.
> > 
> 
> KEY_RADIO is reserved for selecting radio input (as pooosed to TV, AUX,
> etc) with a remote control. Rfkill woudl need a separate keycode if it
> needs "all types of radios" event.

Hmm, let me check where I got the wrong idea of using KEY_RADIO from,
because thinkpad-acpi already uses KEY_WLAN which means that at least in
the past I did know KEY_RADIO was not to be used for wireless data
communication devices like that...  jeez, looks like spontaneous brain
corruption on that topic hapenned to me sometime ago, and it came out in
a linux-thinkpad thread a few weeks ago.  The wrong semanthics for
KEY_RADIO seem to have stuck to my mind since then.  Drat, I *really*
apologise for this one.

This, of course, is a major NAK for this patch.  And I am considering
dropping the handling of KEY_<whatever replaces RADIO> completely from
it.  SW_RADIO (after a rename, see below) still needs to be handled,
though.

> Btw, is there any devices in the wild that actually have separate
> switches for different types of transmitters?

Separate switches?  I know of none.

Separate hot keys/buttons?  I haven't seen it, but check commit
90da11514562020ea7d697982f912ac949adc317's comment.  That was the commit
which added KEY_WLAN and KEY_BLUETOOTH, back in 2.6.18-rc.  Maybe ask
Lennart Poettering about it?

What I have seen in laptops is:

"Wireless Switch" (SW_RADIO -- this one has a bad name, might even be
what caused me to screw up with the KEY_RADIO thing, and it hints that
my brain corruption was deep rooted, since I was the one who came up
with SW_RADIO).   These switches do their plain best to remove all RF
output when in the "wireles off" position, and stop bothering RF output
when in the "wireless on" position.  Transitions from off->on are often
used as a hint to bring up wireless data communication services (such as
firing up wirelesss settings GUI pannels, etc).

"Wireless hot-key", which either brings up an GUI related to which
wireless data communication radios are active and their configuration,
or directly changes the set of active wireless data communication
radios.

One could easily argue that, should we make it possible for userspace to
interact with the global rfkill state for each rfkill switch type, all
handling of the "Wireless hot-key" should be done in userspace.  I will
go with that for now, and think about it some more.

New patches coming soon.  Please don't merge ANY of the patches in this
set, I will respin the entire series.

-- 
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

  reply	other threads:[~2008-04-12 18:02 UTC|newest]

Thread overview: 61+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-04-11 20:37 [GIT PATCH] rfkill support for r/w and r/o rfkill switches Henrique de Moraes Holschuh
2008-04-11 20:37 ` [PATCH 1/8] rfkill: clarify meaning of rfkill states Henrique de Moraes Holschuh
2008-04-14  4:22   ` Dmitry Torokhov
2008-04-11 20:37 ` [PATCH 2/8] rfkill: fix minor typo in kernel doc Henrique de Moraes Holschuh
2008-04-11 20:37 ` [PATCH 3/8] rfkill: handle KEY_RADIO and SW_RADIO events Henrique de Moraes Holschuh
2008-04-12 10:36   ` Ivo van Doorn
2008-04-12 12:05     ` Henrique de Moraes Holschuh
2008-04-12 12:23       ` Ivo van Doorn
2008-04-12 13:08         ` Henrique de Moraes Holschuh
2008-04-12 13:17           ` Ivo van Doorn
2008-04-12 15:47   ` Dmitry Torokhov
2008-04-12 18:02     ` Henrique de Moraes Holschuh [this message]
2008-04-12 18:14       ` Ivo van Doorn
2008-04-12 19:09         ` Carlos Corbacho
2008-04-12 20:36           ` Henrique de Moraes Holschuh
2008-04-11 20:37 ` [PATCH 4/8] rfkill: add read-write rfkill switch support Henrique de Moraes Holschuh
2008-04-12 10:36   ` Ivo van Doorn
2008-04-14  1:20     ` Henrique de Moraes Holschuh
2008-04-14 12:00       ` Ivo van Doorn
2008-04-14 14:16         ` Dmitry Torokhov
2008-04-14 14:36           ` Henrique de Moraes Holschuh
2008-04-14 15:19             ` Dmitry Torokhov
2008-04-14 16:33               ` Henrique de Moraes Holschuh
2008-04-14 18:05                 ` Dmitry Torokhov
2008-04-14 21:41                   ` Henrique de Moraes Holschuh
2008-04-14 19:06         ` Carlos Corbacho
2008-04-14 20:23           ` Dmitry Torokhov
2008-04-15  7:27             ` Carlos Corbacho
2008-04-15 12:58               ` Dmitry Torokhov
2008-04-14 21:04           ` Ivo van Doorn
2008-04-14 21:46             ` Henrique de Moraes Holschuh
2008-04-15  8:14               ` Ivo Van Doorn
2008-04-11 20:37 ` [PATCH 5/8] rfkill: add read-only " Henrique de Moraes Holschuh
2008-04-11 20:37 ` [PATCH 6/8] rfkill: add the WWAN radio type Henrique de Moraes Holschuh
2008-04-11 20:44   ` Inaky Perez-Gonzalez
2008-04-11 20:53     ` Henrique de Moraes Holschuh
2008-04-12 10:36   ` Ivo van Doorn
2008-04-12 12:15     ` Henrique de Moraes Holschuh
2008-04-12 12:28       ` Ivo van Doorn
2008-04-12 23:23       ` Inaky Perez-Gonzalez
2008-04-13 17:25         ` Henrique de Moraes Holschuh
2008-04-13 17:37           ` Ivo van Doorn
2008-04-13 18:16             ` Henrique de Moraes Holschuh
2008-04-14  4:20               ` Dmitry Torokhov
2008-04-11 20:37 ` [PATCH 7/8] rfkill: add an "any radio" switch type and functionality Henrique de Moraes Holschuh
2008-04-12 19:57   ` Pavel Machek
2008-04-13 17:40     ` Henrique de Moraes Holschuh
2008-04-11 20:37 ` [PATCH 8/8] rfkill: add parameter to disable radios by default Henrique de Moraes Holschuh
2008-04-12 10:36   ` Ivo van Doorn
2008-04-12 12:56     ` Henrique de Moraes Holschuh
2008-04-12 13:43       ` Ivo van Doorn
2008-04-12 14:43         ` Henrique de Moraes Holschuh
2008-04-12 16:24           ` Ivo van Doorn
2008-04-12 18:36             ` Henrique de Moraes Holschuh
2008-04-12 19:15               ` Ivo van Doorn
2008-04-12 10:36 ` [GIT PATCH] rfkill support for r/w and r/o rfkill switches Ivo van Doorn
2008-04-16 18:37 ` John W. Linville
2008-04-16 19:26   ` Ivo van Doorn
2008-04-16 19:58     ` John W. Linville
2008-04-16 20:40       ` Ivo van Doorn
2008-04-17  1:29         ` David Miller

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080412180219.GI3402@khazad-dum.debian.net \
    --to=hmh@hmh.eng.br \
    --cc=IvDoorn@gmail.com \
    --cc=dmitry.torokhov@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linville@tuxdriver.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome