From: Arnd Bergmann <arnd@arndb.de>
To: x86@kernel.org
Cc: linux-kernel@vger.kernel.org,
Remis Lima Baima <remis.developer@googlemail.com>
Subject: [PATCH v2] x86: fix ktermios-termio conversion
Date: Mon, 11 May 2009 23:19:17 +0000 [thread overview]
Message-ID: <200905112319.17999.arnd@arndb.de> (raw)
In-Reply-To: <200905112259.04714.arnd@arndb.de>
The operation with the variable 'c_line' was missing in the function
'user_termio_to_kernel_termios'. Also the casting '*(unsigned short *)'
in the macro 'SET_LOW_TERMIOS_BITS' was a bit 'unhealthy'. So the macro
was removed and the function was changed to be like in other archs
(e.g. h8300, m68k, sparc) that have a more elegant solution.
In the function 'kernel_termios_to_user_termio' the return values of
the functions calls 'put_user' and 'copy_to_user' were not being
checked.
Signed-off-by: Remis Lima Baima <remis.developer@googlemail.com>
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
---
initial patch was wordwrapped, resend
arch/x86/include/asm/termios.h | 54 +++++++++++++++++++++++++++------------
1 files changed, 37 insertions(+), 17 deletions(-)
diff --git a/arch/x86/include/asm/termios.h b/arch/x86/include/asm/termios.h
index f729563..47420df 100644
--- a/arch/x86/include/asm/termios.h
+++ b/arch/x86/include/asm/termios.h
@@ -54,20 +54,37 @@ struct termio {
/*
* Translate a "termio" structure into a "termios". Ugh.
*/
-#define SET_LOW_TERMIOS_BITS(termios, termio, x) { \
- unsigned short __tmp; \
- get_user(__tmp,&(termio)->x); \
- *(unsigned short *) &(termios)->x = __tmp; \
-}
-
static inline int user_termio_to_kernel_termios(struct ktermios *termios,
struct termio __user *termio)
{
- SET_LOW_TERMIOS_BITS(termios, termio, c_iflag);
- SET_LOW_TERMIOS_BITS(termios, termio, c_oflag);
- SET_LOW_TERMIOS_BITS(termios, termio, c_cflag);
- SET_LOW_TERMIOS_BITS(termios, termio, c_lflag);
- return copy_from_user(termios->c_cc, termio->c_cc, NCC);
+ unsigned short tmp;
+
+ if (get_user(tmp, &termio->c_iflag) < 0)
+ goto fault;
+ termios->c_iflag = (0xffff0000 & termios->c_iflag) | tmp;
+
+ if (get_user(tmp, &termio->c_oflag) < 0)
+ goto fault;
+ termios->c_oflag = (0xffff0000 & termios->c_oflag) | tmp;
+
+ if (get_user(tmp, &termio->c_cflag) < 0)
+ goto fault;
+ termios->c_cflag = (0xffff0000 & termios->c_cflag) | tmp;
+
+ if (get_user(tmp, &termio->c_lflag) < 0)
+ goto fault;
+ termios->c_lflag = (0xffff0000 & termios->c_lflag) | tmp;
+
+ if (get_user(termios->c_line, &termio->c_line) < 0)
+ goto fault;
+
+ if (copy_from_user(termios->c_cc, termio->c_cc, NCC) != 0)
+ goto fault;
+
+ return 0;
+
+ fault:
+ return -EFAULT;
}
/*
@@ -76,12 +93,15 @@ static inline int user_termio_to_kernel_termios(struct ktermios *termios,
static inline int kernel_termios_to_user_termio(struct termio __user *termio,
struct ktermios *termios)
{
- put_user((termios)->c_iflag, &(termio)->c_iflag);
- put_user((termios)->c_oflag, &(termio)->c_oflag);
- put_user((termios)->c_cflag, &(termio)->c_cflag);
- put_user((termios)->c_lflag, &(termio)->c_lflag);
- put_user((termios)->c_line, &(termio)->c_line);
- return copy_to_user((termio)->c_cc, (termios)->c_cc, NCC);
+ if (put_user(termios->c_iflag, &termio->c_iflag) < 0 ||
+ put_user(termios->c_oflag, &termio->c_oflag) < 0 ||
+ put_user(termios->c_cflag, &termio->c_cflag) < 0 ||
+ put_user(termios->c_lflag, &termio->c_lflag) < 0 ||
+ put_user(termios->c_line, &termio->c_line) < 0 ||
+ copy_to_user(termio->c_cc, termios->c_cc, NCC) != 0)
+ return -EFAULT;
+
+ return 0;
}
static inline int user_termios_to_kernel_termios(struct ktermios *k,
--
1.6.0.4
next prev parent reply other threads:[~2009-05-11 23:19 UTC|newest]
Thread overview: 74+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20090511222702.352192505@arndb.de>
2009-05-11 22:37 ` [PATCH] mb862xxfb: use CONFIG_OF instead of CONFIG_PPC_OF Arnd Bergmann
2009-05-13 12:25 ` Anatolij Gustschin
2009-05-11 22:38 ` [PATCH] ata: libata depends on HAS_DMA Arnd Bergmann
2009-05-12 0:58 ` Jeff Garzik
2009-05-12 12:40 ` Arnd Bergmann
2009-05-12 13:05 ` Arnd Bergmann
2009-05-12 8:06 ` Alan Cox
2009-05-12 9:23 ` Arnd Bergmann
2009-05-13 3:30 ` Brad Boyer
2009-05-13 4:12 ` Michael Schmitz
2009-05-13 4:34 ` Brad Boyer
2009-05-13 8:51 ` Alan Cox
2009-05-13 8:55 ` Geert Uytterhoeven
2009-05-13 23:57 ` Robert Hancock
2009-05-14 0:18 ` FUJITA Tomonori
2009-05-15 5:31 ` Tejun Heo
2009-05-15 11:16 ` Arnd Bergmann
2009-05-15 11:21 ` Tejun Heo
2009-05-15 11:55 ` Arnd Bergmann
2009-05-17 9:00 ` Robert Hancock
2009-05-17 19:38 ` Arnd Bergmann
2009-05-17 20:05 ` Jeff Garzik
2009-05-17 22:45 ` [PATCH] asm-generic: add a dma-mapping.h file Arnd Bergmann
2009-05-18 6:03 ` Geert Uytterhoeven
2009-05-18 8:28 ` Arnd Bergmann
2009-05-18 10:45 ` FUJITA Tomonori
2009-05-18 14:45 ` Arnd Bergmann
2009-05-18 22:44 ` FUJITA Tomonori
2009-05-19 16:22 ` Arnd Bergmann
2009-05-19 17:01 ` Grant Grundler
2009-05-19 17:40 ` Arnd Bergmann
2009-05-19 18:08 ` Grant Grundler
2009-05-22 12:12 ` FUJITA Tomonori
2009-05-22 14:07 ` Arnd Bergmann
2009-05-22 14:38 ` FUJITA Tomonori
2009-05-22 15:05 ` Arnd Bergmann
2009-05-26 4:36 ` FUJITA Tomonori
2009-05-26 12:35 ` Arnd Bergmann
2009-05-27 3:58 ` FUJITA Tomonori
2009-05-18 22:54 ` Jeff Garzik
2009-05-18 23:22 ` FUJITA Tomonori
2009-05-18 10:45 ` [PATCH] ata: libata depends on HAS_DMA FUJITA Tomonori
2009-05-13 10:39 ` Arnd Bergmann
2009-05-11 22:40 ` [PATCH] scsi: libsas " Arnd Bergmann
2009-05-11 22:50 ` James Bottomley
2009-05-11 22:59 ` James Bottomley
2009-05-11 23:16 ` Arnd Bergmann
2009-05-11 22:43 ` [PATCH] arm: rename CLOCK_TICK_RATE to ARM_TICK_RATE Arnd Bergmann
2009-05-11 23:11 ` [PATCH v2] " Arnd Bergmann
2009-05-13 17:11 ` [PATCH] " Arnd Bergmann
2009-05-11 22:50 ` [PATCH] x86: use PIT_TICK_RATE consistently Arnd Bergmann
2009-05-11 23:05 ` Arnd Bergmann
2009-05-11 22:55 ` [PATCH] move PIT_TICK_RATE to linux/timex.h Arnd Bergmann
2009-05-12 0:01 ` Andrew Morton
2009-05-12 0:36 ` Arnd Bergmann
2009-05-11 22:57 ` [PATCH] mips: use PIT_TICK_RATE in i8253 Arnd Bergmann
2009-05-11 22:58 ` [PATCH] input: use PIT_TICK_RATE in vt beep ioctl Arnd Bergmann
2009-05-12 9:31 ` Alan Cox
2009-05-11 22:59 ` [PATCH] x86: fix ktermios-termio conversion Arnd Bergmann
2009-05-11 23:19 ` Arnd Bergmann [this message]
2009-05-12 7:55 ` [PATCH v2] " Ingo Molnar
2009-05-12 9:04 ` Arnd Bergmann
2009-05-12 9:10 ` Ingo Molnar
2009-05-12 9:21 ` Alan Cox
2009-05-12 9:26 ` Ingo Molnar
2009-05-12 10:05 ` Alan Cox
2009-05-12 10:15 ` Ingo Molnar
2009-05-12 11:33 ` [PATCH v3] " Arnd Bergmann
2009-05-12 11:42 ` [PATCH v2] " Arnd Bergmann
2009-05-12 9:17 ` Alan Cox
2009-05-11 23:02 ` [PATCH] ipc: use __ARCH_WANT_IPC_PARSE_VERSION in ipc/util.h Arnd Bergmann
2009-05-12 0:19 ` Serge E. Hallyn
2009-05-11 23:03 ` [PATCH] syscalls.h add the missing sys_pipe2 declaration Arnd Bergmann
2009-05-11 23:08 ` Arnd Bergmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200905112319.17999.arnd@arndb.de \
--to=arnd@arndb.de \
--cc=linux-kernel@vger.kernel.org \
--cc=remis.developer@googlemail.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome