From: Arnd Bergmann <arnd@arndb.de>
To: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] asm-generic: add a dma-mapping.h file
Date: Tue, 26 May 2009 13:35:41 +0100 [thread overview]
Message-ID: <200905261335.41643.arnd@arndb.de> (raw)
In-Reply-To: <20090526122423S.fujita.tomonori@lab.ntt.co.jp>
On Tuesday 26 May 2009, FUJITA Tomonori wrote:
> > dma_get_cache_alignment() is still less generic than
> > the other functions, as this is still architecture
> > specific. Should I leave that out as well then?
>
> Yes, I think that only adding generic functions is a better
> approach. Overriding with #ifdef is really ugly.
>
Ok, will do.
[trimming Cc list a bit, as the subject has changed]
Could you be more specific as to why you think the #ifdef
in this file is ugly? I agree that we should always avoid
#ifdef in a device driver file or around the usage of an
API, but we use it everywhere when defining an optional
API, e.g.
#ifdef CONFIG_DMA_API_DEBUG
extern void dma_debug_add_bus(struct bus_type *bus);
#else
static inline void dma_debug_add_bus(struct bus_type *bus)
{
{
#endif
or
#ifndef clear_user_highpage
static inline void clear_user_highpage(struct page *page, unsigned long vaddr)
{
void *addr = kmap_atomic(page, KM_USER0);
clear_user_page(addr, vaddr, page);
kunmap_atomic(addr, KM_USER0);
}
#endif
This has always made a lot of sense to me when you are defining
something that you want to become a No-op in certain configurations
or that only needs special handling in a few cases. IIRC, Linus
has stated that he prefers the second of the two styles above when
you have the choice, which is why I started out that way, while
for the dma_debug stuff, the CONFIG_ symbol clearly makes sense.
Arnd <><
next prev parent reply other threads:[~2009-05-26 12:35 UTC|newest]
Thread overview: 74+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20090511222702.352192505@arndb.de>
2009-05-11 22:37 ` [PATCH] mb862xxfb: use CONFIG_OF instead of CONFIG_PPC_OF Arnd Bergmann
2009-05-13 12:25 ` Anatolij Gustschin
2009-05-11 22:38 ` [PATCH] ata: libata depends on HAS_DMA Arnd Bergmann
2009-05-12 0:58 ` Jeff Garzik
2009-05-12 12:40 ` Arnd Bergmann
2009-05-12 13:05 ` Arnd Bergmann
2009-05-12 8:06 ` Alan Cox
2009-05-12 9:23 ` Arnd Bergmann
2009-05-13 3:30 ` Brad Boyer
2009-05-13 4:12 ` Michael Schmitz
2009-05-13 4:34 ` Brad Boyer
2009-05-13 8:51 ` Alan Cox
2009-05-13 8:55 ` Geert Uytterhoeven
2009-05-13 23:57 ` Robert Hancock
2009-05-14 0:18 ` FUJITA Tomonori
2009-05-15 5:31 ` Tejun Heo
2009-05-15 11:16 ` Arnd Bergmann
2009-05-15 11:21 ` Tejun Heo
2009-05-15 11:55 ` Arnd Bergmann
2009-05-17 9:00 ` Robert Hancock
2009-05-17 19:38 ` Arnd Bergmann
2009-05-17 20:05 ` Jeff Garzik
2009-05-17 22:45 ` [PATCH] asm-generic: add a dma-mapping.h file Arnd Bergmann
2009-05-18 6:03 ` Geert Uytterhoeven
2009-05-18 8:28 ` Arnd Bergmann
2009-05-18 10:45 ` FUJITA Tomonori
2009-05-18 14:45 ` Arnd Bergmann
2009-05-18 22:44 ` FUJITA Tomonori
2009-05-19 16:22 ` Arnd Bergmann
2009-05-19 17:01 ` Grant Grundler
2009-05-19 17:40 ` Arnd Bergmann
2009-05-19 18:08 ` Grant Grundler
2009-05-22 12:12 ` FUJITA Tomonori
2009-05-22 14:07 ` Arnd Bergmann
2009-05-22 14:38 ` FUJITA Tomonori
2009-05-22 15:05 ` Arnd Bergmann
2009-05-26 4:36 ` FUJITA Tomonori
2009-05-26 12:35 ` Arnd Bergmann [this message]
2009-05-27 3:58 ` FUJITA Tomonori
2009-05-18 22:54 ` Jeff Garzik
2009-05-18 23:22 ` FUJITA Tomonori
2009-05-18 10:45 ` [PATCH] ata: libata depends on HAS_DMA FUJITA Tomonori
2009-05-13 10:39 ` Arnd Bergmann
2009-05-11 22:40 ` [PATCH] scsi: libsas " Arnd Bergmann
2009-05-11 22:50 ` James Bottomley
2009-05-11 22:59 ` James Bottomley
2009-05-11 23:16 ` Arnd Bergmann
2009-05-11 22:43 ` [PATCH] arm: rename CLOCK_TICK_RATE to ARM_TICK_RATE Arnd Bergmann
2009-05-11 23:11 ` [PATCH v2] " Arnd Bergmann
2009-05-13 17:11 ` [PATCH] " Arnd Bergmann
2009-05-11 22:50 ` [PATCH] x86: use PIT_TICK_RATE consistently Arnd Bergmann
2009-05-11 23:05 ` Arnd Bergmann
2009-05-11 22:55 ` [PATCH] move PIT_TICK_RATE to linux/timex.h Arnd Bergmann
2009-05-12 0:01 ` Andrew Morton
2009-05-12 0:36 ` Arnd Bergmann
2009-05-11 22:57 ` [PATCH] mips: use PIT_TICK_RATE in i8253 Arnd Bergmann
2009-05-11 22:58 ` [PATCH] input: use PIT_TICK_RATE in vt beep ioctl Arnd Bergmann
2009-05-12 9:31 ` Alan Cox
2009-05-11 22:59 ` [PATCH] x86: fix ktermios-termio conversion Arnd Bergmann
2009-05-11 23:19 ` [PATCH v2] " Arnd Bergmann
2009-05-12 7:55 ` Ingo Molnar
2009-05-12 9:04 ` Arnd Bergmann
2009-05-12 9:10 ` Ingo Molnar
2009-05-12 9:21 ` Alan Cox
2009-05-12 9:26 ` Ingo Molnar
2009-05-12 10:05 ` Alan Cox
2009-05-12 10:15 ` Ingo Molnar
2009-05-12 11:33 ` [PATCH v3] " Arnd Bergmann
2009-05-12 11:42 ` [PATCH v2] " Arnd Bergmann
2009-05-12 9:17 ` Alan Cox
2009-05-11 23:02 ` [PATCH] ipc: use __ARCH_WANT_IPC_PARSE_VERSION in ipc/util.h Arnd Bergmann
2009-05-12 0:19 ` Serge E. Hallyn
2009-05-11 23:03 ` [PATCH] syscalls.h add the missing sys_pipe2 declaration Arnd Bergmann
2009-05-11 23:08 ` Arnd Bergmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200905261335.41643.arnd@arndb.de \
--to=arnd@arndb.de \
--cc=fujita.tomonori@lab.ntt.co.jp \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome