From: Oleg Nesterov <oleg@redhat.com>
To: Andi Kleen <andi@firstfloor.org>
Cc: Alexey Dobriyan <adobriyan@gmail.com>,
Ananth Mavinakayanahalli <ananth@in.ibm.com>,
Christoph Hellwig <hch@infradead.org>,
"Frank Ch. Eigler" <fche@redhat.com>,
Ingo@firstfloor.org, "Molnar <mingo"@firstfloor.org,
utrace-devel@redhat.com, linux-kernel@vger.kernel.org
Subject: Re: [RFC,PATCH 14/14] utrace core
Date: Tue, 24 Nov 2009 21:41:52 +0100 [thread overview]
Message-ID: <20091124204152.GA9131@redhat.com> (raw)
In-Reply-To: <87my2bwtno.fsf@basil.nowhere.org>
On 11/24, Andi Kleen wrote:
>
> Oleg Nesterov <oleg@redhat.com> writes:
>
> > From: Roland McGrath <roland@redhat.com>
> >
> > This adds the utrace facility, a new modular interface in the kernel
> > for implementing user thread tracing and debugging. This fits on top
> > of the tracehook_* layer, so the new code is well-isolated.
>
> Could we just drop the tracehook layer if this finally merged
> and call the low level functions directly?
Not sure I understand. Tracehooks are trivial inline wrappers on
top utrace calls,
> It might have been reasonably early on when it was still out of tree,
> but longer term when it's integrated having strange opaque hooks
> like that just makes the coder harder to read and maintain.
Well, I don't think the code will be better if we remove tracehooks.
For example. tracehook_report_syscall_entry() has a lot of callers
in arch/, each callsite should be changed to do
if ((task_utrace_flags(current) & UTRACE_EVENT(SYSCALL_ENTRY)) &&
utrace_report_syscall_entry(regs))
ret = -1; // this depends on machine
instead of simply calling tracehook_report_syscall_entry().
What is the point?
But again, perhaps I misunderstood you.
Oleg.
next prev parent reply other threads:[~2009-11-24 20:47 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-11-24 20:02 Oleg Nesterov
2009-11-24 20:32 ` Andi Kleen
2009-11-24 20:41 ` Oleg Nesterov [this message]
2009-11-24 21:26 ` Andi Kleen
2009-11-24 21:31 ` Frank Ch. Eigler
2009-11-24 21:34 ` Andi Kleen
2009-11-24 21:44 ` Oleg Nesterov
2009-11-25 8:46 ` Andi Kleen
2009-11-25 14:55 ` Oleg Nesterov
2009-11-25 16:00 ` Ingo Molnar
2009-11-25 21:50 ` Christoph Hellwig
2009-12-01 23:47 ` Roland McGrath
2009-12-01 19:54 ` Peter Zijlstra
2009-12-01 22:08 ` Oleg Nesterov
2009-12-07 18:34 ` Peter Zijlstra
2009-12-08 15:04 ` Oleg Nesterov
2009-12-08 15:29 ` Peter Zijlstra
2009-12-08 16:31 ` Oleg Nesterov
2009-12-08 18:19 ` Peter Zijlstra
2009-12-08 18:37 ` Oleg Nesterov
2009-12-13 20:48 ` Roland McGrath
2009-12-08 15:35 ` Peter Zijlstra
2009-12-08 17:51 ` Oleg Nesterov
2009-12-02 5:44 ` Roland McGrath
2009-12-02 18:34 ` Oleg Nesterov
2009-12-02 18:49 ` Oleg Nesterov
2009-12-05 19:14 ` Roland McGrath
2009-12-14 0:25 ` Roland McGrath
2009-12-14 13:51 ` Peter Zijlstra
2009-12-14 17:41 ` Oleg Nesterov
2009-12-14 19:31 ` Oleg Nesterov
2009-12-14 19:42 ` Roland McGrath
2009-12-16 11:18 ` Roland McGrath
2009-12-14 17:03 ` Oleg Nesterov
2009-12-14 19:44 ` Roland McGrath
2009-12-14 20:24 ` Oleg Nesterov
2009-12-15 2:59 ` Roland McGrath
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20091124204152.GA9131@redhat.com \
--to=oleg@redhat.com \
--cc="Molnar <mingo"@firstfloor.org \
--cc=Ingo@firstfloor.org \
--cc=adobriyan@gmail.com \
--cc=ananth@in.ibm.com \
--cc=andi@firstfloor.org \
--cc=fche@redhat.com \
--cc=hch@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=utrace-devel@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome