* [PATCH] DRM: Rename clamp variable
@ 2009-12-21 1:24 Andi Kleen
2009-12-21 5:39 ` Dave Airlie
0 siblings, 1 reply; 2+ messages in thread
From: Andi Kleen @ 2009-12-21 1:24 UTC (permalink / raw)
To: airlied, linux-kernel
DRM: Rename clamp variable
linux/kernel.h has a "clamp" macro, but r300_cmdbuf also uses a variable
with the same name. Right now it doesn't seem to include the header,
but sooner or later someone will. So better rename the variable
now.
Signed-off-by: Andi Kleen <ak@linux.intel.com>
---
drivers/gpu/drm/radeon/r300_cmdbuf.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Index: linux-2.6.33-rc1-ak/drivers/gpu/drm/radeon/r300_cmdbuf.c
===================================================================
--- linux-2.6.33-rc1-ak.orig/drivers/gpu/drm/radeon/r300_cmdbuf.c
+++ linux-2.6.33-rc1-ak/drivers/gpu/drm/radeon/r300_cmdbuf.c
@@ -990,7 +990,7 @@ static inline int r300_emit_r500fp(drm_r
int sz;
int addr;
int type;
- int clamp;
+ int isclamp;
int stride;
RING_LOCALS;
@@ -999,10 +999,10 @@ static inline int r300_emit_r500fp(drm_r
addr = ((header.r500fp.adrhi_flags & 1) << 8) | header.r500fp.adrlo;
type = !!(header.r500fp.adrhi_flags & R500FP_CONSTANT_TYPE);
- clamp = !!(header.r500fp.adrhi_flags & R500FP_CONSTANT_CLAMP);
+ isclamp = !!(header.r500fp.adrhi_flags & R500FP_CONSTANT_CLAMP);
addr |= (type << 16);
- addr |= (clamp << 17);
+ addr |= (isclamp << 17);
stride = type ? 4 : 6;
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] DRM: Rename clamp variable
2009-12-21 1:24 [PATCH] DRM: Rename clamp variable Andi Kleen
@ 2009-12-21 5:39 ` Dave Airlie
0 siblings, 0 replies; 2+ messages in thread
From: Dave Airlie @ 2009-12-21 5:39 UTC (permalink / raw)
To: Andi Kleen; +Cc: linux-kernel
On Mon, Dec 21, 2009 at 11:24 AM, Andi Kleen <andi@firstfloor.org> wrote:
> DRM: Rename clamp variable
>
> linux/kernel.h has a "clamp" macro, but r300_cmdbuf also uses a variable
> with the same name. Right now it doesn't seem to include the header,
> but sooner or later someone will. So better rename the variable
> now.
>
> Signed-off-by: Andi Kleen <ak@linux.intel.com>
Queued for drm-core-next, will push to Linus in next push.
Thanks,
Dave.
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2009-12-21 5:39 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-12-21 1:24 [PATCH] DRM: Rename clamp variable Andi Kleen
2009-12-21 5:39 ` Dave Airlie
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®