From: Heiko Carstens <heiko.carstens@de.ibm.com>
To: Jason Baron <jbaron@redhat.com>
Cc: linux-kernel@vger.kernel.org, laijs@cn.fujitsu.com,
lizf@cn.fujitsu.com, rostedt@goodmis.org, fweisbec@gmail.com,
mingo@elte.hu, hpa@zytor.com, tglx@linutronix.de,
mhiramat@redhat.com
Subject: Re: [PATCH 5/6] syscalls: add define syscall prefix macro
Date: Wed, 3 Feb 2010 14:01:04 +0100 [thread overview]
Message-ID: <20100203130104.GB30003@osiris.boeblingen.de.ibm.com> (raw)
In-Reply-To: <ce5ccbcc86e34954948239b17010c5537fb62917.1265142153.git.jbaron@redhat.com>
On Tue, Feb 02, 2010 at 04:21:55PM -0500, Jason Baron wrote:
> Add a new 'SYSCALL_PREFIX_DEFINE#()' style macro to include/linux/syscalls.h.
> This allows us to create syscalls via:
>
> SYSCALL_PREFIX_DEFINE1(32_, mmap, struct mmap_arg_struct __user *, arg);
>
> The standard 'SYSCALL_DEFINE#()' macro forces 'sys_blah', but for the 32 compat
> calls we want 'sys32_blah'.
Not really. That's what you want for x86. But the generic name for compat syscalls
is compat_sys_whatever. The arch specific compat syscalls don't follow a common
naming scheme (yet).
Especially if you consider the idea to get automated correct sign extension via
hpa's planned script for compat syscalls it would be good if you would just name
that define something like SYSCALL_COMPAT.. or COMPAT_SYSCALL..
That way it would be easy to add a hook in there.
next prev parent reply other threads:[~2010-02-03 13:01 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-02-02 21:21 [PATCH 0/6] tracing: add compat syscall support Jason Baron
2010-02-02 21:21 ` [PATCH 1/6] x86: add NR_syscalls_compat, make ia32 syscall table visible Jason Baron
2010-02-02 21:21 ` [PATCH 2/6] x86: add arch_compat_syscall_addr() Jason Baron
2010-02-02 21:21 ` [PATCH 3/6] tracing: remove syscall bitmaps in preparation for compat support Jason Baron
2010-02-02 21:21 ` [PATCH 4/6] tracing: add tracing support for compat syscalls Jason Baron
2010-02-03 12:52 ` Heiko Carstens
2010-02-08 15:43 ` Jason Baron
2010-02-08 16:34 ` Heiko Carstens
2010-02-09 10:21 ` Heiko Carstens
2010-02-09 14:54 ` Jason Baron
2010-02-02 21:21 ` [PATCH 5/6] syscalls: add define syscall prefix macro Jason Baron
2010-02-03 13:01 ` Heiko Carstens [this message]
2010-02-08 15:48 ` Jason Baron
2010-02-08 16:12 ` Arnd Bergmann
2010-02-08 17:54 ` Christoph Hellwig
2010-02-08 20:48 ` Arnd Bergmann
2010-02-08 16:53 ` Randy Dunlap
2010-02-08 17:11 ` Jason Baron
2010-02-10 3:00 ` Steven Rostedt
2010-02-02 21:22 ` [PATCH 6/6] x86: convert compat syscalls to use 'DEFINE_SYSCALL()' macros Jason Baron
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20100203130104.GB30003@osiris.boeblingen.de.ibm.com \
--to=heiko.carstens@de.ibm.com \
--cc=fweisbec@gmail.com \
--cc=hpa@zytor.com \
--cc=jbaron@redhat.com \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lizf@cn.fujitsu.com \
--cc=mhiramat@redhat.com \
--cc=mingo@elte.hu \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®