From: Tejun Heo <tj@kernel.org>
To: Lai Jiangshan <laijs@cn.fujitsu.com>
Cc: linux-kernel@vger.kernel.org,
Peter Zijlstra <peterz@infradead.org>,
Viresh Kumar <viresh.kumar@linaro.org>,
Ingo Molnar <mingo@kernel.org>
Subject: Re: [PATCH 05/10 V2] workqueue: separate iteration role from worker_idr
Date: Mon, 12 May 2014 17:35:53 -0400 [thread overview]
Message-ID: <20140512213553.GE18959@mtj.dyndns.org> (raw)
In-Reply-To: <1399877792-13046-6-git-send-email-laijs@cn.fujitsu.com>
On Mon, May 12, 2014 at 02:56:17PM +0800, Lai Jiangshan wrote:
> worker_idr has the iteration(iterating for attached workers) and worker ID
^
Please put a space before an opening parenthses. It becomes a lot
easier on the eyes.
> duties. These two duties are not necessary tied together. We can separate
necessarily
> them and use a list for tracking attached workers and iteration
>
> After separation, we can add the rescuer workers to the list for iteration
> in future. worker_idr can't add rescuer workers due to rescuer workers
> can't allocate id from worker_idr.
Explaining how that'd be beneficial and justifies this change would be
nice.
...
> /**
> - * for_each_pool_worker - iterate through all workers of a worker_pool
> - * @worker: iteration cursor
> - * @wi: integer used for iteration
> - * @pool: worker_pool to iterate workers of
> - *
> - * This must be called with @pool->manager_mutex.
> - *
> - * The if/else clause exists only for the lockdep assertion and can be
> - * ignored.
> - */
> -#define for_each_pool_worker(worker, wi, pool) \
> - idr_for_each_entry(&(pool)->worker_idr, (worker), (wi)) \
> - if (({ lockdep_assert_held(&pool->manager_mutex); false; })) { } \
> - else
Hmmm.... don't we still want the lockdep protection?
> @@ -1772,6 +1759,8 @@ static struct worker *create_worker(struct worker_pool *pool)
>
> /* successful, commit the pointer to idr */
/* successful, commit it to idr and link on the workers list */
> idr_replace(&pool->worker_idr, worker, worker->id);
> + /* successful, attach the worker to the pool */
and lose the above line.
> diff --git a/kernel/workqueue_internal.h b/kernel/workqueue_internal.h
> index 7e2204d..c44abc3 100644
> --- a/kernel/workqueue_internal.h
> +++ b/kernel/workqueue_internal.h
> @@ -37,6 +37,7 @@ struct worker {
> struct task_struct *task; /* I: worker task */
> struct worker_pool *pool; /* I: the associated pool */
> /* L: for rescuers */
> + struct list_head node; /* M: attached to the pool */
/* M: anchored at pool->workers */
Thanks.
--
tejun
next prev parent reply other threads:[~2014-05-12 21:36 UTC|newest]
Thread overview: 78+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-04-27 4:08 [PATCH 00/10] workqueue: async worker destruction and pool-binding synchronization Lai Jiangshan
2014-04-27 4:08 ` [PATCH 01/10] workqueue: use manager lock only to protect worker_idr Lai Jiangshan
2014-05-05 13:01 ` Tejun Heo
2014-05-06 15:43 ` Lai Jiangshan
2014-04-27 4:08 ` [PATCH 02/10] workqueue: destroy_worker() should destroy idle workers only Lai Jiangshan
2014-05-05 13:13 ` Tejun Heo
2014-05-06 15:58 ` Lai Jiangshan
2014-04-27 4:08 ` [PATCH 03/10] workqueue: async worker destruction Lai Jiangshan
2014-05-05 14:31 ` Tejun Heo
2014-05-05 15:02 ` Tejun Heo
2014-05-06 16:27 ` Lai Jiangshan
2014-05-06 16:31 ` Tejun Heo
2014-05-07 7:30 ` Lai Jiangshan
2014-05-07 13:15 ` Tejun Heo
2014-04-27 4:08 ` [PATCH 04/10] workqueue: destroy worker directly in the idle timeout handler Lai Jiangshan
2014-05-05 14:36 ` Tejun Heo
2014-05-07 7:10 ` Lai Jiangshan
2014-05-07 13:12 ` Tejun Heo
2014-05-07 13:38 ` Lai Jiangshan
2014-05-07 13:41 ` Tejun Heo
2014-05-07 15:30 ` Lai Jiangshan
2014-05-07 15:37 ` Tejun Heo
2014-04-27 4:09 ` [PATCH 05/10] workqueue: separate iteration role from worker_idr Lai Jiangshan
2014-05-05 14:57 ` Tejun Heo
2014-04-27 4:09 ` [PATCH 06/10] workqueue: convert worker_idr to worker_ida Lai Jiangshan
2014-05-05 14:59 ` Tejun Heo
2014-05-06 16:33 ` Lai Jiangshan
2014-05-06 16:35 ` Tejun Heo
2014-05-06 16:38 ` Tejun Heo
2014-04-27 4:09 ` [PATCH 07/10] workqueue: narrow the protection range of manager_mutex Lai Jiangshan
2014-04-27 4:09 ` [PATCH 08/10] workqueue: rename manager_mutex to bind_mutex Lai Jiangshan
2014-04-27 4:09 ` [PATCH 09/10] workqueue: separate pool-binding code out from create_worker() Lai Jiangshan
2014-04-27 4:09 ` [PATCH 10/10] workqueue: use generic pool-bind/unbind routine for rescuers Lai Jiangshan
2014-05-05 14:54 ` Tejun Heo
2014-05-05 15:05 ` [PATCH 00/10] workqueue: async worker destruction and pool-binding synchronization Tejun Heo
2014-05-12 6:56 ` [PATCH 00/10 V2] workqueue: async worker destruction and worker attaching/detaching Lai Jiangshan
2014-05-12 6:56 ` [PATCH 01/10 V2] workqueue: use manager lock only to protect worker_idr Lai Jiangshan
2014-05-12 6:56 ` [PATCH 02/10 V2] workqueue: destroy_worker() should destroy idle workers only Lai Jiangshan
2014-05-12 21:08 ` Tejun Heo
2014-05-13 6:08 ` Lai Jiangshan
2014-05-12 6:56 ` [PATCH 03/10 V2] workqueue: async worker destruction Lai Jiangshan
2014-05-12 21:20 ` Tejun Heo
2014-05-13 6:32 ` Lai Jiangshan
2014-05-13 14:14 ` Tejun Heo
2014-05-20 9:54 ` Lai Jiangshan
2014-05-12 6:56 ` [PATCH 04/10 V2] workqueue: destroy worker directly in the idle timeout handler Lai Jiangshan
2014-05-12 21:26 ` Tejun Heo
2014-05-12 6:56 ` [PATCH 05/10 V2] workqueue: separate iteration role from worker_idr Lai Jiangshan
2014-05-12 21:35 ` Tejun Heo [this message]
2014-05-12 21:37 ` Tejun Heo
2014-05-12 6:56 ` [PATCH 06/10 V2] workqueue: convert worker_idr to worker_ida Lai Jiangshan
2014-05-12 21:40 ` Tejun Heo
2014-05-13 6:43 ` Lai Jiangshan
2014-05-13 14:17 ` Tejun Heo
2014-05-12 6:56 ` [PATCH 07/10 V2] workqueue: narrow the protection range of manager_mutex Lai Jiangshan
2014-05-12 6:56 ` [PATCH 08/10 V2] workqueue: rename manager_mutex to attach_mutex Lai Jiangshan
2014-05-12 22:01 ` Tejun Heo
2014-05-13 6:45 ` Lai Jiangshan
2014-05-13 14:19 ` Tejun Heo
2014-05-12 6:56 ` [PATCH 09/10 V2] workqueue: separate pool-attaching code out from create_worker() Lai Jiangshan
2014-05-12 6:56 ` [PATCH 10/10 V2] workqueue: use generic attach/detach routine for rescuers Lai Jiangshan
2014-05-12 22:05 ` Tejun Heo
2014-05-13 6:55 ` Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 00/10] workqueue: async worker destruction and worker attaching/detaching Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 01/10] workqueue: use manager lock only to protect worker_idr Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 02/10] workqueue: destroy_worker() should destroy idle workers only Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 03/10] workqueue: async worker destruction Lai Jiangshan
2014-05-20 14:22 ` Tejun Heo
2014-05-20 14:23 ` Tejun Heo
2014-05-20 14:24 ` Tejun Heo
2014-05-20 9:46 ` [PATCH V3 04/10] workqueue: destroy worker directly in the idle timeout handler Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 05/10] workqueue: separate iteration role from worker_idr Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 06/10] workqueue: convert worker_idr to worker_ida Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 07/10] workqueue: narrow the protection range of manager_mutex Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 08/10] workqueue: rename manager_mutex to attach_mutex Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 09/10] workqueue: separate pool-attaching code out from create_worker() Lai Jiangshan
2014-05-20 9:46 ` [PATCH V3 10/10] workqueue: use generic attach/detach routine for rescuers Lai Jiangshan
2014-05-20 15:00 ` [PATCH V3 00/10] workqueue: async worker destruction and worker attaching/detaching Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140512213553.GE18959@mtj.dyndns.org \
--to=tj@kernel.org \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=peterz@infradead.org \
--cc=viresh.kumar@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®