* [PATCH 0/4] staging: panel: Module parameters clean-up
@ 2014-11-12 1:08 Mariusz Gorski
2014-11-12 1:08 ` [PATCH 1/4] staging: panel: Reorder initial DEFAULT_* defines Mariusz Gorski
` (4 more replies)
0 siblings, 5 replies; 6+ messages in thread
From: Mariusz Gorski @ 2014-11-12 1:08 UTC (permalink / raw)
To: Greg Kroah-Hartman, Willy Tarreau; +Cc: devel, linux-kernel
This small set of patches (although it also could be a single patch...)
rearranges groups of defines, redefines and module parameter declarations,
so that they always appear in the same order defined by Kconfig, which
makes it more pleasant to read and understand. It's a preparation for
a bigger clean-up of current init code.
Mariusz Gorski (4):
staging: panel: Reorder initial DEFAULT_* defines
staging: panel: Reorder DEFAULT_* values redefines
staging: panel: Reorder module parameter declarations
staging: panel: Use better names for two defined values
drivers/staging/panel/panel.c | 121 ++++++++++++++++++++++--------------------
1 file changed, 62 insertions(+), 59 deletions(-)
--
2.1.3
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 1/4] staging: panel: Reorder initial DEFAULT_* defines
2014-11-12 1:08 [PATCH 0/4] staging: panel: Module parameters clean-up Mariusz Gorski
@ 2014-11-12 1:08 ` Mariusz Gorski
2014-11-12 1:08 ` [PATCH 2/4] staging: panel: Reorder DEFAULT_* values redefines Mariusz Gorski
` (3 subsequent siblings)
4 siblings, 0 replies; 6+ messages in thread
From: Mariusz Gorski @ 2014-11-12 1:08 UTC (permalink / raw)
To: Greg Kroah-Hartman, Willy Tarreau; +Cc: devel, linux-kernel
Change the order of the initial DEFAULT_* defines so that it
matches the Kconfig order.
Signed-off-by: Mariusz Gorski <marius.gorski@gmail.com>
---
drivers/staging/panel/panel.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index d30ccb5..530f7e1 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -302,14 +302,15 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
/*
* Construct custom config from the kernel's configuration
*/
-#define DEFAULT_PROFILE PANEL_PROFILE_LARGE
#define DEFAULT_PARPORT 0
-#define DEFAULT_LCD LCD_TYPE_OLD
+#define DEFAULT_PROFILE PANEL_PROFILE_LARGE
#define DEFAULT_KEYPAD KEYPAD_TYPE_OLD
+#define DEFAULT_LCD LCD_TYPE_OLD
+#define DEFAULT_LCD_HEIGHT 2
#define DEFAULT_LCD_WIDTH 40
#define DEFAULT_LCD_BWIDTH 40
#define DEFAULT_LCD_HWIDTH 64
-#define DEFAULT_LCD_HEIGHT 2
+#define DEFAULT_LCD_CHARSET LCD_CHARSET_NORMAL
#define DEFAULT_LCD_PROTO LCD_PROTO_PARALLEL
#define DEFAULT_LCD_PIN_E PIN_AUTOLF
@@ -318,7 +319,6 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
#define DEFAULT_LCD_PIN_SCL PIN_STROBE
#define DEFAULT_LCD_PIN_SDA PIN_D0
#define DEFAULT_LCD_PIN_BL PIN_NOT_SET
-#define DEFAULT_LCD_CHARSET LCD_CHARSET_NORMAL
#ifdef CONFIG_PANEL_PROFILE
#undef DEFAULT_PROFILE
--
2.1.3
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 2/4] staging: panel: Reorder DEFAULT_* values redefines
2014-11-12 1:08 [PATCH 0/4] staging: panel: Module parameters clean-up Mariusz Gorski
2014-11-12 1:08 ` [PATCH 1/4] staging: panel: Reorder initial DEFAULT_* defines Mariusz Gorski
@ 2014-11-12 1:08 ` Mariusz Gorski
2014-11-12 1:08 ` [PATCH 3/4] staging: panel: Reorder module parameter declarations Mariusz Gorski
` (2 subsequent siblings)
4 siblings, 0 replies; 6+ messages in thread
From: Mariusz Gorski @ 2014-11-12 1:08 UTC (permalink / raw)
To: Greg Kroah-Hartman, Willy Tarreau; +Cc: devel, linux-kernel
Change the order of the DEFAULT_* values redefines so that it
matches the Kconfig order.
Signed-off-by: Mariusz Gorski <marius.gorski@gmail.com>
---
drivers/staging/panel/panel.c | 26 +++++++++++++-------------
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index 530f7e1..4434c1d 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -320,16 +320,16 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
#define DEFAULT_LCD_PIN_SDA PIN_D0
#define DEFAULT_LCD_PIN_BL PIN_NOT_SET
-#ifdef CONFIG_PANEL_PROFILE
-#undef DEFAULT_PROFILE
-#define DEFAULT_PROFILE CONFIG_PANEL_PROFILE
-#endif
-
#ifdef CONFIG_PANEL_PARPORT
#undef DEFAULT_PARPORT
#define DEFAULT_PARPORT CONFIG_PANEL_PARPORT
#endif
+#ifdef CONFIG_PANEL_PROFILE
+#undef DEFAULT_PROFILE
+#define DEFAULT_PROFILE CONFIG_PANEL_PROFILE
+#endif
+
#if DEFAULT_PROFILE == 0 /* custom */
#ifdef CONFIG_PANEL_KEYPAD
#undef DEFAULT_KEYPAD
@@ -341,6 +341,11 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
#define DEFAULT_LCD CONFIG_PANEL_LCD
#endif
+#ifdef CONFIG_PANEL_LCD_HEIGHT
+#undef DEFAULT_LCD_HEIGHT
+#define DEFAULT_LCD_HEIGHT CONFIG_PANEL_LCD_HEIGHT
+#endif
+
#ifdef CONFIG_PANEL_LCD_WIDTH
#undef DEFAULT_LCD_WIDTH
#define DEFAULT_LCD_WIDTH CONFIG_PANEL_LCD_WIDTH
@@ -356,9 +361,9 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
#define DEFAULT_LCD_HWIDTH CONFIG_PANEL_LCD_HWIDTH
#endif
-#ifdef CONFIG_PANEL_LCD_HEIGHT
-#undef DEFAULT_LCD_HEIGHT
-#define DEFAULT_LCD_HEIGHT CONFIG_PANEL_LCD_HEIGHT
+#ifdef CONFIG_PANEL_LCD_CHARSET
+#undef DEFAULT_LCD_CHARSET
+#define DEFAULT_LCD_CHARSET CONFIG_PANEL_LCD_CHARSET
#endif
#ifdef CONFIG_PANEL_LCD_PROTO
@@ -396,11 +401,6 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
#define DEFAULT_LCD_PIN_BL CONFIG_PANEL_LCD_PIN_BL
#endif
-#ifdef CONFIG_PANEL_LCD_CHARSET
-#undef DEFAULT_LCD_CHARSET
-#define DEFAULT_LCD_CHARSET CONFIG_PANEL_LCD_CHARSET
-#endif
-
#endif /* DEFAULT_PROFILE == 0 */
/* global variables */
--
2.1.3
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 3/4] staging: panel: Reorder module parameter declarations
2014-11-12 1:08 [PATCH 0/4] staging: panel: Module parameters clean-up Mariusz Gorski
2014-11-12 1:08 ` [PATCH 1/4] staging: panel: Reorder initial DEFAULT_* defines Mariusz Gorski
2014-11-12 1:08 ` [PATCH 2/4] staging: panel: Reorder DEFAULT_* values redefines Mariusz Gorski
@ 2014-11-12 1:08 ` Mariusz Gorski
2014-11-12 1:08 ` [PATCH 4/4] staging: panel: Use better names for two defined values Mariusz Gorski
2014-11-12 5:29 ` [PATCH 0/4] staging: panel: Module parameters clean-up Willy Tarreau
4 siblings, 0 replies; 6+ messages in thread
From: Mariusz Gorski @ 2014-11-12 1:08 UTC (permalink / raw)
To: Greg Kroah-Hartman, Willy Tarreau; +Cc: devel, linux-kernel
Change the order of the module parameter declarations
so that it matches the Kconfig order.
Signed-off-by: Mariusz Gorski <marius.gorski@gmail.com>
---
drivers/staging/panel/panel.c | 73 ++++++++++++++++++++++---------------------
1 file changed, 38 insertions(+), 35 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index 4434c1d..05b0d1e 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -433,6 +433,22 @@ static int parport = -1;
module_param(parport, int, 0000);
MODULE_PARM_DESC(parport, "Parallel port index (0=lpt1, 1=lpt2, ...)");
+static int profile = DEFAULT_PROFILE;
+module_param(profile, int, 0000);
+MODULE_PARM_DESC(profile,
+ "1=16x2 old kp; 2=serial 16x2, new kp; 3=16x2 hantronix; "
+ "4=16x2 nexcom; default=40x2, old kp");
+
+static int keypad_type = -1;
+module_param(keypad_type, int, 0000);
+MODULE_PARM_DESC(keypad_type,
+ "Keypad type: 0=none, 1=old 6 keys, 2=new 6+1 keys, 3=nexcom 4 keys");
+
+static int lcd_type = -1;
+module_param(lcd_type, int, 0000);
+MODULE_PARM_DESC(lcd_type,
+ "LCD type: 0=none, 1=old //, 2=serial ks0074, 3=hantronix //, 4=nexcom //, 5=compiled-in");
+
static int lcd_height = -1;
module_param(lcd_height, int, 0000);
MODULE_PARM_DESC(lcd_height, "Number of lines on the LCD");
@@ -449,39 +465,15 @@ static int lcd_hwidth = -1; /* hardware buffer width (usually 64) */
module_param(lcd_hwidth, int, 0000);
MODULE_PARM_DESC(lcd_hwidth, "LCD line hardware address (64)");
-static int lcd_enabled = -1;
-module_param(lcd_enabled, int, 0000);
-MODULE_PARM_DESC(lcd_enabled, "Deprecated option, use lcd_type instead");
-
-static int keypad_enabled = -1;
-module_param(keypad_enabled, int, 0000);
-MODULE_PARM_DESC(keypad_enabled, "Deprecated option, use keypad_type instead");
-
-static int lcd_type = -1;
-module_param(lcd_type, int, 0000);
-MODULE_PARM_DESC(lcd_type,
- "LCD type: 0=none, 1=old //, 2=serial ks0074, 3=hantronix //, 4=nexcom //, 5=compiled-in");
+static int lcd_charset = -1;
+module_param(lcd_charset, int, 0000);
+MODULE_PARM_DESC(lcd_charset, "LCD character set: 0=standard, 1=KS0074");
static int lcd_proto = -1;
module_param(lcd_proto, int, 0000);
MODULE_PARM_DESC(lcd_proto,
"LCD communication: 0=parallel (//), 1=serial, 2=TI LCD Interface");
-static int lcd_charset = -1;
-module_param(lcd_charset, int, 0000);
-MODULE_PARM_DESC(lcd_charset, "LCD character set: 0=standard, 1=KS0074");
-
-static int keypad_type = -1;
-module_param(keypad_type, int, 0000);
-MODULE_PARM_DESC(keypad_type,
- "Keypad type: 0=none, 1=old 6 keys, 2=new 6+1 keys, 3=nexcom 4 keys");
-
-static int profile = DEFAULT_PROFILE;
-module_param(profile, int, 0000);
-MODULE_PARM_DESC(profile,
- "1=16x2 old kp; 2=serial 16x2, new kp; 3=16x2 hantronix; "
- "4=16x2 nexcom; default=40x2, old kp");
-
/*
* These are the parallel port pins the LCD control signals are connected to.
* Set this to 0 if the signal is not used. Set it to its opposite value
@@ -506,20 +498,31 @@ module_param(lcd_rw_pin, int, 0000);
MODULE_PARM_DESC(lcd_rw_pin,
"# of the // port pin connected to LCD 'RW' signal, with polarity (-17..17)");
-static int lcd_bl_pin = PIN_NOT_SET;
-module_param(lcd_bl_pin, int, 0000);
-MODULE_PARM_DESC(lcd_bl_pin,
- "# of the // port pin connected to LCD backlight, with polarity (-17..17)");
+static int lcd_cl_pin = PIN_NOT_SET;
+module_param(lcd_cl_pin, int, 0000);
+MODULE_PARM_DESC(lcd_cl_pin,
+ "# of the // port pin connected to serial LCD 'SCL' signal, with polarity (-17..17)");
static int lcd_da_pin = PIN_NOT_SET;
module_param(lcd_da_pin, int, 0000);
MODULE_PARM_DESC(lcd_da_pin,
"# of the // port pin connected to serial LCD 'SDA' signal, with polarity (-17..17)");
-static int lcd_cl_pin = PIN_NOT_SET;
-module_param(lcd_cl_pin, int, 0000);
-MODULE_PARM_DESC(lcd_cl_pin,
- "# of the // port pin connected to serial LCD 'SCL' signal, with polarity (-17..17)");
+static int lcd_bl_pin = PIN_NOT_SET;
+module_param(lcd_bl_pin, int, 0000);
+MODULE_PARM_DESC(lcd_bl_pin,
+ "# of the // port pin connected to LCD backlight, with polarity (-17..17)");
+
+/* Deprecated module parameters - consider not using them anymore */
+
+static int lcd_enabled = -1;
+module_param(lcd_enabled, int, 0000);
+MODULE_PARM_DESC(lcd_enabled, "Deprecated option, use lcd_type instead");
+
+static int keypad_enabled = -1;
+module_param(keypad_enabled, int, 0000);
+MODULE_PARM_DESC(keypad_enabled, "Deprecated option, use keypad_type instead");
+
static const unsigned char *lcd_char_conv;
--
2.1.3
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 4/4] staging: panel: Use better names for two defined values
2014-11-12 1:08 [PATCH 0/4] staging: panel: Module parameters clean-up Mariusz Gorski
` (2 preceding siblings ...)
2014-11-12 1:08 ` [PATCH 3/4] staging: panel: Reorder module parameter declarations Mariusz Gorski
@ 2014-11-12 1:08 ` Mariusz Gorski
2014-11-12 5:29 ` [PATCH 0/4] staging: panel: Module parameters clean-up Willy Tarreau
4 siblings, 0 replies; 6+ messages in thread
From: Mariusz Gorski @ 2014-11-12 1:08 UTC (permalink / raw)
To: Greg Kroah-Hartman, Willy Tarreau; +Cc: devel, linux-kernel
Give DEFAULT_KEYPAD and DEFAULT_LCD defines better names,
so that their meaning is emphasized.
Signed-off-by: Mariusz Gorski <marius.gorski@gmail.com>
---
drivers/staging/panel/panel.c | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index 05b0d1e..c6eeddf 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -304,8 +304,8 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
*/
#define DEFAULT_PARPORT 0
#define DEFAULT_PROFILE PANEL_PROFILE_LARGE
-#define DEFAULT_KEYPAD KEYPAD_TYPE_OLD
-#define DEFAULT_LCD LCD_TYPE_OLD
+#define DEFAULT_KEYPAD_TYPE KEYPAD_TYPE_OLD
+#define DEFAULT_LCD_TYPE LCD_TYPE_OLD
#define DEFAULT_LCD_HEIGHT 2
#define DEFAULT_LCD_WIDTH 40
#define DEFAULT_LCD_BWIDTH 40
@@ -332,13 +332,13 @@ static unsigned char lcd_bits[LCD_PORTS][LCD_BITS][BIT_STATES];
#if DEFAULT_PROFILE == 0 /* custom */
#ifdef CONFIG_PANEL_KEYPAD
-#undef DEFAULT_KEYPAD
-#define DEFAULT_KEYPAD CONFIG_PANEL_KEYPAD
+#undef DEFAULT_KEYPAD_TYPE
+#define DEFAULT_KEYPAD_TYPE CONFIG_PANEL_KEYPAD
#endif
#ifdef CONFIG_PANEL_LCD
-#undef DEFAULT_LCD
-#define DEFAULT_LCD CONFIG_PANEL_LCD
+#undef DEFAULT_LCD_TYPE
+#define DEFAULT_LCD_TYPE CONFIG_PANEL_LCD
#endif
#ifdef CONFIG_PANEL_LCD_HEIGHT
@@ -2239,9 +2239,9 @@ static int panel_init(void)
case PANEL_PROFILE_CUSTOM:
/* custom profile */
if (keypad_type < 0)
- keypad_type = DEFAULT_KEYPAD;
+ keypad_type = DEFAULT_KEYPAD_TYPE;
if (lcd_type < 0)
- lcd_type = DEFAULT_LCD;
+ lcd_type = DEFAULT_LCD_TYPE;
break;
case PANEL_PROFILE_OLD:
/* 8 bits, 2*16, old keypad */
--
2.1.3
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 0/4] staging: panel: Module parameters clean-up
2014-11-12 1:08 [PATCH 0/4] staging: panel: Module parameters clean-up Mariusz Gorski
` (3 preceding siblings ...)
2014-11-12 1:08 ` [PATCH 4/4] staging: panel: Use better names for two defined values Mariusz Gorski
@ 2014-11-12 5:29 ` Willy Tarreau
4 siblings, 0 replies; 6+ messages in thread
From: Willy Tarreau @ 2014-11-12 5:29 UTC (permalink / raw)
To: Mariusz Gorski; +Cc: Greg Kroah-Hartman, devel, linux-kernel
On Wed, Nov 12, 2014 at 02:08:05AM +0100, Mariusz Gorski wrote:
> This small set of patches (although it also could be a single patch...)
> rearranges groups of defines, redefines and module parameter declarations,
> so that they always appear in the same order defined by Kconfig, which
> makes it more pleasant to read and understand. It's a preparation for
> a bigger clean-up of current init code.
>
> Mariusz Gorski (4):
> staging: panel: Reorder initial DEFAULT_* defines
> staging: panel: Reorder DEFAULT_* values redefines
> staging: panel: Reorder module parameter declarations
> staging: panel: Use better names for two defined values
Whole patchset Acked-By: Willy Tarreau <w@1wt.eu>
BTW Mariusz, please use this e-mail address instead of the meta-x.org
one in the future.
Thanks,
Willy
^ permalink raw reply [flat|nested] 6+ messages in thread
end of thread, other threads:[~2014-11-12 5:29 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-11-12 1:08 [PATCH 0/4] staging: panel: Module parameters clean-up Mariusz Gorski
2014-11-12 1:08 ` [PATCH 1/4] staging: panel: Reorder initial DEFAULT_* defines Mariusz Gorski
2014-11-12 1:08 ` [PATCH 2/4] staging: panel: Reorder DEFAULT_* values redefines Mariusz Gorski
2014-11-12 1:08 ` [PATCH 3/4] staging: panel: Reorder module parameter declarations Mariusz Gorski
2014-11-12 1:08 ` [PATCH 4/4] staging: panel: Use better names for two defined values Mariusz Gorski
2014-11-12 5:29 ` [PATCH 0/4] staging: panel: Module parameters clean-up Willy Tarreau
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®