From: Jiri Olsa <jolsa@redhat.com>
To: "Liang, Kan" <kan.liang@intel.com>
Cc: "a.p.zijlstra@chello.nl" <a.p.zijlstra@chello.nl>,
"acme@kernel.org" <acme@kernel.org>,
"luto@kernel.org" <luto@kernel.org>,
"mingo@redhat.com" <mingo@redhat.com>,
"eranian@google.com" <eranian@google.com>,
"ak@linux.intel.com" <ak@linux.intel.com>,
"mark.rutland@arm.com" <mark.rutland@arm.com>,
"Hunter, Adrian" <adrian.hunter@intel.com>,
"jolsa@kernel.org" <jolsa@kernel.org>,
"namhyung@kernel.org" <namhyung@kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH V2 5/6] perf,tools: caculate and save freq/CPU%/CORE_BUSY% in he_stat
Date: Mon, 27 Jul 2015 19:16:18 +0200 [thread overview]
Message-ID: <20150727171618.GB20509@krava.brq.redhat.com> (raw)
In-Reply-To: <37D7C6CF3E00A74B8858931C1DB2F077018CCDD2@SHSMSX103.ccr.corp.intel.com>
On Mon, Jul 27, 2015 at 05:11:13PM +0000, Liang, Kan wrote:
> >
> > On Fri, Jul 24, 2015 at 09:48:31AM -0400, kan.liang@intel.com wrote:
> >
> > SNIP
> >
> > > struct addr_location *al,
> > > @@ -109,6 +110,7 @@ struct hist_entry *__hists__add_entry(struct
> > hists *hists,
> > > struct branch_info *bi,
> > > struct mem_info *mi, u64 period,
> > > u64 weight, u64 transaction,
> > > + struct freq_perf_info *freq_perf,
> > > bool sample_self);
> > > int hist_entry_iter__add(struct hist_entry_iter *iter, struct
> > addr_location *al,
> > > int max_stack_depth, void *arg);
> > > diff --git a/tools/perf/util/sort.h b/tools/perf/util/sort.h index
> > > e97cd47..90422ed 100644
> > > --- a/tools/perf/util/sort.h
> > > +++ b/tools/perf/util/sort.h
> > > @@ -54,6 +54,9 @@ struct he_stat {
> > > u64 period_guest_us;
> > > u64 weight;
> > > u32 nr_events;
> > > + u64 freq;
> > > + u64 cpu_u;
> >
> > could the cpu_u have more descriptive name?
>
> How about "cpu_util" or "cpu_utilization"?
cpu_util sounds good to me
thanks,
jirka
next prev parent reply other threads:[~2015-07-27 17:22 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-07-24 13:48 [PATCH V2 0/6] Freq/CPU%/CORE_BUSY% support kan.liang
2015-07-24 13:48 ` [PATCH V2 1/6] perf,tools: save cpu max freq in perf header kan.liang
2015-07-26 16:31 ` Jiri Olsa
2015-07-26 16:32 ` Jiri Olsa
2015-07-24 13:48 ` [PATCH V2 2/6] perf,tools: read cpu max freq and msr type from header kan.liang
2015-07-24 13:48 ` [PATCH V2 3/6] perf,tools: Dump per-sample freq/CPU%/CORE_BUSY% in report -D kan.liang
2015-07-26 16:31 ` Jiri Olsa
2015-07-24 13:48 ` [PATCH V2 4/6] perf,tools: save misc sample read value in struct perf_sample kan.liang
2015-07-26 16:31 ` Jiri Olsa
2015-07-27 22:24 ` Liang, Kan
2015-07-28 13:55 ` Jiri Olsa
2015-07-24 13:48 ` [PATCH V2 5/6] perf,tools: caculate and save freq/CPU%/CORE_BUSY% in he_stat kan.liang
2015-07-26 16:31 ` Jiri Olsa
2015-07-27 17:19 ` Liang, Kan
2015-07-27 17:27 ` Jiri Olsa
2015-07-27 22:34 ` Liang, Kan
2015-07-28 13:50 ` Jiri Olsa
2015-07-26 16:31 ` Jiri Olsa
2015-07-27 17:11 ` Liang, Kan
2015-07-27 17:16 ` Jiri Olsa [this message]
2015-07-24 13:48 ` [PATCH V2 6/6] perf,tools: Show freq/CPU%/CORE_BUSY% in perf report --stdio kan.liang
2015-07-26 16:32 ` Jiri Olsa
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150727171618.GB20509@krava.brq.redhat.com \
--to=jolsa@redhat.com \
--cc=a.p.zijlstra@chello.nl \
--cc=acme@kernel.org \
--cc=adrian.hunter@intel.com \
--cc=ak@linux.intel.com \
--cc=eranian@google.com \
--cc=jolsa@kernel.org \
--cc=kan.liang@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@kernel.org \
--cc=mark.rutland@arm.com \
--cc=mingo@redhat.com \
--cc=namhyung@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®