From: Ingo Molnar <mingo@kernel.org>
To: Dave Hansen <dave@sr71.net>
Cc: dave.hansen@linux.intel.com, mingo@redhat.com, x86@kernel.org,
bp@alien8.de, fenghua.yu@intel.com, tim.c.chen@linux.intel.com,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 05/11] x86, fpu: add helper xfeature_nr_enabled() instead of test_bit()
Date: Fri, 28 Aug 2015 07:04:57 +0200 [thread overview]
Message-ID: <20150828050457.GD25556@gmail.com> (raw)
In-Reply-To: <20150827171107.219DA1AA@viggo.jf.intel.com>
* Dave Hansen <dave@sr71.net> wrote:
>
> From: Dave Hansen <dave.hansen@linux.intel.com>
>
> We currently use test_bit() in a few places to see if an xfeature
> is enabled. It ends up being a bit ugly because 'xfeatures_mask'
> is a u64 and test_bit wants an 'unsigned long' so it requires a
> cast. The *_bit() functions are also techincally atomic, which
> we have no need for here.
>
> So, remove the test_bit()s and replace with the new
> xfeature_nr_enabled() helper.
Small nit: please name it xfeature_enabled(), as it's shorter and already pretty
unambiguous.
Thanks,
Ingo
next prev parent reply other threads:[~2015-08-28 5:05 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-08-27 17:11 [PATCH 00/11] [v2] x86, fpu: XSAVE cleanups and sanity checks Dave Hansen
2015-08-27 17:11 ` [PATCH 01/11] x86, fpu: kill LWP support Dave Hansen
2015-08-28 4:50 ` Ingo Molnar
2015-08-27 17:11 ` [PATCH 03/11] x86, fpu: rework XSTATE_* macros to remove magic '2' Dave Hansen
2015-08-27 17:11 ` [PATCH 02/11] x86, fpu: rename xfeature_bit Dave Hansen
2015-08-28 5:16 ` Ingo Molnar
2015-08-27 17:11 ` [PATCH 04/11] x86, fpu: remove xfeature_nr Dave Hansen
2015-08-28 5:06 ` Ingo Molnar
2015-08-27 17:11 ` [PATCH 05/11] x86, fpu: add helper xfeature_nr_enabled() instead of test_bit() Dave Hansen
2015-08-28 5:04 ` Ingo Molnar [this message]
2015-08-27 17:11 ` [PATCH 06/11] x86, fpu: rework MPX 'xstate' types Dave Hansen
2015-08-27 17:11 ` [PATCH 07/11] x86, fpu: rework YMM definition Dave Hansen
2015-08-27 17:11 ` [PATCH 10/11] x86, fpu: check to ensure increasing-offset xstate offsets Dave Hansen
2015-08-27 17:11 ` [PATCH 09/11] x86, fpu: correct and check XSAVE xstate size calculations Dave Hansen
2015-08-28 4:54 ` Ingo Molnar
2015-08-28 14:31 ` Dave Hansen
2015-08-28 16:44 ` Andi Kleen
2015-08-27 17:11 ` [PATCH 08/11] x86, fpu: add C structures for AVX-512 state components Dave Hansen
2015-08-28 5:00 ` Ingo Molnar
2015-08-27 17:11 ` [PATCH 11/11] x86, fpu: check CPU-provided sizes against struct declarations Dave Hansen
2015-08-28 5:25 ` Ingo Molnar
2015-08-28 16:02 ` Dave Hansen
2015-08-28 5:18 ` [PATCH 00/11] [v2] x86, fpu: XSAVE cleanups and sanity checks Ingo Molnar
-- strict thread matches above, loose matches on Subject: below --
2015-08-25 20:12 [PATCH 00/11] " Dave Hansen
2015-08-25 20:12 ` [PATCH 05/11] x86, fpu: add helper xfeature_nr_enabled() instead of test_bit() Dave Hansen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150828050457.GD25556@gmail.com \
--to=mingo@kernel.org \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=dave@sr71.net \
--cc=fenghua.yu@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=tim.c.chen@linux.intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome