mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] drm: drm_atomic_crtc_get_property should be static
@ 2015-09-24 10:01 Geliang Tang
  2015-09-24 15:16 ` Daniel Vetter
  0 siblings, 1 reply; 2+ messages in thread
From: Geliang Tang @ 2015-09-24 10:01 UTC (permalink / raw)
  To: David Airlie; +Cc: Geliang Tang, dri-devel, linux-kernel

Fixes the following sparse warning:
 drivers/gpu/drm/drm_atomic.c:442:5: warning: symbol
 'drm_atomic_crtc_get_property' was not declared. Should it be static?

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 drivers/gpu/drm/drm_atomic.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/drm_atomic.c b/drivers/gpu/drm/drm_atomic.c
index 940f80b..7bb3845 100644
--- a/drivers/gpu/drm/drm_atomic.c
+++ b/drivers/gpu/drm/drm_atomic.c
@@ -438,7 +438,8 @@ EXPORT_SYMBOL(drm_atomic_crtc_set_property);
  * consistent behavior you must call this function rather than the
  * driver hook directly.
  */
-int drm_atomic_crtc_get_property(struct drm_crtc *crtc,
+static int
+drm_atomic_crtc_get_property(struct drm_crtc *crtc,
 		const struct drm_crtc_state *state,
 		struct drm_property *property, uint64_t *val)
 {
-- 
1.9.1



^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] drm: drm_atomic_crtc_get_property should be static
  2015-09-24 10:01 [PATCH] drm: drm_atomic_crtc_get_property should be static Geliang Tang
@ 2015-09-24 15:16 ` Daniel Vetter
  0 siblings, 0 replies; 2+ messages in thread
From: Daniel Vetter @ 2015-09-24 15:16 UTC (permalink / raw)
  To: Geliang Tang; +Cc: David Airlie, linux-kernel, dri-devel

On Thu, Sep 24, 2015 at 03:01:03AM -0700, Geliang Tang wrote:
> Fixes the following sparse warning:
>  drivers/gpu/drm/drm_atomic.c:442:5: warning: symbol
>  'drm_atomic_crtc_get_property' was not declared. Should it be static?
> 
> Signed-off-by: Geliang Tang <geliangtang@163.com>

Applied to drm-misc, thansk.
-Daniel

> ---
>  drivers/gpu/drm/drm_atomic.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/drm_atomic.c b/drivers/gpu/drm/drm_atomic.c
> index 940f80b..7bb3845 100644
> --- a/drivers/gpu/drm/drm_atomic.c
> +++ b/drivers/gpu/drm/drm_atomic.c
> @@ -438,7 +438,8 @@ EXPORT_SYMBOL(drm_atomic_crtc_set_property);
>   * consistent behavior you must call this function rather than the
>   * driver hook directly.
>   */
> -int drm_atomic_crtc_get_property(struct drm_crtc *crtc,
> +static int
> +drm_atomic_crtc_get_property(struct drm_crtc *crtc,
>  		const struct drm_crtc_state *state,
>  		struct drm_property *property, uint64_t *val)
>  {
> -- 
> 1.9.1
> 
> 
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2015-09-24 15:13 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-09-24 10:01 [PATCH] drm: drm_atomic_crtc_get_property should be static Geliang Tang
2015-09-24 15:16 ` Daniel Vetter

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®