From: Steven Rostedt <rostedt@goodmis.org>
To: linux-kernel@vger.kernel.org
Cc: Ingo Molnar <mingo@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>
Subject: [for-next][PATCH 01/30] tracing: Rename check_ignore_pid() to ignore_this_task()
Date: Wed, 20 Apr 2016 15:29:39 -0400 [thread overview]
Message-ID: <20160420193026.047100637@goodmis.org> (raw)
In-Reply-To: <20160420192938.515326341@goodmis.org>
[-- Attachment #1: 0001-tracing-Rename-check_ignore_pid-to-ignore_this_task.patch --]
[-- Type: text/plain, Size: 2576 bytes --]
From: Steven Rostedt <rostedt@goodmis.org>
The name "check_ignore_pid" is confusing in trying to figure out if the pid
should be ignored or not. Rename it to "ignore_this_task" which is pretty
straight forward, as a task (not a pid) is passed in, and should if true
should be ignored.
Signed-off-by: Steven Rostedt <rostedt@goodmis.org>
---
kernel/trace/trace_events.c | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/kernel/trace/trace_events.c b/kernel/trace/trace_events.c
index 05ddc0820771..598a18675a6b 100644
--- a/kernel/trace/trace_events.c
+++ b/kernel/trace/trace_events.c
@@ -484,7 +484,7 @@ static int cmp_pid(const void *key, const void *elt)
}
static bool
-check_ignore_pid(struct trace_pid_list *filtered_pids, struct task_struct *task)
+ignore_this_task(struct trace_pid_list *filtered_pids, struct task_struct *task)
{
pid_t search_pid;
pid_t *pid;
@@ -517,8 +517,8 @@ event_filter_pid_sched_switch_probe_pre(void *data, bool preempt,
pid_list = rcu_dereference_sched(tr->filtered_pids);
this_cpu_write(tr->trace_buffer.data->ignore_pid,
- check_ignore_pid(pid_list, prev) &&
- check_ignore_pid(pid_list, next));
+ ignore_this_task(pid_list, prev) &&
+ ignore_this_task(pid_list, next));
}
static void
@@ -531,7 +531,7 @@ event_filter_pid_sched_switch_probe_post(void *data, bool preempt,
pid_list = rcu_dereference_sched(tr->filtered_pids);
this_cpu_write(tr->trace_buffer.data->ignore_pid,
- check_ignore_pid(pid_list, next));
+ ignore_this_task(pid_list, next));
}
static void
@@ -547,7 +547,7 @@ event_filter_pid_sched_wakeup_probe_pre(void *data, struct task_struct *task)
pid_list = rcu_dereference_sched(tr->filtered_pids);
this_cpu_write(tr->trace_buffer.data->ignore_pid,
- check_ignore_pid(pid_list, task));
+ ignore_this_task(pid_list, task));
}
static void
@@ -564,7 +564,7 @@ event_filter_pid_sched_wakeup_probe_post(void *data, struct task_struct *task)
/* Set tracing if current is enabled */
this_cpu_write(tr->trace_buffer.data->ignore_pid,
- check_ignore_pid(pid_list, current));
+ ignore_this_task(pid_list, current));
}
static void __ftrace_clear_event_pids(struct trace_array *tr)
@@ -1561,7 +1561,7 @@ static void ignore_task_cpu(void *data)
mutex_is_locked(&event_mutex));
this_cpu_write(tr->trace_buffer.data->ignore_pid,
- check_ignore_pid(pid_list, current));
+ ignore_this_task(pid_list, current));
}
static ssize_t
--
2.8.0.rc3
next prev parent reply other threads:[~2016-04-20 19:30 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-04-20 19:29 [for-next][PATCH 00/30] tracing: Add features for event-fork and histograms Steven Rostedt
2016-04-20 19:29 ` Steven Rostedt [this message]
2016-04-20 19:29 ` [for-next][PATCH 02/30] tracing: Use pid bitmap instead of a pid array for set_event_pid Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 03/30] tracing: Add infrastructure to allow set_event_pid to follow children Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 04/30] tracing: Update the documentation to describe "event-fork" option Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 05/30] tracing: Add lock-free tracing_map Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 06/30] tracing: Fix TRACING_MAP Kconfig Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 07/30] tracing: Update some tracing_map constants and comments Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 08/30] tracing: Add hist event trigger command Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 09/30] tracing: Add hist trigger support for multiple values (vals= param) Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 10/30] tracing: Add hist trigger support for compound keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 11/30] tracing: Add hist trigger support for user-defined sorting (sort= param) Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 12/30] tracing: Add hist trigger support for pausing and continuing a trace Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 13/30] tracing: Add hist trigger support for clearing " Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 14/30] tracing: Add hist trigger hex modifier for displaying numeric fields Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 15/30] tracing: Add hist trigger sym and sym-offset modifiers Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 16/30] tracing: Add hist trigger execname modifier Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 17/30] tracing: Add hist trigger syscall modifier Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 18/30] tracing: Add hist trigger support for stacktraces as keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 19/30] tracing: Support string type key properly Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 20/30] tracing: Remove restriction on string position in hist trigger keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 21/30] tracing: Add enable_hist/disable_hist triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 22/30] tracing: Add hist trigger Documentation Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 23/30] tracing: Add support for multiple hist triggers per event Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 24/30] tracing: Add support for named triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 25/30] tracing: Add support for named hist triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 26/30] kselftests/ftrace : Add event trigger testcases Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 27/30] kselftests/ftrace: Add hist " Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 28/30] tracing: Add hist trigger log2 modifier Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 29/30] kselftests/ftrace: Add a test for log2 modifier of hist trigger Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 30/30] tracing: Fix unsigned comparison to zero in hist trigger code Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160420193026.047100637@goodmis.org \
--to=rostedt@goodmis.org \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome