mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: linux-kernel@vger.kernel.org
Cc: Ingo Molnar <mingo@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Tom Zanussi <tom.zanussi@linux.intel.com>
Subject: [for-next][PATCH 07/30] tracing: Update some tracing_map constants and comments
Date: Wed, 20 Apr 2016 15:29:45 -0400	[thread overview]
Message-ID: <20160420193027.122044274@goodmis.org> (raw)
In-Reply-To: <20160420192938.515326341@goodmis.org>

[-- Attachment #1: 0007-tracing-Update-some-tracing_map-constants-and-commen.patch --]
[-- Type: text/plain, Size: 2142 bytes --]

From: Tom Zanussi <tom.zanussi@linux.intel.com>

Make it clear exactly how many keys and values are supported through
better defines, and add 1 to the vals count, since normally clients
want support for at least a hitcount and two other values.

Also, note the error return value for tracing_map_add_key/val_field()
in the comments.

Link: http://lkml.kernel.org/r/6696fa02ebc716aa344c27a571a2afaa25e5b4d4.1457029949.git.tom.zanussi@linux.intel.com

Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Signed-off-by: Steven Rostedt <rostedt@goodmis.org>
---
 kernel/trace/tracing_map.c | 4 ++--
 kernel/trace/tracing_map.h | 5 +++--
 2 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/kernel/trace/tracing_map.c b/kernel/trace/tracing_map.c
index dd6401dd145e..e0f172932eca 100644
--- a/kernel/trace/tracing_map.c
+++ b/kernel/trace/tracing_map.c
@@ -163,7 +163,7 @@ static int tracing_map_add_field(struct tracing_map *map,
  * tracing_map_update_sum() or reading it via tracing_map_read_sum().
  *
  * Return: The index identifying the field in the map and associated
- * tracing_map_elts.
+ * tracing_map_elts, or -EINVAL on error.
  */
 int tracing_map_add_sum_field(struct tracing_map *map)
 {
@@ -184,7 +184,7 @@ int tracing_map_add_sum_field(struct tracing_map *map)
  * the key referenced by this key field resides.
  *
  * Return: The index identifying the field in the map and associated
- * tracing_map_elts.
+ * tracing_map_elts, or -EINVAL on error.
  */
 int tracing_map_add_key_field(struct tracing_map *map,
 			      unsigned int offset,
diff --git a/kernel/trace/tracing_map.h b/kernel/trace/tracing_map.h
index 1f7eda548787..618838f5f30a 100644
--- a/kernel/trace/tracing_map.h
+++ b/kernel/trace/tracing_map.h
@@ -5,9 +5,10 @@
 #define TRACING_MAP_BITS_MAX		17
 #define TRACING_MAP_BITS_MIN		7
 
-#define TRACING_MAP_FIELDS_MAX		4
 #define TRACING_MAP_KEYS_MAX		2
-
+#define TRACING_MAP_VALS_MAX		3
+#define TRACING_MAP_FIELDS_MAX		(TRACING_MAP_KEYS_MAX + \
+					 TRACING_MAP_VALS_MAX)
 #define TRACING_MAP_SORT_KEYS_MAX	2
 
 typedef int (*tracing_map_cmp_fn_t) (void *val_a, void *val_b);
-- 
2.8.0.rc3

  parent reply	other threads:[~2016-04-20 19:30 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-20 19:29 [for-next][PATCH 00/30] tracing: Add features for event-fork and histograms Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 01/30] tracing: Rename check_ignore_pid() to ignore_this_task() Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 02/30] tracing: Use pid bitmap instead of a pid array for set_event_pid Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 03/30] tracing: Add infrastructure to allow set_event_pid to follow children Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 04/30] tracing: Update the documentation to describe "event-fork" option Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 05/30] tracing: Add lock-free tracing_map Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 06/30] tracing: Fix TRACING_MAP Kconfig Steven Rostedt
2016-04-20 19:29 ` Steven Rostedt [this message]
2016-04-20 19:29 ` [for-next][PATCH 08/30] tracing: Add hist event trigger command Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 09/30] tracing: Add hist trigger support for multiple values (vals= param) Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 10/30] tracing: Add hist trigger support for compound keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 11/30] tracing: Add hist trigger support for user-defined sorting (sort= param) Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 12/30] tracing: Add hist trigger support for pausing and continuing a trace Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 13/30] tracing: Add hist trigger support for clearing " Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 14/30] tracing: Add hist trigger hex modifier for displaying numeric fields Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 15/30] tracing: Add hist trigger sym and sym-offset modifiers Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 16/30] tracing: Add hist trigger execname modifier Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 17/30] tracing: Add hist trigger syscall modifier Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 18/30] tracing: Add hist trigger support for stacktraces as keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 19/30] tracing: Support string type key properly Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 20/30] tracing: Remove restriction on string position in hist trigger keys Steven Rostedt
2016-04-20 19:29 ` [for-next][PATCH 21/30] tracing: Add enable_hist/disable_hist triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 22/30] tracing: Add hist trigger Documentation Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 23/30] tracing: Add support for multiple hist triggers per event Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 24/30] tracing: Add support for named triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 25/30] tracing: Add support for named hist triggers Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 26/30] kselftests/ftrace : Add event trigger testcases Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 27/30] kselftests/ftrace: Add hist " Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 28/30] tracing: Add hist trigger log2 modifier Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 29/30] kselftests/ftrace: Add a test for log2 modifier of hist trigger Steven Rostedt
2016-04-20 19:30 ` [for-next][PATCH 30/30] tracing: Fix unsigned comparison to zero in hist trigger code Steven Rostedt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160420193027.122044274@goodmis.org \
    --to=rostedt@goodmis.org \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=tom.zanussi@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome